Announcement

Collapse
No announcement yet.

VR IK Body - Support

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • replied
    Originally posted by Emil17x3 View Post
    Been wondering, if it is possible to let the hands stop before colliding with smth (like in boneworks for instance)
    Thanks in advance
    Not by the plugin. But you can apply physics on top of animation.

    Leave a comment:


  • replied
    Been wondering, if it is possible to let the hands stop before colliding with smth (like in boneworks for instance)
    Thanks in advance

    Leave a comment:


  • replied
    Originally posted by FinalZer0 View Post
    Yi yuri, I have problem when moving character with this plugin. Its causes twitches to character mesh in multiplayer mode. Have you experienced something like that?
    Wasn't it fixed with lastest update?

    Leave a comment:


  • replied
    Originally posted by paranormalpants View Post
    Our main issue is that the calibration process appears to put our VR headset at mouth height (right near the end of the standard head bone), no matter what settings we play with for offsets and head sizes / heights. We're using Oculus Rift S headsets, and have reset the left and right palm offsets, as suggested. This still doesn't appear to line the controllers up with the hands correctly, but we feel that we can tweak these settings to get close enough once the camera is properly oriented to the eye-height of our character.

    Do you have a recommendation for getting this calibration as close as possible, especially for Rift S headsets?

    Our second issue (potentially related to the first) is that the character is floating a few centimeters off the ground after calibration, even though the physics collider lines up pretty much exactly with the bottom of the feet. The distance off the ground appears to be roughly the same as the difference between the mouth (where our VR headset appears to be locked) and the eyes (where we'd like it to be).

    Finally, do you have recommendations to smooth out twitchy rendering of the player avatar? It seems to flicker in and out of existence at a random framerate...as if there is some mismatch between the last stored value of the VR hardware and the current frame which is rendering.

    We are working with a character model from Character Creator 3, exported for compatibility with the Unreal skeleton naming conventions. This is all working at a basic level, but we'll need to dial in these last bits in order to use this in our commercial project. It feels close, but we can't seem to get a properly calibrated avatar out of this.

    Thanks for your help!
    Hi,
    1. Have you tried "Calibration Height Adjustment" is properties of VRIKBody component ("Body Params" rollout)?
    2. VRIKBody also has "Foot Offset to Ground" settings. It should work.
    3. I didn't notice such flickering. Could you capture a video?

    Leave a comment:


  • replied
    Originally posted by benbr_ View Post
    Hi, I have set everything up as the tutorial showed but for some reason the player mesh shrinks to a tiny size and floats near the camera, any idea what went wrong?
    It's better to use demo project as a start point (it includes both Pawn and Character-based blueprints), as tutorial video is outdated. By default, the plugin takes actor location as a base point to calculate player height. But it doesn't work for Characters. You need to use "Input from Components" mode and set RootComp.

    Leave a comment:


  • replied
    benbr_
    paranormalpants
    FinalZer0
    I don't follow this topic and don't receive notifications. For quick response, please contact via e-mail (ykasczc@gmail.com) or marketplace form.
    Last edited by YuriNK; 02-04-2020, 07:59 AM.

    Leave a comment:


  • replied
    Alright, Setting the VROrigin as Root Comp in Activate Input fixed the problem

    Leave a comment:


  • replied
    Yi yuri, I have problem when moving character with this plugin. Its causes twitches to character mesh in multiplayer mode. Have you experienced something like that?

    Leave a comment:


  • replied
    So I was forced to move the VR Origin point down by around -90 and now my mesh is floating over the character (like the head and hands are following the hmd and motion controllers, but everything is floating those 90 points over the position, of where the actual controllers and hmd are). Is there a Slider or smth to adjust that? Thanks

    Leave a comment:


  • replied
    Originally posted by Rareden View Post

    Hi, ended up shutting down the system momentarily if anything needs to be done to it or calling the hide bone before any of the animation stuff is initialized which works out fine.
    benbr_ common issues ive seen with this are bone scale inconsistencys, usually with our users, if they export a character from blender it has issues with the scale differences between ue4 and blender. check your root and hip bone scales, they will need to be 1.0.
    I'll look into that, thanks a lot

    Leave a comment:


  • replied
    Originally posted by YuriNK View Post

    Hi,

    Bug fix isn't ready yet. For now, you can use a workaround. Instead of "Hide Bone by Name" you can hide head by applying zero scale in animation blueprint in "Transform (Modify) Bone" node.
    Hi, ended up shutting down the system momentarily if anything needs to be done to it or calling the hide bone before any of the animation stuff is initialized which works out fine.
    benbr_ common issues ive seen with this are bone scale inconsistencys, usually with our users, if they export a character from blender it has issues with the scale differences between ue4 and blender. check your root and hip bone scales, they will need to be 1.0.
    Last edited by Rareden; 01-26-2020, 08:00 AM.

    Leave a comment:


  • replied
    Hi, we're having a couple of issues that we need to solve for a project. The plugin overall is working well, and thanks for all of your work on this!

    Our main issue is that the calibration process appears to put our VR headset at mouth height (right near the end of the standard head bone), no matter what settings we play with for offsets and head sizes / heights. We're using Oculus Rift S headsets, and have reset the left and right palm offsets, as suggested. This still doesn't appear to line the controllers up with the hands correctly, but we feel that we can tweak these settings to get close enough once the camera is properly oriented to the eye-height of our character.

    Do you have a recommendation for getting this calibration as close as possible, especially for Rift S headsets?

    Our second issue (potentially related to the first) is that the character is floating a few centimeters off the ground after calibration, even though the physics collider lines up pretty much exactly with the bottom of the feet. The distance off the ground appears to be roughly the same as the difference between the mouth (where our VR headset appears to be locked) and the eyes (where we'd like it to be).

    Finally, do you have recommendations to smooth out twitchy rendering of the player avatar? It seems to flicker in and out of existence at a random framerate...as if there is some mismatch between the last stored value of the VR hardware and the current frame which is rendering.

    We are working with a character model from Character Creator 3, exported for compatibility with the Unreal skeleton naming conventions. This is all working at a basic level, but we'll need to dial in these last bits in order to use this in our commercial project. It feels close, but we can't seem to get a properly calibrated avatar out of this.

    Thanks for your help!

    Leave a comment:


  • replied
    Any ideas? I spent £78 on this plugin and can't get it to work...

    Leave a comment:


  • replied
    Hi, I have set everything up as the tutorial showed but for some reason the player mesh shrinks to a tiny size and floats near the camera, any idea what went wrong?

    Leave a comment:


  • replied
    Originally posted by YuriNK
    Hi,
    I'm pllanning update in a few days and will add this feature.

    But you can do it manually in animation blueprint, of course, using TwoBoneIK and line tracing.
    Heyo,

    I see the Plugin was updated. Were you able to add the feature to keep the feet planted and stationary? If so, how do I implement it?
    Been trying to get that manual line trace with two-bone IK to work, but can't seem to wrench control of the Pelvis from VR IK Body.
    Thanks for looking into this. Will be a big help.

    Leave a comment:

Working...
X