Announcement

Collapse
No announcement yet.

VR IK Body - Support

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • replied
    Originally posted by VictorBurgos View Post
    Have you tried to do Snap or Smooth Turning? Basically rotating the character? Seems there are some issues with the "correct facing orientation" (so says our animator)

    The request from him: "Is there a way to rotate the root based on the body rotation (i.e) capsule and not the head?"

    At the very least so Snap/Smooth Turning will work out of the box with your plugin?
    Just checked it. Yes, smooth rotation of the owning actor affects torso orientation. Please write me on e-mail if you need hot update (I usually update marketplace version only after 3-5 fixes).

    Leave a comment:


  • replied
    Have you tried to do Snap or Smooth Turning? Basically rotating the character? Seems there are some issues with the "correct facing orientation" (so says our animator)

    The request from him: "Is there a way to rotate the root based on the body rotation (i.e) capsule and not the head?"

    At the very least so Snap/Smooth Turning will work out of the box with your plugin?

    Thanks

    Also, Multiplayer Tutorial You have the calibration going to PlayerState, but for what possible reason?

    Leave a comment:


  • replied
    Originally posted by Evolution Of War View Post
    Hello!
    I'm trying to Mimic VR Chat's teleport method in Unreal with VRIK. I am using a Pawn that has working teleport, using Deactivate VRIK Input so that when pressing down on thumbpad, the mesh will stop following the player's actions. At this point, I want the body to move to the teleport location. I tried using AI Move To and a Move Function, but couldn't get this to work in 4.19. Is this something to do with VRIK or 4.19 or am I doing something wrong?
    Thanks!

    For Reference: https://youtu.be/NMHqb5CWeMQ?t=1m12s this is what I am trying to mimic.
    Should help:

    Leave a comment:


  • replied
    Originally posted by Evolution Of War View Post
    Hello!
    I'm trying to Mimic VR Chat's teleport method in Unreal with VRIK. I am using a Pawn that has working teleport, using Deactivate VRIK Input so that when pressing down on thumbpad, the mesh will stop following the player's actions. At this point, I want the body to move to the teleport location. I tried using AI Move To and a Move Function, but couldn't get this to work in 4.19. Is this something to do with VRIK or 4.19 or am I doing something wrong?
    Thanks!
    For Reference: https://youtu.be/NMHqb5CWeMQ?t=1m12s this is what I am trying to mimic.
    I think you need a proper switch between two modes in the animation blueprint. Add state machine for basic locomotion and use Blend Poses By Bool. Also, when you start 'teleporting' return skeletal mesh to its default position inside of the CapsuleComponent.

    Leave a comment:


  • replied
    Hello!
    I'm trying to Mimic VR Chat's teleport method in Unreal with VRIK. I am using a Pawn that has working teleport, using Deactivate VRIK Input so that when pressing down on thumbpad, the mesh will stop following the player's actions. At this point, I want the body to move to the teleport location. I tried using AI Move To and a Move Function, but couldn't get this to work in 4.19. Is this something to do with VRIK or 4.19 or am I doing something wrong?
    Thanks!

    For Reference: https://youtu.be/NMHqb5CWeMQ?t=1m12s this is what I am trying to mimic.

    Leave a comment:


  • replied
    Originally posted by VictorBurgos View Post
    Nevermind, figured it out on my own. I had to retarget the Animation BPs to the new skeletons. I don't have the docs in front of me. But you should probably put that in there. Also, should do another tutorial for the Multiplayer Setup Version which is different.
    Ok. I'm sorry, i'll make another tutorial for mulitplayer setup.

    Leave a comment:


  • replied
    Originally posted by VictorBurgos View Post
    What additional setup is required when doing a custom skeletal mesh in your template? Other than renaming the Skeleton Bones in VRIKSkeletalMeshTranslator.
    Bones names + new animation blueprint. All skeleon have different animation blueprints (but setup inside of each blueprint is the same).

    Leave a comment:


  • replied
    Nevermind, figured it out on my own. I had to retarget the Animation BPs to the new skeletons. I don't have the docs in front of me. But you should probably put that in there. Also, should do another tutorial for the Multiplayer Setup Version which is different.

    Leave a comment:


  • replied
    BTW, I am doing the Multiplayer Setup.

    Leave a comment:


  • replied
    Does your plugin take into Case Sensitivity on the Skeletons? If not, what else would cause a new skeleton to NOT work in your project? I literally just swapped out the skeletal mesh from your BP_Avatar and changed out some Skeletal Bone names in IK Skeletal Mesh Translator, but some are capitalized. What other setup would I need to do to get a character working in your template using your current logic?

    Basically the TL;DR: What additional setup is required when doing a custom skeletal mesh in your template? Other than renaming the Skeleton Bones in VRIKSkeletalMeshTranslator.

    The hands don't even move. It's basically a static sk mesh rotated 90 degrees, moves with me. But does nothing else.

    Leave a comment:


  • replied
    Originally posted by YuriNK View Post
    Have you tried basic demo project (https://drive.google.com/open?id=1KG...ovQzbfAbU1LI)? It's based at the tutorial. You can import your skeletal mesh in it and test how it works.

    Also, make sure that skeletal mesh component in you project is rotatetd in forward direction (X axis) of the actor. If you make a screenshots of your pawn blueprint and animation blueprint I think could detect the problem.
    Yeah, your example project works...but it's not the same setup as your tutorial. I'll try to drop a character in there and see what the issue is.

    Leave a comment:


  • replied
    Originally posted by VictorBurgos View Post
    Any chance you could update your tutorial? Seems outdated. Some of the nodes have changed. And I could not get my character up and running 100% with it. My character was at a 90 degree offset and the head/hands were not working at all (wouldn't move with components). Followed the tutorial, changed up Input from Components, because of the docs and also through this thread. Still no go. Tried out your example project...works like a charm...but the BP is completely different than your tutorial...
    Have you tried basic demo project (https://drive.google.com/open?id=1KG...ovQzbfAbU1LI)? It's based at the tutorial. You can import your skeletal mesh in it and test how it works.

    Also, make sure that skeletal mesh component in you project is rotatetd in forward direction (X axis) of the actor. If you make a screenshots of your pawn blueprint and animation blueprint I think could detect the problem.

    Leave a comment:


  • replied
    Any chance you could update your tutorial? Seems outdated. Some of the nodes have changed. And I could not get my character up and running 100% with it. My character was at a 90 degree offset and the head/hands were not working at all (wouldn't move with components). Followed the tutorial, changed up Input from Components, because of the docs and also through this thread. Still no go. Tried out your example project...works like a charm...but the BP is completely different than your tutorial...

    Leave a comment:


  • replied
    Next update will include some bug fixes, better support from Character-based player blueprints, better support for a rough irregular surface, support of crawling (in beta).

    + New simplified demo project (4.18+)
    + Sample of proper legs animation blending in the old demo project (4.18+)
    + New landscape demo map in the old demo project (4.18+)

    ---

    If you have any feature requests please let me know.

    Leave a comment:


  • replied
    Originally posted by Yummy-Vegetables View Post
    Iam getting a lot of errors in the log when I play or when I package the game, they repeat endlessly until they arms are configured. Any idea where they might be coming from, I assume a Tick event?
    LogVRIKSkeletalMeshTranslator: Error: [GetLastPose]: Component isn't ready.
    LogVRIKSkeletalMeshTranslator: Error: [GetLastPose]: Component isn't ready.
    LogVRIKSkeletalMeshTranslator: Error: [GetLastPose]: Component isn't ready.
    LogVRIKSkeletalMeshTranslator: Error: [GetLastPose]: Component isn't ready.
    It happens if LogVRIKSkeletalMeshTranslator::GetLastPose was called before mesh initialization (which happens every time). Just ignore it, I'll remove this message in the next update.

    Leave a comment:

Working...
X