Announcement

Collapse
No announcement yet.

VR IK Body - Support

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • replied
    Originally posted by khazum View Post
    Hello,
    Does your IK Rig package for Android?
    No, it's only for PC VR.

    Leave a comment:


  • replied
    Hello,
    Does your IK Rig package for Android?
    Thank you!
    - s

    Leave a comment:


  • replied
    Thanks, it worked.

    Leave a comment:


  • replied
    Yummy-Vegetables

    Originally posted by Yummy-Vegetables View Post
    When I test the game as a non cooked Standalone game by first creating a shortcut to the UE4Editor.exe and then supplying the command line arguments as per the following the calibration always fails however the calibration always works when I do it through PIE.

    Any ideas?
    Calibration works for me in both demo projects in standalone. The only idea is that it happens because of differences in level loading sequence. Try to add some small delay in BeginPlay before components initialization and between this initialization and loading calibrated data (if you use it).

    The plugin also shouldn't generate these errors anymore, so make sure you updated your version in the launcher (or write me a PM for the lastest version).

    Ed. Just checked again. You're right, calibration doesn't work without delay, so just add Delay node in BeginPlay for ~0.5ms before VRIKBody: :Initialize (or ActivateInput) and VRIKSkeletalMeshTranslator: :Initialize ). My second guess is that I need to set loading phase to PreDefault for the runtime module. Will fix it with the next update, but for now this small workaround with delay is needed.
    Last edited by YuriNK; 04-03-2018, 09:11 AM.

    Leave a comment:


  • replied
    When I test the game as a non cooked Standalone game by first creating a shortcut to the UE4Editor.exe and then supplying the command line arguments as per the following the calibration always fails however the calibration always works when I do it through PIE.

    Any ideas?

    To run as a non cooked standalone game:
    UE4Editor.exe [MyProject] [MyMap] -game

    The only errors in the log I can see are these which I understand are not relevant:

    2018.04.03-09.05.04:668][566]LogVRIKSkeletalMeshTranslator: Error: [GetLastPose]: Component isn't ready.
    [2018.04.03-09.05.04:679][567]LogVRIKSkeletalMeshTranslator: Error: [GetLastPose]: Component isn't ready.
    [2018.04.03-09.05.04:691][568]LogVRIKSkeletalMeshTranslator: Error: [GetLastPose]: Component isn't ready.
    [2018.04.03-09.05.04:701][569]LogVRIKSkeletalMeshTranslator: Error: [GetLastPose]: Component isn't ready.
    [2018.04.03-09.05.04:713][570]LogVRIKSkeletalMeshTranslator: Error: [GetLastPose]: Component isn't ready.
    Last edited by Yummy-Vegetables; 04-03-2018, 05:18 AM.

    Leave a comment:


  • replied
    Oops, misread it. I will shoot you an email. Thanks.
    Last edited by VictorBurgos; 03-30-2018, 11:18 PM.

    Leave a comment:


  • replied
    Originally posted by VictorBurgos View Post
    Have you tried to do Snap or Smooth Turning? Basically rotating the character? Seems there are some issues with the "correct facing orientation" (so says our animator)

    The request from him: "Is there a way to rotate the root based on the body rotation (i.e) capsule and not the head?"

    At the very least so Snap/Smooth Turning will work out of the box with your plugin?
    Just checked it. Yes, smooth rotation of the owning actor affects torso orientation. Please write me on e-mail if you need hot update (I usually update marketplace version only after 3-5 fixes).

    Leave a comment:


  • replied
    Have you tried to do Snap or Smooth Turning? Basically rotating the character? Seems there are some issues with the "correct facing orientation" (so says our animator)

    The request from him: "Is there a way to rotate the root based on the body rotation (i.e) capsule and not the head?"

    At the very least so Snap/Smooth Turning will work out of the box with your plugin?

    Thanks

    Also, Multiplayer Tutorial You have the calibration going to PlayerState, but for what possible reason?

    Leave a comment:


  • replied
    Originally posted by Evolution Of War View Post
    Hello!
    I'm trying to Mimic VR Chat's teleport method in Unreal with VRIK. I am using a Pawn that has working teleport, using Deactivate VRIK Input so that when pressing down on thumbpad, the mesh will stop following the player's actions. At this point, I want the body to move to the teleport location. I tried using AI Move To and a Move Function, but couldn't get this to work in 4.19. Is this something to do with VRIK or 4.19 or am I doing something wrong?
    Thanks!

    For Reference: https://youtu.be/NMHqb5CWeMQ?t=1m12s this is what I am trying to mimic.
    Should help:

    Leave a comment:


  • replied
    Originally posted by Evolution Of War View Post
    Hello!
    I'm trying to Mimic VR Chat's teleport method in Unreal with VRIK. I am using a Pawn that has working teleport, using Deactivate VRIK Input so that when pressing down on thumbpad, the mesh will stop following the player's actions. At this point, I want the body to move to the teleport location. I tried using AI Move To and a Move Function, but couldn't get this to work in 4.19. Is this something to do with VRIK or 4.19 or am I doing something wrong?
    Thanks!
    For Reference: https://youtu.be/NMHqb5CWeMQ?t=1m12s this is what I am trying to mimic.
    I think you need a proper switch between two modes in the animation blueprint. Add state machine for basic locomotion and use Blend Poses By Bool. Also, when you start 'teleporting' return skeletal mesh to its default position inside of the CapsuleComponent.

    Leave a comment:


  • replied
    Hello!
    I'm trying to Mimic VR Chat's teleport method in Unreal with VRIK. I am using a Pawn that has working teleport, using Deactivate VRIK Input so that when pressing down on thumbpad, the mesh will stop following the player's actions. At this point, I want the body to move to the teleport location. I tried using AI Move To and a Move Function, but couldn't get this to work in 4.19. Is this something to do with VRIK or 4.19 or am I doing something wrong?
    Thanks!

    For Reference: https://youtu.be/NMHqb5CWeMQ?t=1m12s this is what I am trying to mimic.

    Leave a comment:


  • replied
    Originally posted by VictorBurgos View Post
    Nevermind, figured it out on my own. I had to retarget the Animation BPs to the new skeletons. I don't have the docs in front of me. But you should probably put that in there. Also, should do another tutorial for the Multiplayer Setup Version which is different.
    Ok. I'm sorry, i'll make another tutorial for mulitplayer setup.

    Leave a comment:


  • replied
    Originally posted by VictorBurgos View Post
    What additional setup is required when doing a custom skeletal mesh in your template? Other than renaming the Skeleton Bones in VRIKSkeletalMeshTranslator.
    Bones names + new animation blueprint. All skeleon have different animation blueprints (but setup inside of each blueprint is the same).

    Leave a comment:


  • replied
    Nevermind, figured it out on my own. I had to retarget the Animation BPs to the new skeletons. I don't have the docs in front of me. But you should probably put that in there. Also, should do another tutorial for the Multiplayer Setup Version which is different.

    Leave a comment:


  • replied
    BTW, I am doing the Multiplayer Setup.

    Leave a comment:

Working...
X