Announcement

Collapse
No announcement yet.

Auto Settings - Game options and input binding toolkit

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Originally posted by Capn C4ke View Post
    My next question is, How do I change the look of the button? I can't find anything to change the look of it
    This is the recommended way of styling setting widgets: https://autosettings.readthedocs.io/en/latest/styling/
    [Game] Hyper Jam - Neon-soaked arena brawler
    [Plugin] Auto Settings - Game options and input binding toolkit
    [Plugin] [Free] Inline Styling Decorator - Allow inline styling on RichTextBlock

    Comment


      I got example project 1.13, running Unreal 4.25.1

      Everything worked great the first time i ran it, but when i stopped it and tried to run it again, it gives me this errors:




      In use pin Raw Value no longer exists on node Clamp Raw Value . Please refresh node or break links to remove pin.

      In use pin Return Value no longer exists on node Clamp Raw Value . Please refresh node or break links to remove pin.

      Could not find a function named "ClampRawValue" in 'StyledSliderSetting_C'.

      Make sure 'StyledSliderSetting_C' has been compiled for Clamp Raw Value

      In use pin Raw Value no longer exists on node Raw Value to Normalized . Please refresh node or break links to remove pin.

      In use pin Return Value no longer exists on node Raw Value to Normalized . Please refresh node or break links to remove pin.

      Could not find a function named "RawValueToNormalized" in 'StyledSliderSetting_C'.

      Make sure 'StyledSliderSetting_C' has been compiled for Raw Value to Normalized

      Click image for larger version

Name:	Capture.PNG
Views:	93
Size:	380.8 KB
ID:	1779977

      Comment


        Originally posted by ugmoe View Post
        I got example project 1.13, running Unreal 4.25.1

        Everything worked great the first time i ran it, but when i stopped it and tried to run it again, it gives me this errors:




        In use pin Raw Value no longer exists on node Clamp Raw Value . Please refresh node or break links to remove pin.

        In use pin Return Value no longer exists on node Clamp Raw Value . Please refresh node or break links to remove pin.

        Could not find a function named "ClampRawValue" in 'StyledSliderSetting_C'.

        Make sure 'StyledSliderSetting_C' has been compiled for Clamp Raw Value

        In use pin Raw Value no longer exists on node Raw Value to Normalized . Please refresh node or break links to remove pin.

        In use pin Return Value no longer exists on node Raw Value to Normalized . Please refresh node or break links to remove pin.

        Could not find a function named "RawValueToNormalized" in 'StyledSliderSetting_C'.

        Make sure 'StyledSliderSetting_C' has been compiled for Raw Value to Normalized

        Click image for larger version

Name:	Capture.PNG
Views:	93
Size:	380.8 KB
ID:	1779977
        Hi, can you tell me the plugin version in the Plugins window?
        [Game] Hyper Jam - Neon-soaked arena brawler
        [Plugin] Auto Settings - Game options and input binding toolkit
        [Plugin] [Free] Inline Styling Decorator - Allow inline styling on RichTextBlock

        Comment


          Originally posted by Sam Bonifacio View Post

          Hi, can you tell me the plugin version in the Plugins window?
          The plugin is Version 1.11

          I updated to the newest version and it works all good now, thanks!
          Last edited by ugmoe; 06-24-2020, 02:20 PM.

          Comment


            It works perfectly in the engine when playing and using, but when i got to package i get this error.

            UATHelper: Packaging (Windows (64-bit)): ERROR: Expecting to find a type to be declared in a module rules named 'AutoSettings' in UE4Rules, Version=0.0.0.0, Culture=neutral, PublicKeyToken=null. This type must derive from the 'ModuleRules' type defined by Unreal Build Tool.

            PackagingResults: Error: Expecting to find a type to be declared in a module rules named 'AutoSettings' in UE4Rules, Version=0.0.0.0, Culture=neutral, PublicKeyToken=null. This type must derive from the 'ModuleRules' type defined by Unreal Build Tool.

            Any ideas on how to fix this?

            Comment



              Originally posted by Dreamcastgamer View Post
              It works perfectly in the engine when playing and using, but when i got to package i get this error.

              UATHelper: Packaging (Windows (64-bit)): ERROR: Expecting to find a type to be declared in a module rules named 'AutoSettings' in UE4Rules, Version=0.0.0.0, Culture=neutral, PublicKeyToken=null. This type must derive from the 'ModuleRules' type defined by Unreal Build Tool.

              PackagingResults: Error: Expecting to find a type to be declared in a module rules named 'AutoSettings' in UE4Rules, Version=0.0.0.0, Culture=neutral, PublicKeyToken=null. This type must derive from the 'ModuleRules' type defined by Unreal Build Tool.

              Any ideas on how to fix this?

              ​​​​If you used 4.25.2 please read this https://www.reddit.com/r/unrealengin...m_medium=web2x , but released update 4.25.3 (i cant check) perhaps they fixed this error
              Last edited by ALM678mb; 07-29-2020, 09:06 AM.

              Comment

              Working...
              X