Announcement

Collapse
No announcement yet.

Blueprint Assist Plugin

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    What are the best settings to resolve auto-layouts that end up looking like this?



    I think I've asked for it before, but adding a rule that forces red nodes to align in columns and to give each other enough spacing to avoid overlap would complete this plugin.

    Alternately, an option to not adjust red nodes at all, no matter what, would be great.

    I've attached my current config.
    Attached Files
    Last edited by Antidamage; 10-22-2020, 09:31 PM.

    Comment


      Hi Antidamage, I do recall fixing an issue which caused results similar to your case when using the format-all command. Could you check if your plugin is up to date?

      Adding rule that forces red nodes to align in columns and to give each other enough spacing to avoid overlap would complete this plugin
      There is a new feature where format-all places will position nodes into columns. You can enable this by going to the Format All Style and setting it to Smart​​​​. This will estimate the columns based on the bounds of the node-tree, so drag the entire tree to move columns. I do not believe it will help for this specific case though.

      Alternately, an option to not adjust red nodes at all, no matter what, would be great
      By default, connected delegates are ignored but I notice you have the setting Treat delegates as execution pins enabled which may not be what you want.

      Let me know if the issue still occurs!
      Blueprint Assist Plugin: Mouse free blueprint creation and quality of life features
      Auto Size Comments Plugin (FREE): Auto resizing comment boxes

      Comment


        Originally posted by fpwong View Post
        Treat delegates as execution pins
        It's up to date and none of the suggestions made any visible difference (at all) aside from this one. That gave me the behaviour I want, so cheers!

        Comment


          I was fiddling with comment padding and trying to get it to format a graph properly. Earlier it was spacing everything apart by tens of thousands of pixels. None of the settings were unreasonably large, e.g. setting comment padding to 200px.

          Now most of the graph has been reformatted into infinity and it crashes if I try to fix it. Help! How do I reset the graph layout?

          The crash is:

          > Unhandled exception at 0x00007FF9F589998C (UE4Editor-SlateCore.dll) in UE4Editor.exe: 0xC00000FD: Stack overflow (parameters: 0x0000000000000001, 0x000000EC29A03FE0).

          > RenderBatch.AddVertex(FSlateVertex::Make<ESlateVertexRounding: Disabled>(RenderTransform, LastPointAdded[0] + AveragedUp, FVector2D(1.0f, 0.0f), FVector2D::ZeroVector, InColor));

          It looks like you need to test the bounds of what you're trying to do in case some sort of unintentional recursion is making massive graphs, which looks like what is happening here.

          If I do any sort of recursion I tend to build a hop limit into it so I can detect if it's going on forever.

          It seems to have left the graph in a bad state, now opening the graph at all crashes UE. Is there a way to reset every node position to zero without trying to draw it?

          Edit: I restored from the saved backups folder, but I'm afraid to reformat it now.
          Last edited by Antidamage; 11-08-2020, 05:22 PM.

          Comment


            Antidamage Oh man, was hoping one of these kinda bugs wouldn't pop up. I'm farily certain this bug is due to the setting "AccountForCommentsWhenFormatting". I do remember this setting having some very bad edge cases at times when I was working on it. Would suggest turning it off for now or being really careful with nested / overlapping comment boxes. I'll try and fix this once and for all in the next update.

            Thankfully you were able to restore from backups, I think? it is possible to restore a graph without drawing it but currently the plugin is not setup to do this at all. Would need to figure out an alternate way of accessing the graph.

            Also if possible could you post your node setup / event which caused this?
            Blueprint Assist Plugin: Mouse free blueprint creation and quality of life features
            Auto Size Comments Plugin (FREE): Auto resizing comment boxes

            Comment


              It's definitely the comment blocks. As a pre-emptive measure I removed all of the comment options and got rid of the blocks themselves. Typically they were really, really far spaced apart, or it was inevitably overlapping all of them so they were merging. I think the deal is just to avoid comments (particularly nested comment blocks.)

              Also, I had the auto-size comments plugin installed, and the comment padding for both it and this plugin were set to be the same.

              I kept a copy of the blueprint so sure thing, but if you want to replicate it: it was several branching sequence nodes with four separate comment blocks, then multiple comment blocks inside of each of those.

              Comment

              Working...
              X