Announcement

Collapse
No announcement yet.

Blueprint Assist Plugin

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Yea unfortunately I don't think I can provide the rest of the graph at this stage. Hopefully gpsyk has one he can provide.

    Comment


      fpwong Can you explain why there is this tiny height difference?

      The straight picture is made using the built in straighten nodes (Q) and then the other picture with the tiny shift in the line is using the blueprint assist format.

      Is this something to do with my settings?

      Because I have to get rid of it, it's really annoying.

      Thanks
      Attached Files

      Comment


        Yep, I gotta say I could not ignore that. My blood pressure rose just looking at it.

        Comment


          TobyTheKiwi Hmm this occurs for me too but it only occurs with the electronic nodes plugin. I'll have a look at this, I suspect it's a rounding issue.
          Edit: Nevemind, it definitely occurs with the default engine too
          Last edited by fpwong; 03-17-2020, 08:08 AM.
          Blueprint Assist Plugin: Mouse free blueprint creation and quality of life features
          Auto Size Comments Plugin (FREE): Auto resizing comment boxes

          Comment


            fpwong Yea I am using the electronic nodes plugin. But I think that just makes the issue more noticeable. If I disable the plugin via the master activate checkbox the behaviour still remains.

            Comment


              TobyTheKiwi I think I know what the issue is, the way the plugin works requires you to be at 1:1 zoom for the formatting to be precise. This is because when you zoom in / out the nodes on the graph change their size slightly. You can confim this by zooming to 1:1 then running the default straighten pin command and then zooming to +7 (with ctrl + mousewheel) and straightening the pins again, which will cause the same issue as in the screenshots.

              Can you confirm this is the case, and the formatting is correct at 1:1 zoom level?
              Blueprint Assist Plugin: Mouse free blueprint creation and quality of life features
              Auto Size Comments Plugin (FREE): Auto resizing comment boxes

              Comment


                fpwong Yes this is something that happens at different zoom levels. The thing is that Zoom 1 isn't the most helpful distance, is there no way to have straight lines at Zoom 2 or 3?

                Comment


                  Originally posted by TobyTheKiwi View Post
                  fpwong Yes this is something that happens at different zoom levels. The thing is that Zoom 1 isn't the most helpful distance, is there no way to have straight lines at Zoom 2 or 3?
                  I could add a setting for what zoom level you prefer to use but as before, it will only be precise when viewing at that zoom level.

                  Otherwise I can add a setting so it format the nodes at the current zoom level. In my opinion this is not useful at all since you often want to format nodes while zoomed out and the formatting will be completely off when doing so.
                  Blueprint Assist Plugin: Mouse free blueprint creation and quality of life features
                  Auto Size Comments Plugin (FREE): Auto resizing comment boxes

                  Comment


                    Well that's quite annoying....

                    fpwong I have found that this issue does remain sometimes at Zoom 1:1 currently I can see it in an example with one float operator between a function start and return nodes.

                    Thanks again for your excellent responsiveness.

                    EDIT: Nevermind!

                    I've discovered this is happening because of the "Blueprint Knot Track Spacing" setting. I'm not sure what the good fix is here. Can we have this setting act as a minimum distance but it will try and create straight wires as a first priority?
                    Last edited by TobyTheKiwi; 03-17-2020, 11:51 PM.

                    Comment


                      TobyTheKiwi That is strange, the Blueprint Knot Track spacing shouldn't have any effect for the example in the screenshot or was this in regards to the float operator? I am aware of an old issue related to knot tracks and wires not being straight. Could you try to make a small example of this?
                      Blueprint Assist Plugin: Mouse free blueprint creation and quality of life features
                      Auto Size Comments Plugin (FREE): Auto resizing comment boxes

                      Comment


                        fpwong These show the issue for me. The out of line picture is with knot spacing 10. If I change it to 5 the line again isn't straight but this time the ^2 is closer to the exec line.
                        Attached Files

                        Comment


                          Originally posted by TobyTheKiwi View Post
                          fpwong These show the issue for me. The out of line picture is with knot spacing 10. If I change it to 5 the line again isn't straight but this time the ^2 is closer to the exec line.
                          Hi Toby, sorry for the late reply. You probably already noticed that changing this variable messes with other parts of the formatting algorithm. Not sure why I was using this setting here. Anyway I'll be adding another setting for this called "VerticalPinSpacing" with a default value of 5.

                          Thanks for figuring this out
                          Last edited by fpwong; 04-07-2020, 04:27 AM.
                          Blueprint Assist Plugin: Mouse free blueprint creation and quality of life features
                          Auto Size Comments Plugin (FREE): Auto resizing comment boxes

                          Comment


                            fpwong Would it be possible to just leave these sort of situations to not have an explicit spacing but just to prefer whatever makes the wires straight?

                            I think there will always be a situation where it's out of line if it's based on a single explicit number for spacing.

                            Comment


                              TobyTheKiwi Currently prefering straight wires would cause a number of issues due to some assumptions I've made in the later parts of the algorithm. I may look into improving this sometime in the future, but the next update will be using the pin spacing (I agree there will be cases where the nodes are not straightened when they should be).
                              Blueprint Assist Plugin: Mouse free blueprint creation and quality of life features
                              Auto Size Comments Plugin (FREE): Auto resizing comment boxes

                              Comment


                                Hi! I asked on the market page on support for Logic Driver. While the logic drive has a state machine graph which I understand you have no intention to add support yet, there are also the state graph and transition graph which is the same as the blueprint graph. So would you consider adding support to that, or could you tell me how we can add support for that ourselves?

                                Comment

                                Working...
                                X