Announcement

Collapse
No announcement yet.

DoN's 3D Pathfinding for Flying A.I. [Support Thread]

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • replied
    Hi everyone,

    Information seems spread out over multiple threads and pages and the dev hasn't been very communicative recently (though I do see the game is being worked on). In light of this, I felt it worthwhile to start up a Discord to see if we can better organise the community that exists around this project. To start, I've compiled a few methods of building for other engine versions and listed these in the #guides channel. I've also summarised a few important links.

    I'm not a C++ programmer by trade, so I won't be able to assist with anything in-depth but it's my hope that this might help in a small way to save the neat functionality this plugin has.

    If the author decides to pick it back up, I'm more than happy to hand over control of the server.

    Here's the link: https://discord.gg/eFW6suw

    Leave a comment:


  • replied
    Originally posted by rasamaya1 View Post
    Really good to know its cookable at least. Will probably have to work as a team to keep the plugin going if modifications are required in the future.
    I really hope so, because this is a very cool plugin and it would be a shame to let it die...

    Leave a comment:


  • replied
    Really good to know its cookable at least. Will probably have to work as a team to keep the plugin going if modifications are required in the future.

    Leave a comment:


  • replied
    Originally posted by 1l2Hawk View Post
    I followed erol's steps from Page 10, and am able to cook a development build with a 4.24 version of this plug successfully. I did get these (4) warnings but I don't think it's related to updating the plugin because these appeared in earlier engine releases as well. Everything seems to be working otherwise.

    Code:
    UATHelper: Packaging (Windows (64-bit)): LogInit: Display: Warning/Error Summary (Unique only)
    UATHelper: Packaging (Windows (64-bit)): LogInit: Display: -----------------------------------
    UATHelper: Packaging (Windows (64-bit)): LogInit: Display: LogClass: Warning: FDoNNavigationQueryData::Origin is not initialized properly
    UATHelper: Packaging (Windows (64-bit)): LogInit: Display: LogClass: Warning: FDoNNavigationQueryData::Destination is not initialized properly
    UATHelper: Packaging (Windows (64-bit)): LogInit: Display: LogAutomationTest: Warning: FDoNNavigationQueryData::Origin is not initialized properly
    UATHelper: Packaging (Windows (64-bit)): LogInit: Display: LogAutomationTest: Warning: FDoNNavigationQueryData::Destination is not initialized properly
    UATHelper: Packaging (Windows (64-bit)): LogInit: Display:
    UATHelper: Packaging (Windows (64-bit)): LogInit: Display: Success - 0 error(s), 4 warning(s)
    UATHelper: Packaging (Windows (64-bit)): LogInit: Display:
    UATHelper: Packaging (Windows (64-bit)):
    UATHelper: Packaging (Windows (64-bit)): Execution of commandlet took: 34.31 seconds
    UATHelper: Packaging (Windows (64-bit)): Took 43.3833294s to run UE4Editor-Cmd.exe, ExitCode=0

    Hi 1|2Hawk,

    Those warnings seem to be related to the product itself and not the engine reporting a warning (but I could be completely wrong). I receive these warnings each time I launch the Engine itself, before I do anything. The log shows them. I haven't had time to go and figure out where they're coming from. If you follow the source code, you should easily be able to trace what is expected and why that warning pops up. If you get that info, could you please share?

    I think the original developer of this awesome plugin has let it die.

    Leave a comment:


  • replied
    I followed erol's steps from Page 10, and am able to cook a development build with a 4.24 version of this plug successfully. I did get these (4) warnings but I don't think it's related to updating the plugin because these appeared in earlier engine releases as well. Everything seems to be working otherwise.

    Code:
    UATHelper: Packaging (Windows (64-bit)):   LogInit: Display: Warning/Error Summary (Unique only)
    UATHelper: Packaging (Windows (64-bit)):   LogInit: Display: -----------------------------------
    UATHelper: Packaging (Windows (64-bit)):   LogInit: Display: LogClass: Warning: FDoNNavigationQueryData::Origin is not initialized properly
    UATHelper: Packaging (Windows (64-bit)):   LogInit: Display: LogClass: Warning: FDoNNavigationQueryData::Destination is not initialized properly
    UATHelper: Packaging (Windows (64-bit)):   LogInit: Display: LogAutomationTest: Warning: FDoNNavigationQueryData::Origin is not initialized properly
    UATHelper: Packaging (Windows (64-bit)):   LogInit: Display: LogAutomationTest: Warning: FDoNNavigationQueryData::Destination is not initialized properly
    UATHelper: Packaging (Windows (64-bit)):   LogInit: Display:
    UATHelper: Packaging (Windows (64-bit)):   LogInit: Display: Success - 0 error(s), 4 warning(s)
    UATHelper: Packaging (Windows (64-bit)):   LogInit: Display:
    UATHelper: Packaging (Windows (64-bit)):   
    UATHelper: Packaging (Windows (64-bit)):   Execution of commandlet took:  34.31 seconds
    UATHelper: Packaging (Windows (64-bit)): Took 43.3833294s to run UE4Editor-Cmd.exe, ExitCode=0

    Leave a comment:


  • replied
    I havn't cooked either... yikes I hope its not an issue. WOuld be amazing if someone updated this for 4.24/4.25. I have it "working" in 4.24 but have not cooked anything. I may be in trouble

    Leave a comment:


  • replied
    laggyluk Not really sure.

    Leave a comment:


  • replied
    Originally posted by Freymox View Post
    Getting these:
    Code:
    LogPlayLevel: Running UnrealHeaderTool "x.uproject" "x.uhtmanifest" -LogCmds="loginit warning, logexit warning, logdatabase error" -Unattended -WarningsAsErrors -installed
    LogPlayLevel: Error: x/Plugins/DonAINavigation/Source/DonAINavigation/Classes/Legacy/DEPRECATED_VolumeAdaptiveBuilder.h(73) : LogCompile: Error: Type 'FNavigationGraphAerial' is not supported by blueprint. VolumeAdaptiveBuilder.NavGraph
    LogPlayLevel: Error: x/Plugins/DonAINavigation/Source/DonAINavigation/Classes/Legacy/DEPRECATED_VolumeAdaptiveBuilder.h(76) : LogCompile: Error: Type 'TArray<FNAVMapContainer>' is not supported by blueprint. VolumeAdaptiveBuilder.NavGraph_GCSafe
    I don't have 'legacy' folder in there, is that older plugin version or some wild result of content cooking?

    Leave a comment:


  • replied
    Hi Freymox , I have not tried to pack my game with this plugin.

    Leave a comment:


  • replied
    laggyluk Yea, no problem there.
    Actually have u erol_demirci try to pack your game with this plugin? I'm getting an error on 4.24 even with regular engine build.

    Getting these:
    Code:
    LogPlayLevel:     Running UnrealHeaderTool "x.uproject" "x.uhtmanifest" -LogCmds="loginit warning, logexit warning, logdatabase error" -Unattended -WarningsAsErrors -installed
    LogPlayLevel: Error:   x/Plugins/DonAINavigation/Source/DonAINavigation/Classes/Legacy/DEPRECATED_VolumeAdaptiveBuilder.h(73) : LogCompile: Error: Type 'FNavigationGraphAerial' is not supported by blueprint. VolumeAdaptiveBuilder.NavGraph
    LogPlayLevel: Error:   x/Plugins/DonAINavigation/Source/DonAINavigation/Classes/Legacy/DEPRECATED_VolumeAdaptiveBuilder.h(76) : LogCompile: Error: Type 'TArray<FNAVMapContainer>' is not supported by blueprint. VolumeAdaptiveBuilder.NavGraph_GCSafe
    Last edited by Freymox; 02-07-2020, 09:00 AM.

    Leave a comment:


  • replied
    Originally posted by Freymox View Post
    erol ademoski I can't make it work for source build :/
    does source build work without the plugin?

    Leave a comment:


  • replied
    erol ademoski I can't make it work for source build :/

    Leave a comment:


  • replied
    Hi Freymox , are you saying you want to build the ENGINE source, and want to include the plugin to be built during that process? If so, I can't say either way because I have never built the ENGINE source. I would post this in the C++ forum. I am sorry I could not be of more help.

    Leave a comment:


  • replied
    erol ademoski Hey. Your guide for upgrade plugin from 4.23 to 4.24 is good. Only question is, how to do it for source build? When I start project it says "Loaded ExampleLibrary.dll from Third Party Plugin Samlple" and it's not working, when I enter game, even if plugin shows as enabled. Plugin is not packed, becouse, as my understanding is, its not working, when packaged.
    And anyways I'm getting error when try to package it:
    Code:
    UATHelper: Package Plugin Task (Windows): ERROR: Failed to build "D:/UnrealEngine/Engine/Programs/AutomationTool/Saved\UATTempProj.proj":
    Last edited by Freymox; 01-30-2020, 10:04 PM.

    Leave a comment:


  • replied
    erol_demirci Cache map doesn't contain voxels per se, only the pointers. Size of a pointer is 4 bytes, if I'm not mistaken.

    Leave a comment:

Working...
X