Announcement

Collapse
No announcement yet.

Able Ability System Info and Support Thread

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

    ExtraLifeMatt The new new ABLE is runing under what engine versions? I've seen it in this threat however I cant find it. Do you guys have a dsicord channel?

    Comment


      I got the crash again while working on my project. This is seen at the end of the crash report text file:
      Can't find file '/Script/AbleEditor'
      Can't find file for asset '/Script/AbleEditor' while loading NULL.
      Can't find file '/Script/AbleEditor'
      Can't find file for asset '/Script/AbleEditor' while loading NULL.
      Can't find file '/Script/AbleEditor'
      Can't find file for asset '/Script/AbleEditor' while loading NULL.
      Can't find file '/Script/AbleEditor'
      Can't find file for asset '/Script/AbleEditor' while loading NULL.
      Can't find file '/Script/AbleEditor'
      Can't find file for asset '/Script/AbleEditor' while loading NULL.
      Can't find file '/Script/AbleEditor'
      Can't find file for asset '/Script/AbleEditor' while loading NULL.
      Can't find file '/Script/AbleEditor'
      Can't find file for asset '/Script/AbleEditor' while loading NULL.
      Can't find file '/Script/AbleEditor'

      I followed an old solution you posted by adding

      // Purge any NULL graphs
      FBlueprintEditorUtils::PurgeNullGraphs(Blueprint);

      In the specified location, but no luck.

      Comment


        Originally posted by mnorris54 View Post
        Sorry vimeo sucks, try this link:

        https://youtu.be/t_YxhbAl5zU
        I have the same troubles that you when trying to disable camera and collision cylinder, etc;
        About the tracing targets...you need to enable this in timeline menu and make sure that tracing query are running one the client too. Only on server don't show it.

        Comment


          Originally posted by Glutamatkrieger View Post
          ExtraLifeMatt , last time i used able it was pretty stable ( no pun intendend). Now i canĀ“t even play the ability. I hit play - nothing happens. The UI also feels worse than before. But my main question is, when can i use able for my projects? I tested the 4.22 one, perhaps it was too early ? Are you trying on fixing the custom task recompiling issues soon ?
          Check your output log. Are you sure your character has an Ability Component? The times when I've seen an ability not play it's because of one of two issues: 1.) You have a channeling condition which isn't valid when you preview (i.e. some key press), or 2.) You don't have an Ability Component and adding one dynamically is not working well (for whatever reason, still debugging that one).

          Also Custom Task compilation should be fixed as it's passing my local testing. If it's not, please give me a repro or you can upload a sample project that shows the issue here: https://www.dropbox.com/request/nD81ewNC7G3p5MNWlMKX

          Originally posted by AngeIV View Post
          ExtraLifeMatt The new new ABLE is runing under what engine versions? I've seen it in this threat however I cant find it. Do you guys have a dsicord channel?
          Able always works for the latest 3 versions, so 4.20, 4.21, 4.22. I can't support older versions unfortunately. There is a player discord channel (I believe I link to it in the first post), but I'm not normally on there. Here is the best place to reach me.

          Originally posted by OllieWilliams View Post
          I got the crash again while working on my project. This is seen at the end of the crash report text file:
          Can't find file '/Script/AbleEditor'
          Can't find file for asset '/Script/AbleEditor' while loading NULL.
          Can't find file '/Script/AbleEditor'
          Can't find file for asset '/Script/AbleEditor' while loading NULL.
          Can't find file '/Script/AbleEditor'
          Can't find file for asset '/Script/AbleEditor' while loading NULL.
          Can't find file '/Script/AbleEditor'
          Can't find file for asset '/Script/AbleEditor' while loading NULL.
          Can't find file '/Script/AbleEditor'
          Can't find file for asset '/Script/AbleEditor' while loading NULL.
          Can't find file '/Script/AbleEditor'
          Can't find file for asset '/Script/AbleEditor' while loading NULL.
          Can't find file '/Script/AbleEditor'
          Can't find file for asset '/Script/AbleEditor' while loading NULL.
          Can't find file '/Script/AbleEditor'

          I followed an old solution you posted by adding

          // Purge any NULL graphs
          FBlueprintEditorUtils::PurgeNullGraphs(Blueprint);

          In the specified location, but no luck.
          You can try something. Open up Able.uplugin and set the LoadingPhase for AbleEditor to "PreDefault". That's fixed that error before, but it causes some other issues with Able Editor Settings not being able to find game classes (since it loads things pre-game binary). But, if that fixes things then I'll find a work around for the other.
          Last edited by ExtraLifeMatt; 04-29-2019, 09:46 AM.
          Able Ability System - A high performance, robust ability system for UE4. Now Available!

          Comment


            Originally posted by Demonrras View Post

            I have the same troubles that you when trying to disable camera and collision cylinder, etc;
            About the tracing targets...you need to enable this in timeline menu and make sure that tracing query are running one the client too. Only on server don't show it.
            Clicking the Show Collision / Show Camera options in the view drop down in the Ability Editor isn't hiding those? That code hasn't changed so I'm a bit shocked it's broken.
            Able Ability System - A high performance, robust ability system for UE4. Now Available!

            Comment


              Originally posted by ExtraLifeMatt View Post

              Check your output log. Are you sure your character has an Ability Component? The times when I've seen an ability not play it's because of one of two issues: 1.) You have a channeling condition which isn't valid when you preview (i.e. some key press), or 2.) You don't have an Ability Component and adding one dynamically is not working well (for whatever reason, still debugging that one).

              Also Custom Task compilation should be fixed as it's passing my local testing. If it's not, please give me a repro or you can upload a sample project that shows the issue here: https://www.dropbox.com/request/nD81ewNC7G3p5MNWlMKX



              Able always works for the latest 3 versions, so 4.20, 4.21, 4.22. I can't support older versions unfortunately. There is a player discord channel (I believe I link to it in the first post), but I'm not normally on there. Here is the best place to reach me.



              You can try something. Open up Able.uplugin and set the LoadingPhase for AbleEditor to "PreDefault". That's fixed that error before, but it causes some other issues with Able Editor Settings not being able to find game classes (since it loads things pre-game binary). But, if that fixes things then I'll find a work around for the other.
              Yup this fixed it! Thanks so much.

              Comment


                Originally posted by OllieWilliams View Post

                Yup this fixed it! Thanks so much.
                Fun. Okay, then I'll find a way to fix the Able Editor Settings. If you see null classes in your allowed classes drop down, that's why.

                EDIT: Testing a workaround for the config issue, and found the issue with camera/character collision not respecting the options. Fixes incoming.
                Last edited by ExtraLifeMatt; 04-29-2019, 11:50 AM.
                Able Ability System - A high performance, robust ability system for UE4. Now Available!

                Comment


                  Originally posted by ExtraLifeMatt View Post

                  Clicking the Show Collision / Show Camera options in the view drop down in the Ability Editor isn't hiding those? That code hasn't changed so I'm a bit shocked it's broken.
                  No. When I go on Ability Editor, click in TIMELINE menu and clicking in this checkbox...don't change nothing in my preview scene.

                  Other issue that I see is: When select an animation task and try to change the animation...this don't change...need to delete the task and add this again with the right animation.

                  Comment


                    Originally posted by Demonrras View Post

                    No. When I go on Ability Editor, click in TIMELINE menu and clicking in this checkbox...don't change nothing in my preview scene.

                    Other issue that I see is: When select an animation task and try to change the animation...this don't change...need to delete the task and add this again with the right animation.
                    Yea, I found the issue with the checkbox for Camera/ Collision. I have a fix coming.

                    As long as you save the Ability (which happens automatically when you try to play an Ability), it should change the Animation during the preview. I'll check that locally as well, but I'd look at your log for any weird errors.
                    Able Ability System - A high performance, robust ability system for UE4. Now Available!

                    Comment


                      How I can make hit reactions??? Like frontal hit, back hit, left and right hit....

                      Comment


                        Originally posted by Demonrras View Post
                        How I can make hit reactions??? Like frontal hit, back hit, left and right hit....
                        That is up to you. Able doesn't support that out of the box.

                        I would do it where I figure out the general direction of the damage (so, just create a vector from the damage source to my actor). And then do a handful of half space tests to find the general location.
                        Able Ability System - A high performance, robust ability system for UE4. Now Available!

                        Comment


                          Task to MoveTo, jump etc don't work...

                          Comment


                            Hey,
                            I recently started working on my project again and saw that there was an Update for Able.
                            Right now it seems that the "OnGetDynamicProperty_Cooldown" function isn't even called.
                            All I did was copy pasting my code from "GetCooldown"(which was marked as deprecated) to this new function.

                            I read that there were bugs with dynamic fields not working. Wasn't this fixed in 3.0.3?

                            I'm glad for any information or help.

                            Comment


                              Originally posted by Demonrras View Post
                              Task to MoveTo, jump etc don't work...
                              Move To / Jump To are entirely experimental. I'm planning to circle around to them this weekend. They may get removed as movement is such a per-game specific thing, but I'm going to see if I can't give them one more shot.
                              Originally posted by Knaarke View Post
                              Hey,
                              I recently started working on my project again and saw that there was an Update for Able.
                              Right now it seems that the "OnGetDynamicProperty_Cooldown" function isn't even called.
                              All I did was copy pasting my code from "GetCooldown"(which was marked as deprecated) to this new function.

                              I read that there were bugs with dynamic fields not working. Wasn't this fixed in 3.0.3?

                              I'm glad for any information or help.
                              Dynamic fields were fixed in 3.0.3, but I may have missed a spot with Cooldown. I'll verify.
                              Able Ability System - A high performance, robust ability system for UE4. Now Available!

                              Comment


                                Originally posted by ExtraLifeMatt View Post

                                Move To / Jump To are entirely experimental. I'm planning to circle around to them this weekend. They may get removed as movement is such a per-game specific thing, but I'm going to see if I can't give them one more shot.


                                Dynamic fields were fixed in 3.0.3, but I may have missed a spot with Cooldown. I'll verify.
                                Pls...implement launch character in movement tasks. I wanna to make some aerial combat where I launch enemies to air and make combos...I puchase your plugin with the hope that can help me with this.

                                Comment

                                Working...
                                X