Announcement

Collapse
No announcement yet.

Able Ability System Info and Support Thread

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • replied
    Right i tried it on UE4 4.20 / 4.21. Installs fine.
    I can view animations and all in single node its fine, I can even use it in game.

    Since we going in circles here, Its nothing to do with the function of the plugin as it works fine.

    Its choosing an animation and problem is swapping to another animation in drop down.
    I click on another animation but it just does not change, I tried it on new clean project and same thing.
    I uninstalled the plugin from epic games and reinstalled it again.

    Its the drop down box that does not change animation.
    The only thing i gotta do is to remove animation and add animation and choose another one this way.


    Can you try it out matt and tell me what happens when you try and change animation.
    Check photo below
    Add able file, Add task, Play animation, Pick an Animation. Highlight the animation bar.
    Click task propertys then under animation pick a new one from dropdown.
    Please tell me if it changes at your end.


    I am using 4.20/4.21 and both clean projects.


    Leave a comment:


  • replied
    Originally posted by jwyuen View Post
    Ok but i it does same on new project also
    What version of UE4?

    Leave a comment:


  • replied
    Ok but i it does same on new project also

    Leave a comment:


  • replied
    Originally posted by jwyuen View Post
    Hi doesnt work on any settings
    I'll PM you, if you can send me your project I'll run things locally with a debugger and see what's going on.

    Leave a comment:


  • replied
    Hi doesnt work on any settings

    Leave a comment:


  • replied
    Originally posted by jwyuen View Post
    Does not change at all so deffo something wrong stays as same anim.
    I saw you change things to dynamic montage from Single Node, if you keep it at Single Node, does it work as expected? There may be something with the montage system.

    Leave a comment:


  • replied
    Does not change at all so deffo something wrong stays as same anim.

    Leave a comment:


  • replied
    Have you got fb or discord??
    I did press play
    Last edited by jwyuen; 01-01-2019, 05:44 PM.

    Leave a comment:


  • replied
    Originally posted by jwyuen View Post
    I have emailed it over to Feedback@extralifestudios.com address. Cant remember your other address and cant find it

    Cheers Matt

    Jesse
    Perfect, Thanks Jesse!

    So, in your video, I never see you hit the "Play" button in the toolbar at the top once you select your Animation (which causes the Ability to play itself). Automatically playing the animation after being selected could be done, but it could be a bit weird because people may not want to automatically play the ability just because you swapped an animation.

    I didn't get any audio in your video, but I assume that's your issue? Or am I misunderstanding?

    Leave a comment:


  • replied
    I have emailed it over to Feedback@extralifestudios.com address. Cant remember your other address and cant find it

    Cheers Matt

    Jesse

    Leave a comment:


  • replied
    Originally posted by ExtraLifeMatt View Post

    You may need to save the ability before the Animation will play (but that should happen behind the scenes when you go to play it). You can turn on the "Verbose" option for that task and see what Animation it says it's trying to play. I'd be curious to see your output as I've never had that issue reported to me.

    I'll share more on 3.0 as I'm ready. It's turned into a rather meaty update, and I think people will enjoy it.


    Hi matt, Since i cant seem to explain this and you have not seen this error before, I have just made you a video to show you the issue.

    Can you Check your E-Mail as i will email you the video over of the error.

    Thank you

    Jesse

    Leave a comment:


  • replied
    Originally posted by jwyuen View Post
    Hi matt, yeah the anims just wont change. Tried everything already. Even started new project. I have to delete play anim and add new one.

    What sorta new features you adding?
    Cant wait.
    This is my main ability system for my game now?
    Jesse
    You may need to save the ability before the Animation will play (but that should happen behind the scenes when you go to play it). You can turn on the "Verbose" option for that task and see what Animation it says it's trying to play. I'd be curious to see your output as I've never had that issue reported to me.

    I'll share more on 3.0 as I'm ready. It's turned into a rather meaty update, and I think people will enjoy it.

    Leave a comment:


  • replied
    Hi matt, yeah the anims just wont change. Tried everything already. Even started new project. I have to delete play anim and add new one.

    What sorta new features you adding?
    Cant wait.
    This is my main ability system for my game now?
    Jesse

    Leave a comment:


  • replied
    Originally posted by jwyuen View Post
    Hi

    I have reinstalled this plugin again recently.
    I have this Bug / problem with Play Animation task.

    When I either select Null or select an animation, I would like to change animation and see different ones.
    When i do this, it does not change to the animation in scroll down.
    Please can you have a look into this. Thank you
    Are you saying you would like it to instantly play the animation while you are scrolling through? Or you simply aren't seeing any animation play after you select one and hit Play?

    EDIT: I'm also working on the 3.0 update which will have some very cool things hopefully people enjoy. Hoping to get it out before the New Year.

    Leave a comment:


  • replied
    Hi

    I have reinstalled this plugin again recently.
    I have this Bug / problem with Play Animation task.

    When I either select Null or select an animation, I would like to change animation and see different ones.
    When i do this, it does not change to the animation in scroll down.
    Please can you have a look into this. Thank you

    Leave a comment:

Working...
X