Announcement

Collapse
No announcement yet.

Able Ability System Info and Support Thread

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    I'm also still experiencing the same issue as before, animations aren't interrupting with their abilities.

    Comment


      Originally posted by SteamPunkProgrammer View Post
      I'm also still experiencing the same issue as before, animations aren't interrupting with their abilities.
      Have you tried the new "Clear Animation Queue" option on the Play Animation call when interrupted?
      Able Ability System - A high performance, robust ability system for UE4. Now Available!

      Comment


        Originally posted by ExtraLifeMatt View Post

        Have you tried the new "Clear Animation Queue" option on the Play Animation call when interrupted?
        I have, the only thing that has any effect is checking both the "Is Playing Ability" and "Has Ability Animation"; checking both of these for the state change within the animation blueprint solves the problem in most cases.

        Comment


          Originally posted by SteamPunkProgrammer View Post

          I have, the only thing that has any effect is checking both the "Is Playing Ability" and "Has Ability Animation"; checking both of these for the state change within the animation blueprint solves the problem in most cases.
          Has Ability Animation you definitely should be checking, but Is Playing Ability shouldn't really matter. The cancel does has to happen within the time frame of the Play Animation Task, so if you are just firing it and forgetting, I could see that cause this.
          Able Ability System - A high performance, robust ability system for UE4. Now Available!

          Comment


            Originally posted by ExtraLifeMatt View Post

            Has Ability Animation you definitely should be checking, but Is Playing Ability shouldn't really matter. The cancel does has to happen within the time frame of the Play Animation Task, so if you are just firing it and forgetting, I could see that cause this.
            I am canceling within the time frame of the animation task. I've even tried pulling it down to the point it cancels just a few mill seconds after it starts (I should just see a twitch in the animation when its canceled) but it just continues to play as if the ability has never been canceled (unless I check for 'Is Playing Ability' that is).

            Comment


              Hey,

              I cloned my Project and upgraded it to 4.19 (together with the new Plugin Version). If I try to package it, this error occurs(UBuildTool-Logfile):
               
              Spoiler


              Am I right to to assume it has to to with this plugin and or did I missed something to do when switching to new Version?

              Thanks in advance.

              Comment


                Hi, sometimes when I try to add preview assets in, the blueprints that I click are not alsways loading in, most of the time it fails to load the blueprint in as a preview asset. Any ideas to why this is happening, this is ue4 4.19

                Comment


                  Sorry for the silence lately, I was knocked out by the flu last week and I'm just now getting up and around again.

                  Originally posted by Knaarke View Post
                  Hey,

                  I cloned my Project and upgraded it to 4.19 (together with the new Plugin Version). If I try to package it, this error occurs(UBuildTool-Logfile):
                   
                  Spoiler


                  Am I right to to assume it has to to with this plugin and or did I missed something to do when switching to new Version?

                  Thanks in advance.
                  Hmmm, not sure why you're the only one getting that (or maybe you arn't). Do you see the ShouldCancelAbility in the AblCancelAbilityTask.cpp?
                  Originally posted by CyberblastSoft View Post
                  Hi, sometimes when I try to add preview assets in, the blueprints that I click are not alsways loading in, most of the time it fails to load the blueprint in as a preview asset. Any ideas to why this is happening, this is ue4 4.19
                  Are you getting any errors? As long as the blueprint has a static mesh / skeletal mesh - it should load.
                  Able Ability System - A high performance, robust ability system for UE4. Now Available!

                  Comment


                    Originally posted by ExtraLifeMatt View Post
                    Sorry for the silence lately, I was knocked out by the flu last week and I'm just now getting up and around again.


                    Hmmm, not sure why you're the only one getting that (or maybe you arn't). Do you see the ShouldCancelAbility in the AblCancelAbilityTask.cpp?
                    No problem, glad you're getting better.

                    I'm not that much into c++ coding but I found the "ShouldCancelAbility" at the end of the class inside a "#if WITH_EDITOR" wrapper and it's getting called above twice.

                     
                    Spoiler


                    Hope that was what you were asking for!?

                    Comment


                      Originally posted by Knaarke View Post

                      No problem, glad you're getting better.

                      I'm not that much into c++ coding but I found the "ShouldCancelAbility" at the end of the class inside a "#if WITH_EDITOR" wrapper and it's getting called above twice.

                       
                      Spoiler


                      Hope that was what you were asking for!?
                      Ahhhh, that's the issue. Just cut and paste that ShouldCancelAbility method outside of the #if WITH_EDITOR block. No idea how that got through submissions, but I'll get a patch out this weekend.
                      Able Ability System - A high performance, robust ability system for UE4. Now Available!

                      Comment


                        Any news on the crash when running in standalone from editor (or rmb and launch from uproject file)? We're currently getting this error and crash when trying.. we're on 4.19.

                        Code:
                        [2018.04.06-22.41.39:942][  0]LogInit: Texture streaming: Enabled
                        [2018.04.06-22.41.40:077][  0]LogLinker: Warning: Can't find file '/Script/AbleEditor'
                        [2018.04.06-22.41.40:077][  0]LoadErrors: Failed to load /Script/AbleEditor.AblAbilityGraph Referenced by DT_ItemList
                        [2018.04.06-22.41.40:077][  0]LogUObjectGlobals: Warning: Failed to load '/Script/AbleEditor': Can't find file '/Script/AbleEditor'
                        [2018.04.06-22.41.40:077][  0]LogLinker: Warning: Can't find file for asset '/Script/AbleEditor' while loading NULL.
                        [2018.04.06-22.41.40:077][  0]LoadErrors: Failed to load /Script/AbleEditor.AblAbilityGraph Referenced by DT_ItemList
                        [2018.04.06-22.41.40:077][  0]LogUObjectGlobals: Warning: Failed to load '/Script/AbleEditor': Can't find file for asset '/Script/AbleEditor' while loading NULL.
                        [2018.04.06-22.41.40:077][  0]LogLinker: Warning: Can't find file '/Script/AbleEditor'
                        [2018.04.06-22.41.40:077][  0]LoadErrors: Failed to load /Script/AbleEditor.AblAbilityGraphSchema Referenced by DT_ItemList
                        [2018.04.06-22.41.40:077][  0]LogUObjectGlobals: Warning: Failed to load '/Script/AbleEditor': Can't find file '/Script/AbleEditor'
                        [2018.04.06-22.41.40:077][  0]LogLinker: Warning: Can't find file for asset '/Script/AbleEditor' while loading NULL.
                        [2018.04.06-22.41.40:077][  0]LoadErrors: Failed to load /Script/AbleEditor.AblAbilityGraphSchema Referenced by DT_ItemList
                        [2018.04.06-22.41.40:077][  0]LogUObjectGlobals: Warning: Failed to load '/Script/AbleEditor': Can't find file for asset '/Script/AbleEditor' while loading NULL.
                        [2018.04.06-22.41.40:077][  0]LogLinker: Warning: Can't find file '/Script/AbleEditor'
                        [2018.04.06-22.41.40:077][  0]LoadErrors: Failed to load /Game/BP/Abilities/Player/Weapons/ABY_BowShoot_01.ABY_BowShoot_01_C Referenced by ABY_BowShoot_01
                        [2018.04.06-22.41.40:077][  0]LogUObjectGlobals: Warning: Failed to load '/Script/AbleEditor': Can't find file '/Script/AbleEditor'
                        [2018.04.06-22.41.40:077][  0]LogLinker: Warning: Can't find file for asset '/Script/AbleEditor' while loading NULL.
                        [2018.04.06-22.41.40:077][  0]LoadErrors: Failed to load /Game/BP/Abilities/Player/Weapons/ABY_BowShoot_01.ABY_BowShoot_01_C Referenced by ABY_BowShoot_01
                        [2018.04.06-22.41.40:077][  0]LogUObjectGlobals: Warning: Failed to load '/Script/AbleEditor': Can't find file for asset '/Script/AbleEditor' while loading NULL.
                        [2018.04.06-22.41.40:077][  0]LogLinker: Warning: Can't find file '/Script/AbleEditor'
                        [2018.04.06-22.41.40:077][  0]LoadErrors: Failed to load /Script/AbleEditor.AblAbilityGraph Referenced by ABY_BowShoot_01
                        [2018.04.06-22.41.40:077][  0]LogUObjectGlobals: Warning: Failed to load '/Script/AbleEditor': Can't find file '/Script/AbleEditor'
                        [2018.04.06-22.41.40:077][  0]LogLinker: Warning: Can't find file for asset '/Script/AbleEditor' while loading NULL.
                        [2018.04.06-22.41.40:077][  0]LoadErrors: Failed to load /Script/AbleEditor.AblAbilityGraph Referenced by ABY_BowShoot_01
                        [2018.04.06-22.41.40:077][  0]LogUObjectGlobals: Warning: Failed to load '/Script/AbleEditor': Can't find file for asset '/Script/AbleEditor' while loading NULL.
                        [2018.04.06-22.41.43:110][  0]LogWindows: Error: === Critical error: ===
                        [2018.04.06-22.41.43:110][  0]LogWindows: Error:
                        [2018.04.06-22.41.43:110][  0]LogWindows: Error: Fatal error!
                        [2018.04.06-22.41.43:110][  0]LogWindows: Error:
                        [2018.04.06-22.41.43:110][  0]LogWindows: Error: Unhandled Exception: EXCEPTION_ACCESS_VIOLATION reading address 0x00000060
                        [2018.04.06-22.41.43:110][  0]LogWindows: Error:
                        [2018.04.06-22.41.43:110][  0]LogWindows: Error: [Callstack] 0x000000002B83097A UE4Editor-Engine.dll!UEdGraph::GetAllChildrenGraphs() [d:\build\++ue4+release-4.19+compile\sync\engine\source\runtime\engine\private\edgraph\edgraph.cpp:340]
                        [2018.04.06-22.41.43:110][  0]LogWindows: Error: [Callstack] 0x000000002B4F31D7 UE4Editor-Engine.dll!UBlueprint::GetAllGraphs() [d:\build\++ue4+release-4.19+compile\sync\engine\source\runtime\engine\private\blueprint.cpp:1542]
                        [2018.04.06-22.41.43:110][  0]LogWindows: Error: [Callstack] 0x000000002A03A214 UE4Editor-UnrealEd.dll!FRegenerationHelper::LinkExternalDependencies() [d:\build\++ue4+release-4.19+compile\sync\engine\source\editor\unrealed\private\kismet2\blueprinteditorutils.cpp:1096]
                        [2018.04.06-22.41.43:110][  0]LogWindows: Error: [Callstack] 0x000000002A039F41 UE4Editor-UnrealEd.dll!FBlueprintEditorUtils::LinkExternalDependencies() [d:\build\++ue4+release-4.19+compile\sync\engine\source\editor\unrealed\private\kismet2\blueprinteditorutils.cpp:1557]
                        [2018.04.06-22.41.43:110][  0]LogWindows: Error: [Callstack] 0x000000002B50FADE UE4Editor-Engine.dll!UBlueprint::RegenerateClass() [d:\build\++ue4+release-4.19+compile\sync\engine\source\runtime\engine\private\blueprint.cpp:649]
                        [2018.04.06-22.41.43:110][  0]LogWindows: Error: [Callstack] 0x0000000044517AC5 UE4Editor-CoreUObject.dll!FLinkerLoad::RegenerateBlueprintClass() [d:\build\++ue4+release-4.19+compile\sync\engine\source\runtime\coreuobject\private\blueprint\blueprintsupport.cpp:580]
                        [2018.04.06-22.41.43:110][  0]LogWindows: Error: [Callstack] 0x00000000444ECD43 UE4Editor-CoreUObject.dll!FLinkerLoad::FinalizeBlueprint() [d:\build\++ue4+release-4.19+compile\sync\engine\source\runtime\coreuobject\private\blueprint\blueprintsupport.cpp:1664]
                        [2018.04.06-22.41.43:110][  0]LogWindows: Error: [Callstack] 0x00000000446A3EDB UE4Editor-CoreUObject.dll!FLinkerLoad::Preload() [d:\build\++ue4+release-4.19+compile\sync\engine\source\runtime\coreuobject\private\uobject\linkerload.cpp:3353]
                        [2018.04.06-22.41.43:110][  0]LogWindows: Error: [Callstack] 0x00000000446730F7 UE4Editor-CoreUObject.dll!FLinkerLoad::CreateExport() [d:\build\++ue4+release-4.19+compile\sync\engine\source\runtime\coreuobject\private\uobject\linkerload.cpp:4027]
                        [2018.04.06-22.41.43:110][  0]LogWindows: Error: [Callstack] 0x0000000044698A11 UE4Editor-CoreUObject.dll!FLinkerLoad::IndexToObject() [d:\build\++ue4+release-4.19+compile\sync\engine\source\runtime\coreuobject\private\uobject\linkerload.cpp:4250]
                        [2018.04.06-22.41.43:110][  0]LogWindows: Error: [Callstack] 0x0000000044671862 UE4Editor-CoreUObject.dll!FLinkerLoad::CreateExport() [d:\build\++ue4+release-4.19+compile\sync\engine\source\runtime\coreuobject\private\uobject\linkerload.cpp:3648]
                        [2018.04.06-22.41.43:110][  0]LogWindows: Error: [Callstack] 0x00000000446734CB UE4Editor-CoreUObject.dll!FLinkerLoad::CreateExportAndPreload() [d:\build\++ue4+release-4.19+compile\sync\engine\source\runtime\coreuobject\private\uobject\linkerload.cpp:2746]
                        [2

                        Comment


                          Originally posted by mesterKG View Post
                          Any news on the crash when running in standalone from editor (or rmb and launch from uproject file)? We're currently getting this error and crash when trying.. we're on 4.19.

                          Code:
                          [2018.04.06-22.41.39:942][ 0]LogInit: Texture streaming: Enabled
                          [2018.04.06-22.41.40:077][ 0]LogLinker: Warning: Can't find file '/Script/AbleEditor'
                          [2018.04.06-22.41.40:077][ 0]LoadErrors: Failed to load /Script/AbleEditor.AblAbilityGraph Referenced by DT_ItemList
                          [2018.04.06-22.41.40:077][ 0]LogUObjectGlobals: Warning: Failed to load '/Script/AbleEditor': Can't find file '/Script/AbleEditor'
                          [2018.04.06-22.41.40:077][ 0]LogLinker: Warning: Can't find file for asset '/Script/AbleEditor' while loading NULL.
                          [2018.04.06-22.41.40:077][ 0]LoadErrors: Failed to load /Script/AbleEditor.AblAbilityGraph Referenced by DT_ItemList
                          [2018.04.06-22.41.40:077][ 0]LogUObjectGlobals: Warning: Failed to load '/Script/AbleEditor': Can't find file for asset '/Script/AbleEditor' while loading NULL.
                          [2018.04.06-22.41.40:077][ 0]LogLinker: Warning: Can't find file '/Script/AbleEditor'
                          [2018.04.06-22.41.40:077][ 0]LoadErrors: Failed to load /Script/AbleEditor.AblAbilityGraphSchema Referenced by DT_ItemList
                          [2018.04.06-22.41.40:077][ 0]LogUObjectGlobals: Warning: Failed to load '/Script/AbleEditor': Can't find file '/Script/AbleEditor'
                          [2018.04.06-22.41.40:077][ 0]LogLinker: Warning: Can't find file for asset '/Script/AbleEditor' while loading NULL.
                          [2018.04.06-22.41.40:077][ 0]LoadErrors: Failed to load /Script/AbleEditor.AblAbilityGraphSchema Referenced by DT_ItemList
                          [2018.04.06-22.41.40:077][ 0]LogUObjectGlobals: Warning: Failed to load '/Script/AbleEditor': Can't find file for asset '/Script/AbleEditor' while loading NULL.
                          [2018.04.06-22.41.40:077][ 0]LogLinker: Warning: Can't find file '/Script/AbleEditor'
                          [2018.04.06-22.41.40:077][ 0]LoadErrors: Failed to load /Game/BP/Abilities/Player/Weapons/ABY_BowShoot_01.ABY_BowShoot_01_C Referenced by ABY_BowShoot_01
                          [2018.04.06-22.41.40:077][ 0]LogUObjectGlobals: Warning: Failed to load '/Script/AbleEditor': Can't find file '/Script/AbleEditor'
                          [2018.04.06-22.41.40:077][ 0]LogLinker: Warning: Can't find file for asset '/Script/AbleEditor' while loading NULL.
                          [2018.04.06-22.41.40:077][ 0]LoadErrors: Failed to load /Game/BP/Abilities/Player/Weapons/ABY_BowShoot_01.ABY_BowShoot_01_C Referenced by ABY_BowShoot_01
                          [2018.04.06-22.41.40:077][ 0]LogUObjectGlobals: Warning: Failed to load '/Script/AbleEditor': Can't find file for asset '/Script/AbleEditor' while loading NULL.
                          [2018.04.06-22.41.40:077][ 0]LogLinker: Warning: Can't find file '/Script/AbleEditor'
                          [2018.04.06-22.41.40:077][ 0]LoadErrors: Failed to load /Script/AbleEditor.AblAbilityGraph Referenced by ABY_BowShoot_01
                          [2018.04.06-22.41.40:077][ 0]LogUObjectGlobals: Warning: Failed to load '/Script/AbleEditor': Can't find file '/Script/AbleEditor'
                          [2018.04.06-22.41.40:077][ 0]LogLinker: Warning: Can't find file for asset '/Script/AbleEditor' while loading NULL.
                          [2018.04.06-22.41.40:077][ 0]LoadErrors: Failed to load /Script/AbleEditor.AblAbilityGraph Referenced by ABY_BowShoot_01
                          [2018.04.06-22.41.40:077][ 0]LogUObjectGlobals: Warning: Failed to load '/Script/AbleEditor': Can't find file for asset '/Script/AbleEditor' while loading NULL.
                          [2018.04.06-22.41.43:110][ 0]LogWindows: Error: === Critical error: ===
                          [2018.04.06-22.41.43:110][ 0]LogWindows: Error:
                          [2018.04.06-22.41.43:110][ 0]LogWindows: Error: Fatal error!
                          [2018.04.06-22.41.43:110][ 0]LogWindows: Error:
                          [2018.04.06-22.41.43:110][ 0]LogWindows: Error: Unhandled Exception: EXCEPTION_ACCESS_VIOLATION reading address 0x00000060
                          [2018.04.06-22.41.43:110][ 0]LogWindows: Error:
                          [2018.04.06-22.41.43:110][ 0]LogWindows: Error: [Callstack] 0x000000002B83097A UE4Editor-Engine.dll!UEdGraph::GetAllChildrenGraphs() [d:\build\++ue4+release-4.19+compile\sync\engine\source\runtime\engine\private\edgraph\edgraph.cpp:340]
                          [2018.04.06-22.41.43:110][ 0]LogWindows: Error: [Callstack] 0x000000002B4F31D7 UE4Editor-Engine.dll!UBlueprint::GetAllGraphs() [d:\build\++ue4+release-4.19+compile\sync\engine\source\runtime\engine\private\blueprint.cpp:1542]
                          [2018.04.06-22.41.43:110][ 0]LogWindows: Error: [Callstack] 0x000000002A03A214 UE4Editor-UnrealEd.dll!FRegenerationHelper::LinkExternalDependencies() [d:\build\++ue4+release-4.19+compile\sync\engine\source\editor\unrealed\private\kismet2\blueprinteditorutils.cpp:1096]
                          [2018.04.06-22.41.43:110][ 0]LogWindows: Error: [Callstack] 0x000000002A039F41 UE4Editor-UnrealEd.dll!FBlueprintEditorUtils::LinkExternalDependencies() [d:\build\++ue4+release-4.19+compile\sync\engine\source\editor\unrealed\private\kismet2\blueprinteditorutils.cpp:1557]
                          [2018.04.06-22.41.43:110][ 0]LogWindows: Error: [Callstack] 0x000000002B50FADE UE4Editor-Engine.dll!UBlueprint::RegenerateClass() [d:\build\++ue4+release-4.19+compile\sync\engine\source\runtime\engine\private\blueprint.cpp:649]
                          [2018.04.06-22.41.43:110][ 0]LogWindows: Error: [Callstack] 0x0000000044517AC5 UE4Editor-CoreUObject.dll!FLinkerLoad::RegenerateBlueprintClass() [d:\build\++ue4+release-4.19+compile\sync\engine\source\runtime\coreuobject\private\blueprint\blueprintsupport.cpp:580]
                          [2018.04.06-22.41.43:110][ 0]LogWindows: Error: [Callstack] 0x00000000444ECD43 UE4Editor-CoreUObject.dll!FLinkerLoad::FinalizeBlueprint() [d:\build\++ue4+release-4.19+compile\sync\engine\source\runtime\coreuobject\private\blueprint\blueprintsupport.cpp:1664]
                          [2018.04.06-22.41.43:110][ 0]LogWindows: Error: [Callstack] 0x00000000446A3EDB UE4Editor-CoreUObject.dll!FLinkerLoad::Preload() [d:\build\++ue4+release-4.19+compile\sync\engine\source\runtime\coreuobject\private\uobject\linkerload.cpp:3353]
                          [2018.04.06-22.41.43:110][ 0]LogWindows: Error: [Callstack] 0x00000000446730F7 UE4Editor-CoreUObject.dll!FLinkerLoad::CreateExport() [d:\build\++ue4+release-4.19+compile\sync\engine\source\runtime\coreuobject\private\uobject\linkerload.cpp:4027]
                          [2018.04.06-22.41.43:110][ 0]LogWindows: Error: [Callstack] 0x0000000044698A11 UE4Editor-CoreUObject.dll!FLinkerLoad::IndexToObject() [d:\build\++ue4+release-4.19+compile\sync\engine\source\runtime\coreuobject\private\uobject\linkerload.cpp:4250]
                          [2018.04.06-22.41.43:110][ 0]LogWindows: Error: [Callstack] 0x0000000044671862 UE4Editor-CoreUObject.dll!FLinkerLoad::CreateExport() [d:\build\++ue4+release-4.19+compile\sync\engine\source\runtime\coreuobject\private\uobject\linkerload.cpp:3648]
                          [2018.04.06-22.41.43:110][ 0]LogWindows: Error: [Callstack] 0x00000000446734CB UE4Editor-CoreUObject.dll!FLinkerLoad::CreateExportAndPreload() [d:\build\++ue4+release-4.19+compile\sync\engine\source\runtime\coreuobject\private\uobject\linkerload.cpp:2746]
                          [2
                          I haven't heard anything from Epic.

                          You can find the fix for that here:

                          https://forums.unrealengine.com/unre...53#post1411553

                          It requires changing the engine source (it's a one line change). I'll try and get another bug report submitted.
                          Able Ability System - A high performance, robust ability system for UE4. Now Available!

                          Comment


                            Originally posted by ExtraLifeMatt View Post

                            I haven't heard anything from Epic.

                            You can find the fix for that here:

                            https://forums.unrealengine.com/unre...53#post1411553

                            It requires changing the engine source (it's a one line change). I'll try and get another bug report submitted.
                            Thanks for the prompt response. Going custom engine has come up several times lately, so we'll certainly consider it. Would be nice if Epic could fix their side though..

                            --kg

                            Comment


                              HI,
                              I've recently bought your Able Ability System and integrated it into 4.19 engine (through the launcher). The problem I have is that upon opening the event graph of any ability all my events dont have context to pass and are displayed as CustomEvents

                              How it looks:
                              https://imgur.com/WwBTUeQ

                              How it should look:
                              https://imgur.com/KAbSlsO

                              What do I do wrong? I need that Context

                              edit:

                              upon opening any ability this error is displayed in the output log:

                              LogBlueprint: Warning: Node '/Game/RogueContent/Unit/Abilities/test.test:Able Ability Graph.K2Node_Event_0' missing NodeGuid, this can cause deterministic cooking issues please resave package.
                              LogBlueprint: Warning: Node '/Game/RogueContent/Unit/Abilities/test.test:Able Ability Graph.K2Node_Event_1' missing NodeGuid, this can cause deterministic cooking issues please resave package.
                              LogBlueprint: Warning: Node '/Game/RogueContent/Unit/Abilities/test.test:Able Ability Graph.K2Node_Event_2' missing NodeGuid, this can cause deterministic cooking issues please resave package.
                              LogBlueprint: Warning: Node '/Game/RogueContent/Unit/Abilities/test.test:Able Ability Graph.K2Node_Event_3' missing NodeGuid, this can cause deterministic cooking issues please resave package.

                              Same thing happens on 4.18.3,
                              Any ideas on how I can debug this problem are much appreciated
                              Thanks,
                              Last edited by Talanar; 04-07-2018, 10:43 AM.

                              Comment


                                Originally posted by Talanar View Post
                                HI,
                                I've recently bought your Able Ability System and integrated it into 4.19 engine (through the launcher). The problem I have is that upon opening the event graph of any ability all my events dont have context to pass and are displayed as CustomEvents

                                How it looks:
                                https://imgur.com/WwBTUeQ

                                How it should look:
                                https://imgur.com/KAbSlsO

                                What do I do wrong? I need that Context

                                edit:

                                upon opening any ability this error is displayed in the output log:

                                LogBlueprint: Warning: Node '/Game/RogueContent/Unit/Abilities/test.test:Able Ability Graph.K2Node_Event_0' missing NodeGuid, this can cause deterministic cooking issues please resave package.
                                LogBlueprint: Warning: Node '/Game/RogueContent/Unit/Abilities/test.test:Able Ability Graph.K2Node_Event_1' missing NodeGuid, this can cause deterministic cooking issues please resave package.
                                LogBlueprint: Warning: Node '/Game/RogueContent/Unit/Abilities/test.test:Able Ability Graph.K2Node_Event_2' missing NodeGuid, this can cause deterministic cooking issues please resave package.
                                LogBlueprint: Warning: Node '/Game/RogueContent/Unit/Abilities/test.test:Able Ability Graph.K2Node_Event_3' missing NodeGuid, this can cause deterministic cooking issues please resave package.

                                Same thing happens on 4.18.3,
                                Any ideas on how I can debug this problem are much appreciated
                                Thanks,
                                Can't say I've seen that before. That warning appears benign, since it would regenerate a NodeGuid. Did you try relaunching the Editor after you integrated the plugin into your game?
                                Able Ability System - A high performance, robust ability system for UE4. Now Available!

                                Comment

                                Working...
                                X