Announcement

Collapse
No announcement yet.

Able Ability System Info and Support Thread

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • replied
    Originally posted by ExtraLifeMatt View Post
    I went ahead and checked on this. Cooldown IS being calculated through the field, but it's not calculated within the Ability Editor (unless you're using a Branch Ability which calls an Ability). This was done on purpose to avoid not being able to iterate quickly on an Ability that has a long cooldown. I could add an option whether or not to respect cooldown while authoring Abilities, or even add an option that just clears all cooldowns - but I'm still thinking on that. I'd appreciate any feedback from people on which they prefer (or if they even want the current behavior changed).
    Sorry..I'm not completely able to follow you.
    What does "OnGetDynamicProperty_Cooldown" if not asking for cooldown at runtime?
    And what would be the best method to dynamically change the cooldown depending on variables from a context actor?

    Aswell thank you for your support and your willingness to help.

    Leave a comment:


  • replied
    Able 3.0.4 has been submitted it. Notes below:

    - Fixed an issue where you could get Ability Script NULL errors when loading the Editor.
    - Hide Collision / Camera / Arrow options now work as expected again.
    - Default to Translate Mode when selecting an actor within the Editor (this makes it clearer to the user that they can use the normal W/R/T keys to modify things).
    Originally posted by Knaarke View Post
    Hey,
    I recently started working on my project again and saw that there was an Update for Able.
    Right now it seems that the "OnGetDynamicProperty_Cooldown" function isn't even called.
    All I did was copy pasting my code from "GetCooldown"(which was marked as deprecated) to this new function.

    I read that there were bugs with dynamic fields not working. Wasn't this fixed in 3.0.3?

    I'm glad for any information or help.
    I went ahead and checked on this. Cooldown IS being calculated through the field, but it's not calculated within the Ability Editor (unless you're using a Branch Ability which calls an Ability). This was done on purpose to avoid not being able to iterate quickly on an Ability that has a long cooldown. I could add an option whether or not to respect cooldown while authoring Abilities, or even add an option that just clears all cooldowns - but I'm still thinking on that. I'd appreciate any feedback from people on which they prefer (or if they even want the current behavior changed).

    I'm still trying to decide how I want to handle Move To / Jump To. I'm leaning towards making them work only with the Character Movement Component which would greatly simplify things. Maybe split out Navigation Path Finding in to it's own Task.

    Thanks for your support and keep the feedback / bug reports coming.

    Leave a comment:


  • replied
    Originally posted by intoxicat3 View Post
    Doing jam using Able. Anyone had problems when restarting level? (only in build or DebugGame / DevGame without Editor) When destroying AblComponent it tries to call OnAbilityEndBP for "None" Ability. It isn't null but just None object... cause to crash.

    It appears when I'm extending abilities from other ones not from base c++ class.

    Code:
    Assertion failed: !IsUnreachable() [File:D:\Build\++UE4\Sync\Engine\Source\Runtime\CoreUObject\Private\UObject\ScriptCore.cpp] [Line: 1302]
    None None.None Function: 'None.None:OnAbilityEndBP'
    Interesting... Not sure what a "None" object is, or why that method would be unreachable. Can you upload your game jam project to my bug report link and give me some repro steps? https://www.dropbox.com/request/nD81ewNC7G3p5MNWlMKX

    Leave a comment:


  • replied
    Doing jam using Able. Anyone had problems when restarting level? (only in build or DebugGame / DevGame without Editor) When destroying AblComponent it tries to call OnAbilityEndBP for "None" Ability. It isn't null but just None object... cause to crash.

    It appears when I'm extending abilities from other ones not from base c++ class.

    Code:
    Assertion failed: !IsUnreachable() [File:D:\Build\++UE4\Sync\Engine\Source\Runtime\CoreUObject\Private\UObject\ScriptCore.cpp] [Line: 1302]
    None None.None  Function: 'None.None:OnAbilityEndBP'
    Last edited by intoxicat3; 05-05-2019, 09:17 AM.

    Leave a comment:


  • replied
    Originally posted by Demonrras View Post

    Pls...implement launch character in movement tasks. I wanna to make some aerial combat where I launch enemies to air and make combos...I puchase your plugin with the hope that can help me with this.
    You're going to have to get comfortable with making your own Tasks (either through Custom Task or through C++ and inheriting from UAblAbilityTask). You're going to want to just apply some Z velocity to a character and then put them in some "Air Juggle" movement state (which you'll have to create).

    Again, Movement is so game specific that it's near impossible for me to make "out of the box" solutions for people.

    Leave a comment:


  • replied
    Originally posted by ExtraLifeMatt View Post

    Move To / Jump To are entirely experimental. I'm planning to circle around to them this weekend. They may get removed as movement is such a per-game specific thing, but I'm going to see if I can't give them one more shot.


    Dynamic fields were fixed in 3.0.3, but I may have missed a spot with Cooldown. I'll verify.
    Pls...implement launch character in movement tasks. I wanna to make some aerial combat where I launch enemies to air and make combos...I puchase your plugin with the hope that can help me with this.

    Leave a comment:


  • replied
    Originally posted by Demonrras View Post
    Task to MoveTo, jump etc don't work...
    Move To / Jump To are entirely experimental. I'm planning to circle around to them this weekend. They may get removed as movement is such a per-game specific thing, but I'm going to see if I can't give them one more shot.
    Originally posted by Knaarke View Post
    Hey,
    I recently started working on my project again and saw that there was an Update for Able.
    Right now it seems that the "OnGetDynamicProperty_Cooldown" function isn't even called.
    All I did was copy pasting my code from "GetCooldown"(which was marked as deprecated) to this new function.

    I read that there were bugs with dynamic fields not working. Wasn't this fixed in 3.0.3?

    I'm glad for any information or help.
    Dynamic fields were fixed in 3.0.3, but I may have missed a spot with Cooldown. I'll verify.

    Leave a comment:


  • replied
    Hey,
    I recently started working on my project again and saw that there was an Update for Able.
    Right now it seems that the "OnGetDynamicProperty_Cooldown" function isn't even called.
    All I did was copy pasting my code from "GetCooldown"(which was marked as deprecated) to this new function.

    I read that there were bugs with dynamic fields not working. Wasn't this fixed in 3.0.3?

    I'm glad for any information or help.

    Leave a comment:


  • replied
    Task to MoveTo, jump etc don't work...

    Leave a comment:


  • replied
    Originally posted by Demonrras View Post
    How I can make hit reactions??? Like frontal hit, back hit, left and right hit....
    That is up to you. Able doesn't support that out of the box.

    I would do it where I figure out the general direction of the damage (so, just create a vector from the damage source to my actor). And then do a handful of half space tests to find the general location.

    Leave a comment:


  • replied
    How I can make hit reactions??? Like frontal hit, back hit, left and right hit....

    Leave a comment:


  • replied
    Originally posted by Demonrras View Post

    No. When I go on Ability Editor, click in TIMELINE menu and clicking in this checkbox...don't change nothing in my preview scene.

    Other issue that I see is: When select an animation task and try to change the animation...this don't change...need to delete the task and add this again with the right animation.
    Yea, I found the issue with the checkbox for Camera/ Collision. I have a fix coming.

    As long as you save the Ability (which happens automatically when you try to play an Ability), it should change the Animation during the preview. I'll check that locally as well, but I'd look at your log for any weird errors.

    Leave a comment:


  • replied
    Originally posted by ExtraLifeMatt View Post

    Clicking the Show Collision / Show Camera options in the view drop down in the Ability Editor isn't hiding those? That code hasn't changed so I'm a bit shocked it's broken.
    No. When I go on Ability Editor, click in TIMELINE menu and clicking in this checkbox...don't change nothing in my preview scene.

    Other issue that I see is: When select an animation task and try to change the animation...this don't change...need to delete the task and add this again with the right animation.

    Leave a comment:


  • replied
    Originally posted by OllieWilliams View Post

    Yup this fixed it! Thanks so much.
    Fun. Okay, then I'll find a way to fix the Able Editor Settings. If you see null classes in your allowed classes drop down, that's why.

    EDIT: Testing a workaround for the config issue, and found the issue with camera/character collision not respecting the options. Fixes incoming.
    Last edited by ExtraLifeMatt; 04-29-2019, 11:50 AM.

    Leave a comment:


  • replied
    Originally posted by ExtraLifeMatt View Post

    Check your output log. Are you sure your character has an Ability Component? The times when I've seen an ability not play it's because of one of two issues: 1.) You have a channeling condition which isn't valid when you preview (i.e. some key press), or 2.) You don't have an Ability Component and adding one dynamically is not working well (for whatever reason, still debugging that one).

    Also Custom Task compilation should be fixed as it's passing my local testing. If it's not, please give me a repro or you can upload a sample project that shows the issue here: https://www.dropbox.com/request/nD81ewNC7G3p5MNWlMKX



    Able always works for the latest 3 versions, so 4.20, 4.21, 4.22. I can't support older versions unfortunately. There is a player discord channel (I believe I link to it in the first post), but I'm not normally on there. Here is the best place to reach me.



    You can try something. Open up Able.uplugin and set the LoadingPhase for AbleEditor to "PreDefault". That's fixed that error before, but it causes some other issues with Able Editor Settings not being able to find game classes (since it loads things pre-game binary). But, if that fixes things then I'll find a work around for the other.
    Yup this fixed it! Thanks so much.

    Leave a comment:

Working...
X