Announcement

Collapse
No announcement yet.

Blue man Vehicle Physics Plugin

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • replied
    Originally posted by Theremin View Post
    Hello, I've some issues after the 4.21 update.

    If I play as listen server everything is fine, but as client the rotation of the vehicle and the sound aren't smooth. The sound isn't really a problem because I can smooth it with an interpolation, but for the rotation I'm not sure if it's a conflict with something in my project or if is the replication of the plugin.

    Has anyone had the same problem? Thanks in advance
    Yep, it's a bloody nightmare.

    Leave a comment:


  • replied
    I get a crash during gameplay:

    Code:
    Assertion failed: ModuleManager.IsModuleLoaded(ModuleName) [File:D:/Program Files/UE_4.21/Engine/Source/Runtime/Core/Public\Modules/ModuleManager.h] [Line: 263]
    02-18 20:58:04.028 16783 16812 D UE4     : Tried to get module interface for unloaded module: 'BlueManVehiclePhysics'

    Leave a comment:


  • replied
    Hello, I've some issues after the 4.21 update.

    If I play as listen server everything is fine, but as client the rotation of the vehicle and the sound aren't smooth. The sound isn't really a problem because I can smooth it with an interpolation, but for the rotation I'm not sure if it's a conflict with something in my project or if is the replication of the plugin.

    Has anyone had the same problem? Thanks in advance

    Leave a comment:


  • replied
    Here's an updated RPM Drop Fix function. This makes it so the RPM is always smooth and doesn't jump around at all. Use 'RPM Actual' for your sound and animation RPM floats.
    Attached Files

    Leave a comment:


  • replied
    Originally posted by ghostnova91 View Post

    Awesome thank you so much this really helped me out!

    If I figure out the RPM thing too I'll let you know. I have issues with my engine sounds when I handbrake.
    No problem. I actually just figured out how to fix the RPM problem:

    Make a float variable called 'RpmTemp' and follow these graphs. RL is my rear wheel which is affected by the Handbrake.

    Attached Files

    Leave a comment:


  • replied
    Originally posted by xetura View Post

    1. I just figured this out in Decemeber, but it doesn't do it immediately. It gets less sensitive the faster the vehicle goes, which helps with spinouts and roll-overs. I just can't remember which exact setting it was. I provided a screenshot of my settings. You can also lower 'steering sensitivity'.

    2. Select your mesh in your vehicle's BP and find 'Center of Mass Offset'. Lower your Z value. You can also modify the X value to adjust steering sensitivity.

    3. I believe this is supposed to be, 'wheel rolling resistance' and 'sticky tires rolling resistance multiplier'.
    Awesome thank you so much this really helped me out!

    If I figure out the RPM thing too I'll let you know. I have issues with my engine sounds when I handbrake.

    Leave a comment:


  • replied
    What I'd really like to know is how to make the RPM's not drop to 500 when I hit the eBrake. The engine should still be revving or staying somewhat still.

    Leave a comment:


  • replied
    Originally posted by ghostnova91 View Post
    Hello, I am hoping to get answers to a couple of questions I have related to the video below.

    1. In the video when I am doing those short turns I am just tapping the steering keys but the car turns quite a bit. What setting can I use to lower the amount that the car turns when just tapping the key?

    2. In the video you can see that my car flips very easily when turning. I am not sure what to do about getting it to flip less. I hope to be able to keep the flip at higher speeds and crashing.

    3. Is there a way to increase deceleration? Even at low speeds if I let go of the gas the car pretty much goes on forever.

    https://www.dropbox.com/s/5a45vs6blc...22.01.mp4?dl=0

    Thanks so much for any support you can provide.
    1. I just figured this out in Decemeber, but it doesn't do it immediately. It gets less sensitive the faster the vehicle goes, which helps with spinouts and roll-overs. I just can't remember which exact setting it was. I provided a screenshot of my settings. You can also lower 'steering sensitivity'.

    2. Select your mesh in your vehicle's BP and find 'Center of Mass Offset'. Lower your Z value. You can also modify the X value to adjust steering sensitivity.

    3. I believe this is supposed to be, 'wheel rolling resistance' and 'sticky tires rolling resistance multiplier'.
    Attached Files
    Last edited by xetura; 02-13-2019, 05:56 PM.

    Leave a comment:


  • replied
    Originally posted by ghostnova91 View Post
    Hello, I am hoping to get answers to a couple of questions I have related to the video below.

    1. In the video when I am doing those short turns I am just tapping the steering keys but the car turns quite a bit. What setting can I use to lower the amount that the car turns when just tapping the key?

    2. In the video you can see that my car flips very easily when turning. I am not sure what to do about getting it to flip less. I hope to be able to keep the flip at higher speeds and crashing.

    3. Is there a way to increase deceleration? Even at low speeds if I let go of the gas the car pretty much goes on forever.

    https://www.dropbox.com/s/5a45vs6blc...22.01.mp4?dl=0

    Thanks so much for any support you can provide.
    I have the exact same three questions.

    Leave a comment:


  • replied
    Hello, I am hoping to get answers to a couple of questions I have related to the video below.

    1. In the video when I am doing those short turns I am just tapping the steering keys but the car turns quite a bit. What setting can I use to lower the amount that the car turns when just tapping the key?

    2. In the video you can see that my car flips very easily when turning. I am not sure what to do about getting it to flip less. I hope to be able to keep the flip at higher speeds and crashing.

    3. Is there a way to increase deceleration? Even at low speeds if I let go of the gas the car pretty much goes on forever.

    https://www.dropbox.com/s/5a45vs6blc...22.01.mp4?dl=0

    Thanks so much for any support you can provide.

    Leave a comment:


  • replied
    Blue Man confirmed to me that you can't change transmission values at runtime via blueprints and said he'll patch it in the next update.

    Leave a comment:


  • replied
    I figured out why you can't set gears at runtime... you can only break the gears, not make them... well, you can change the ratio lol. I'd like to be able to change gears at runtime. Changing transmissions is a key part of my game.
    Attached Files

    Leave a comment:


  • replied
    Looks like the 4.21 update is live. Thank you, Blue Man.
    Last edited by xetura; 01-31-2019, 01:42 AM.

    Leave a comment:


  • replied
    Originally posted by Saiboat View Post
    1. open up demo project from marketplace ("VehiclePhysics 4.19")
    2. add more startpoints
    3. play with 2 players, one client, one server
    4. drive around a bit on server
    5. drive around a bit on client
    6. result: already both vehicles are out of sync https://i.imgur.com/BlUbQp2.png

    I don't believe I'm the only one trying to use this plugin in multiplayer. How did you guys fix this problem??
    I'm happy to announce that with the preview-code Blue Man sent me, under engine version 4.21.2 these issues have gone away. Although the behavior is in certain cases laggy and jolty, most of the time the vehicle is at the same location with the same roation on client and server, both with using listen server and dedicated server. I will keep an eye out on the weird behavior (sometimes location and roation are out of sync for one second or so) and try to bring these issues up in more detail, once the plugin is finally live on the marketplace.

    Leave a comment:


  • replied
    Originally posted by qdelpeche View Post

    That was 13 days ago ... so what is the excuse this time?
    Pretty much... Bandwagon time? :P Hit him up on discord for a non-package version. I did, has at least allowed me to continue working for the meantime but I need it to work packaged eventually

    Leave a comment:

Working...
X