Announcement

Collapse
No announcement yet.

Including Demo Assets from Epic example content & Supported Engine Versions

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    [SUPPORT] Including Demo Assets from Epic example content & Supported Engine Versions

    hi there

    A couple of questions (forgive me if they've been answered elsewhere)...

    1) Is it ok to include assets from the starter content and/or any of Epic's learning content in the demo map for the marketplace assets to show how it is to be used in context? For some of the assets I want to release, it would make it a lot easier if I were to be able to just use some freely available meshes to put together a demo level.

    2) When supporting multiple engine versions, how are we supposed to be able to support new engine features? For example if I want to support the upcoming 4.15 with the new material re-route nodes AND be ale to support 4.14, is that possible? Or do we have to just support the minimum features available so that it is compatible with both. Are we able to submit multiple packages for each engine version and the right one will get installed?

    Thanks
    Dan
    Visual Effects Artist, Weta Digital, Wellington New Zealand
    BLOG www.danielelliott.co.uk
    @danielelliott3d https://twitter.com/danielelliott3d
    Unreal Engine and VFX Tutorials https://www.youtube.com/user/DokipenTechTutorials
    2015 Showreel: https://vimeo.com/116917817

    #2
    Originally posted by dokipen View Post
    hi there

    A couple of questions (forgive me if they've been answered elsewhere)...

    1) Is it ok to include assets from the starter content and/or any of Epic's learning content in the demo map for the marketplace assets to show how it is to be used in context? For some of the assets I want to release, it would make it a lot easier if I were to be able to just use some freely available meshes to put together a demo level.

    2) When supporting multiple engine versions, how are we supposed to be able to support new engine features? For example if I want to support the upcoming 4.15 with the new material re-route nodes AND be ale to support 4.14, is that possible? Or do we have to just support the minimum features available so that it is compatible with both. Are we able to submit multiple packages for each engine version and the right one will get installed?

    Thanks
    Dan
    Hey there.

    1) It's fine to include the content provided for free by Epic (but only Epic) in marketplace submissions, but only if it is for demonstration only. You can't be submitting something where that is the majority or selling point of your pack.

    2) You can submit multiple packages. One for each version. However, as long as it is compatible then you don't need to if you don't want to.

    Comment


      #3
      [MENTION=5960]apoisonedgift[/MENTION] is correct.

      But i think it's always good to provide multiple versions. This way you provide several options for developers who have not yet migrated to the latest version of the engine. At least the last ones (It's just my opinion).


      MarketPlace Assets:|Time SHIFT| |Quick Gravity Tools|

      {Time SHIFT Free Demo} |Quick Gravity Tools Free Demo| {Time SHIFT Forum Thread}

      |Facebook| |Youtube| |E-mail|

      Comment


        #4
        When submitting your product just let Epic know that you have specific project files for 4.14 and 4.15. You don't have to submit a new project each engine release unless manual work is required to maintain compatibility with a new release. Otherwise you can just extend the compatibility of the product through the seller portal. Good luck! =)

        Simulacrum Game | Play The Alpha | Caldera Entertainment | Twitter | ArtStation

        Comment

        Working...
        X