Announcement

Collapse
No announcement yet.

Feedback on the new docs site

Collapse
This is a sticky topic.
X
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    On dynamic delegates page brackets are broken in the "Declaration macro" section

    Comment


    • echo_four commented
      Editing a comment
      Hey IrSoil! Thanks for the great feedback (attaching that image is especially helpful). I'll pass this along so we can look into updating that page. Please let us know if you spot anything else that looks off!

    Click image for larger version

Name:	1.jpg
Views:	154
Size:	90.8 KB
ID:	1833568
    https://docs.unrealengine.com/en-US/...ces/index.html

    Comment


    • echo_four commented
      Editing a comment
      Good eye 305715030. I'll create a ticket so that we can update that page pronto. In the meantime, please let us know if you spot anything else that looks off.

    https://docs.unrealengine.com/en-US/...r/2/index.html

    On the above page I believe these is a typo in Section 2.7 where it says to "Include the following header files to FPSCamera.h.". That file doesn't exist in the project at the moment and I believe it should be "Include the following header files to FPSCharacter.h."

    Comment


    • echo_four commented
      Editing a comment
      Hey nleyder! Thanks for reaching out to us. I've made a ticket for us to look at that page asap. Please let us know if you spot anything else that looks off.

    Using Unreal Editor 4.25, in the "Programming Quick Start" guide, section 4 "Compile and Test Your C++ Code", step 3, the cube doesn't appear in the perspective viewport when I drag it there, nor does the Details panel contain a Transform section for the new FloatingActor (and there is no red dot next to its name in the outliner, unlike the step 4 screenshot), unless I click the Compile button at the top of the Unreal Editor window -- just compiling the code in Visual Studio is not enough, the last sentence of step 1 is not optional.

    Sorry for wasting your time with such a trivial misstatement but I just spent far too long finding out why I couldn't follow along.

    Comment


    • echo_four commented
      Editing a comment
      Hey verdyss! No suggestion is too small. Sorry for the unintended confusion and I've made a ticket to update that doc. Please let us know if you spot anything else that looks off.

    https://docs.unrealengine.com/en-US/...low/index.html has a link to the Unreal Engine repository on GitHub so UE can be built on Linux, but the repository is no longer there.

    Comment


    • echo_four commented
      Editing a comment
      Hey eyeclick! Thanks for reaching out to us. I've created a ticket so that we can look into correcting that article. Please let us know if you spot anything else like this that looks off.

    https://docs.unrealengine.com/en-US/...put/index.html
    Should include instructions on how to enable the "r.AllowHDR" console variable, without it the "Enable HDRDisplay Output" function doesn't work.

    Comment


    • echo_four commented
      Editing a comment
      Hey MarkJG, thanks for the recommendation. I've made a ticket so that we can look into adding that info to that page. Let us know if you think of anything else that we can add to that page to improve it.

    https://docs.unrealengine.com/en-US/...API/index.html
    1. Request URL:
      https://docs.unrealengine.com/en-US/...API/index.html
    2. Request Method:
      GET
    3. Status Code:
      403
    4. Remote Address:
      23.2.133.195:443
    5. Referrer Policy:
      strict-origin-when-cross-origin

    Comment


    • echo_four commented
      Editing a comment
      Hi 305715030. Thanks for letting us know about that broken link. We actually already have a ticket logged to look into that. I've bumped that ticket and asked the owner for an update. Thanks again for your feedback.

    I'm trying to learn the API through the documentation, but the documentation I'm working with doesn't seem to work.
    https://docs.unrealengine.com/en-US/...nts/index.html
    Maybe I'm posting to the wrong area, but my mesh isn't spawning. I noticed that the documentation is for v.24 and I'm on v.25. Was there an API update in v.25? If so, could someone point me to the change log that explains what part they changed that doesn't allowed official documentation to work? I've gone over my code a couple times to make sure I didn't typo, I think its all good on my end. Thanks

    Comment


    • echo_four commented
      Editing a comment
      Hey Haragoth! Thanks for reaching out to us. Here are the minor release notes for 4.25, I hope they help: https://docs.unrealengine.com/en-US/..._25/index.html. Otherwise, could you give us some more details around where the process is failing (specific steps and errors are appreciated).

    Im trying to figure out modular skeletal meshes and ive come to find out that this https://docs.unrealengine.com/en-US/...ers/index.html doc does absolutly nothing and does not work. The code is broken

    Comment


    • echo_four commented
      Editing a comment
      Hello ItsSharp. Thanks for reaching out to us. Would you mind providing more details as to where it's broken?

    Yeah so it seems the code you guys have provided does not compile at all. Without the code working the whole doc doesnt work at all. I dont if it could just be something changed in an update but it just does not work. I have fixed it but the fixed code does not affect the project at all and doesnt seem to do what the doc says it will. Thank You!

    Comment


    • echo_four commented
      Editing a comment
      Thanks for the additional information ItsSharp. I've passed this along to the rest of the Docs team so we can look into updating that page. Please let us know if you run into anything else that isn't working and we'll be sure to make note of it.

    Hello,

    I think UnrealBuildTool documentation has nothing to do with UnrealBuildTool

    Its talking about conceptial stuff.

    But my IDE executes this: "<path>\Build.bat" <project_name> HTML5 Shipping -Project="<some>.uproject" -WaitMutex -FromMsBuild

    And there's no doc for other options than "-WaitMutex.". I don't think it even mentions there's BAT file to use the tool.

    Sadly there's no API docs either. Look at this (random example): "FLauncherChunkInstaller" description: "Launcher Implementation of the platform chunk install module" but what is it doing? why did you have to implement this?


    Summary: We need practical everyday life (with real-world examples) access to what's inside UE4 in docs.

    Comment


    • echo_four commented
      Editing a comment
      Hey SDarkSun! Thanks for reaching out to us. We're sorry that the current UBT documentation doesn't have what you're looking for. Let me pass this request along to the rest of the Docs team to see what we can do. Please let us know if you spot any other topics that could benefit from elaboration.

    [Blueprint Interface] There is a point that once i was confused could be added in Blueprint Interface page. Please consider it. Thank you.
    Note : "Interface's function events could only be created when these functions have no output parameter."
    I check the interface page (Location : Blueprints Visual Scripting - Specialized Node Groups - Types of Blueprints - Blueprints Interface), there is no tip about that.
    So if it's appropriate, could you add a tip for that to make others know that? And it will be nice if adding more mechanisms.
    Thanks for your looking over.

    Comment


    • echo_four commented
      Editing a comment
      Hey HolmeNiu! Thanks for reaching out to us, and thank you so much for taking the time to submit this suggestion. I've passed along a ticket to the rest of the Docs team that includes your suggestion. We'll take a closer look and see what we can do to incorporate your feedback. Thanks again, and please let us know if you think of anything else that we could include to improve the documentation!

    When reading documentation on any page that lets you open a higher quality version of a diagram after closing the diagram you are unable to scroll up or down because the body overflow is set to hidden.
    Click image for larger version

Name:	bugReportDevTools.png
Views:	101
Size:	123.1 KB
ID:	1838416


    ---
    Steps to reproduce:
    Chrome Version 87.0.4280.88 (Official Build) (64-bit) - latest
    New incognito window
    Url: https://docs.unrealengine.com/en-US/...ent/index.html
    Accept cookies (*)
    Scroll to bottom of page
    Switch to dark theme
    Click the picture (https://docs.unrealengine.com/Images...ampleUsage.png) that is right above the Switch theme button
    Close the pop-up
    You should have no scroll bar now and be stuck

    ---
    Did not reproduce on IE 11

    Comment


    • echo_four commented
      Editing a comment
      Hey imRaduR! Thanks for reaching out to us. I haven't experienced this, but we can certainly look into it. I've created a ticket and sent it to the rest of the Docs team so we can investigate. Thanks again and please let us know if you see anything else on the page that looks off.

    Hi!
    Some pictures are missing at https://docs.unrealengine.com/en-US/...***/index.html
    It's just an example, there are some more unloaded images

    Comment


    • Jeff Wilson commented
      Editing a comment
      Are you still seeing this issue? The site was in the process of being updated at the time so that might have led to some issues. I am not seeing any broken images on that site at the moment.

    Everything works well now, thanks

    Comment


    • echo_four commented
      Editing a comment
      Glad to hear it GhermanOsipov. Let us know if you experience any other issues.
Working...
X