Announcement

Collapse
No announcement yet.

Feedback on the new docs site

Collapse
This is a sticky topic.
X
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    echo_four Ok so two specific issues I ran into recently:
    1. Gameplay debugger page should have some mention that it`s being deprecated. I couldn`t get it to work and only in a config file I have found a mention that it`s being remade into a plugin.
    https://docs.unrealengine.com/en-US/...ger/index.html
    Maybe it`s unrelated, maybe a bug with non-english keyboards, but still, it would be good to know the current status of the feature.

    2. Light functions should have a mention that they require shadow casting enabled to work. That cost me about an hour to figure out by trial and error.
    https://docs.unrealengine.com/en-US/...3_2/index.html
    I know there`s an image with shadow there, but it`s not exactly obvious when it`s not stated.

    Comment


    • echo_four commented
      Editing a comment
      Hey Eskel! Thanks for pointing both of these things out to us. I've created separate tickets for them both and passed them along. Please let us know if you find anything else you think we should look into!

    • echo_four commented
      Editing a comment
      Hey Eskel. I appreciate you hanging in there while we looked into this stuff. From what I can find, the Gameplay Debugger has not been depreciated. Would you mind helping us out by letting us know where you heard that it was? If you're having trouble bringing it up, could you give us some more insight into what's happening when you try to?

    Did the AI stuff but it is extremely hard to know which blueprint is what. Seems like I did something wrong and cant figure out what. My AI is wether moving or having any gravitation. Just stays there like an static mesh. However I will delete all the trash and build some tutorial on youtube...

    Think this waste of time was a lesson for me to never use the UE docs in the first place.

    EDIT: Okay after deleting one "move to" and creating a new one it worked .. No idea what the problem was
    Last edited by Acanku; 05-05-2020, 01:07 PM.

    Comment


    • echo_four commented
      Editing a comment
      Hey Acanku! I'm sorry to hear you were having trouble (but glad to hear you got it sorted). Was there a doc page(s) that had any errors that caused this issue? If so let me know and I can look into it.

    Don't see Chaos in the 4.25 release.

    Comment


    Can you add the ability to post feedback on each documentation page, similar to the microsoft doco site.

    Also can someone fix the USTRUCT page
    https://docs.unrealengine.com/en-US/...cts/index.html

    The example is wrong.

    Comment


    • echo_four commented
      Editing a comment
      Hey ShrewdTactician! We can look into that. In the meantime, your best bet is posting any docs feedback you have to these forums. I'll also pass along your feedback on the USTRUCT page.

    • echo_four commented
      Editing a comment
      Hey ShrewdTactician! I just wanted to follow up and let you know I've updated the example. The changes should be live in a few days when they're published. Thanks again!

    Originally posted by Acanku View Post
    Did the AI stuff but it is extremely hard to know which blueprint is what. Seems like I did something wrong and cant figure out what. My AI is wether moving or having any gravitation. Just stays there like an static mesh. However I will delete all the trash and build some tutorial on youtube...

    Think this waste of time was a lesson for me to never use the UE docs in the first place.

    EDIT: Okay after deleting one "move to" and creating a new one it worked .. No idea what the problem was
    It seems like something is wrong in the blueprints I'm working with. Even when everything compiles correctly, it keeps spitting errors. I assume some tick overlaps or something because when I set some ticks slower, I have waaaay less errors. But this is something I have to figure out in my project..

    Thank you anyway!

    Comment


    • echo_four commented
      Editing a comment
      Hey Acanku. I hear ya. Thanks for following up and I wish you the best with your project. Please let me know if there's anything documentation-wise I can help clear up.

    Hello,
    no Idea if this potential error already has been mentioned but in my understanding in the Multiplayer Programming Quickstart Guide in section 5.5 the Code has to be added to the constructor in the ThirdPersonMPProjectile.cpp not the .h .

    Comment


    • echo_four commented
      Editing a comment
      Hey r03n3! Thanks for pointing this out. I've passed this along so we can look into getting this update. Thanks again, and please let us know if you spot anything else you think we should look into.

    • echo_four commented
      Editing a comment
      Hey r03n3! This should be fixed now. Thanks again for the feedback, and let us know if you spot anything else that looks off.

    [Suggestion] Please place dark/light theme selection tab on top of page not the bottom. Scrolling down everytime to change the theme while reading the docs is a bit bothersome. Thank you !

    Comment


    • echo_four commented
      Editing a comment
      Hey GmakerDOB! Thanks for the suggestion. I'll pass this along so we can look into it. Let us know if you think of anything else that might make that Docs site easier to use.

    In some documentation ( Drag and Drop operation one for example https://docs.unrealengine.com/en-US/...rop/index.html ) it would be nice if the tutorial explained what something is used for when new blueprints/widgets is created (e.g. in this case the WidgetDrag) to teach the user what is going on, instead of being step by step reproduction of certain function. Would be better teaching material, and less just copying and not knowing what is going on till close to end
    Twitter@Detocroix

    Comment


    • echo_four commented
      Editing a comment
      Hey Detocroix! Thanks for reaching out. I think I get what you're saying. Rather then just explaining HOW to do something, maybe taking a bit more time to say WHY you're doing it. We try to include NOTE boxes where able (to elaborate on points) and hyperlink to other pages that give more info. That said I understand your suggestion and will pass it along.

    I don't know if this is the right place to report it, but in the Drag and Drop Operation tutorial it tells you to create a "Drag and Drop Operation" node, but if you write the name of the node in the right click menu, you won't find it. However if you search it without "and" (or "&" like in my case) you can find the node. And when you place the node, the node has wrong header name ("Create Drag Drop Operation" instead of "Create Drag And Drop Operation"

    Click image for larger version

Name:	drag-and-drop.png
Views:	188
Size:	97.8 KB
ID:	1757411
    Twitter@Detocroix

    Comment


    • echo_four commented
      Editing a comment
      Hello again Detocroix! I'm glad you got it sorted out. I can make a ticket to clarify the steps/images (Or maybe add a NOTE box to help people with node-naming/locating nodes). Thanks again for the suggestion.

    • echo_four commented
      Editing a comment
      Hey Detocroix! I just wanted to let you know I addressed this (you should see the fix once it's published in a few days). I tweaked the language to make it easier to find the Drag Drop node. Thanks again for your help, and please let us know if you spot anything else that could be clearer.

    Some pages like the plugins overview page are broken, and just load to the index. This link comes up first in the result for search for plugins.

    https://docs.unrealengine.com/en-US/...ins/index.html

    Comment


    • echo_four commented
      Editing a comment
      Hey ShrewdTactician! Thanks for pointing this out to us. I've passed this along so we can look into it.

    Same with the modules page:
    https://docs.unrealengine.com/en-US/...API/index.html

    Comment


    • echo_four commented
      Editing a comment
      Thanks for pointing this out to us ShrewdTactician. I've let the rest of the docs team know, and we're looking into it.

    Yes, many pages are broken in this way. And apparently it only affects the pages I need
    Here's another that's busted:
    https://docs.unrealengine.com/en-US/...ext/index.html

    Comment


    • echo_four commented
      Editing a comment
      Hey RonP! Thanks for letting us know. Yeah it looks like a few pages/links are broken in this way. I've passed your comments along and will give an update as soon as I know more.

    the two side panels for "docs.unrealengine.com" is taking up too much visual real estate, please hide them.

    Comment


    • echo_four commented
      Editing a comment
      Hey pickersZ! Thanks for the suggestion. I'll pass this along and see what we can do to free up some space.

    I cant look up the other delegate C++ doc because they keep sending me back to the index.
    https://docs.unrealengine.com/en-US/...tes/index.html

    Comment


    • echo_four commented
      Editing a comment
      Hey RowdyWabbid! Thanks for letting us know. There looks to be something going on with a few docs pages. I've passed your comments along and will post an update once I know more.

    Documentation doesn't say where texture compression. And I cannot find it

    Comment

Working...
X