Announcement

Collapse
No announcement yet.

High resolution display support for editor

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    High resolution display support for editor

    I use a 4k monitor and the ue4 editor font size and UI elements are borderline on usability due to small physical size with my display's high DPI (24 inch ips at 3840x2160). Many of the applications in my pipeline (though not all yet, so ue4 is hardly alone) , offer scaling options, or can be configured to. Is there a way to raise the font size without Windows pixel doubling (unacceptable to use), and if not, any current plans to provide this type of support? Thanks for your time.

    #2
    Hi ShipWorthyGames,

    Go to the menu bar at the top > Window > Developer Tools > Widget Reflector

    Once here you can change the "Application Scale" and change the value.

    This will not just change the font size though. It scales the Slate windows that make up the editor.

    Click image for larger version

Name:	Widgetsize.png
Views:	1
Size:	68.3 KB
ID:	1052362
    Click image for larger version

Name:	widgetsize2.PNG
Views:	1
Size:	12.8 KB
ID:	1052363

    Thank you!

    Tim
    Tim Hobson | Learning Resources | Epic Games
    UE4 Documentation

    Comment


      #3
      Hello Tim, thanks, that's exactly what I needed! It doesn't persist through reloading the editor as far as I'm finding but that's no big deal to set each time. Have a good evening.

      Comment


        #4
        This is great, scaling to .8 or .9 makes my 15 inch macbook much more usable. Saving this setting would be pretty neat anyway, can we configure this through some configuration file?
        Any update about hdpi support on mac? lowering the scale would be much easier if retina display was correctly supported..

        Comment


          #5
          @ShipWorthyGames: I'm glad that works for you. I wasn't aware it couldn't be saved. I'll ping on of the devs on Monday when they're all back and see if there is a way to save that setting or if it's not yet possible.

          @Devel.bmad: Not sure on the HDPI for Mac. I'll see if I can find an answer to this as well.

          Tim
          Tim Hobson | Learning Resources | Epic Games
          UE4 Documentation

          Comment


            #6
            @Tim Hobson: Ok, thank you, I'm really looking forward for it.

            As concern scaling: testing a bit more the functionality I found a weird behaviour on mac (I'm still at UE 4.1.1), apparently if I scale to .9 the scene outliner, the details panel and the world panel don't get mouse click correctly. They do seem to get focus overing the mouse, but for example I'm not able to drag the scrollbar or select a different tab.
            Same behaviour for some of the dialogs (e.g. saving assets): I can close the dialog, but I cannot check/uncheck items or click any button.

            Turning scale back to 1.0 fixes the problem. I'm on a macbookpro and I'm using the touchpad, are you able to replicate the problem?
            Last edited by devel.bmad; 07-04-2014, 10:52 AM.

            Comment


              #7
              Yeah that is a known issue. If I remember right, there was submitted a while back as a bug. I think when I noticed it it was around .9 and lower on my screen that I could no longer click the "X" to close a window and use some of the buttons. I should have mentioned that earlier, but didn't happen to think about it.

              Tim
              Tim Hobson | Learning Resources | Epic Games
              UE4 Documentation

              Comment


                #8
                Originally posted by Tim Hobson View Post
                @ShipWorthyGames: I'm glad that works for you. I wasn't aware it couldn't be saved. I'll ping on of the devs on Monday when they're all back and see if there is a way to save that setting or if it's not yet possible.

                @Devel.bmad: Not sure on the HDPI for Mac. I'll see if I can find an answer to this as well.

                Tim
                Hi Tim,

                Are the Dev's still working on saving the 'Widget Reflector' settings (e.g. scale) after restarting?
                I can easily set my scale to 1.5 every time I run UE4.3, but would be better if I didn't have to.

                Comment


                  #9
                  The technique the widget reflector uses to handle scaling the UI is not sufficient for supporting HiDPI OpenGL Rendering on OS X. We'd need to make many more changes, especially to mouse handling as you have discovered, for it to work correctly. It is something we will support eventually, but I'm not sure when.

                  Comment


                    #10
                    Thx for your solution, Tim.
                    But there seems to be a display bug when set the application scale to above 1, I can't select the actors accurately in viewport, there always be some deviation of the mouse click position. And the deviation increased with the scale value .
                    the propose is just adjust the text font size, but now it did not work well when using editor.Hope to reply soon

                    Comment


                      #11
                      this bug(cant save widget size) still exist on version 4.6

                      Comment


                        #12
                        I had this problem today and figured out a solution. Somehow when working today, I must have hit a keyboard shortcut that had turned on a Windows feature for UE4Editor.exe called "Disable display scaling on high DPI settings". This can be found if you look at Properties on the UE4Editor.exe. Click the Compatibility tab in Properties and uncheck that. I have no idea what happened to me, but the whole editor all of a sudden scaled down. The splash screen was also scaled down. I noticed that other installs of UE4 didn't have this checkbox set. Windows set it somehow behind my back while working.

                        Comment


                          #13
                          Originally posted by 团子Zero View Post
                          Thx for your solution, Tim.
                          But there seems to be a display bug when set the application scale to above 1, I can't select the actors accurately in viewport, there always be some deviation of the mouse click position. And the deviation increased with the scale value .
                          the propose is just adjust the text font size, but now it did not work well when using editor.Hope to reply soon
                          Yup, nice feature and yet so unusable due this the selection offset bug. Would be great if you guys could fix that.

                          Comment


                            #14
                            Though helpful, the Widget Reflector is still at best a temporary fix. That the editor runs on OS X is an absolute dream come true. Yet half the macs with the guts to run it (MBP's and Mac Pro's) are run with monitors upon which you get a sub-standard product. It's not just cosmetic, either, since visual feedback is so central a part of the tool.

                            I can't recommend enough anyone reading this to visit https://trello.com/c/D0SC1m1e and vote for this feature.

                            Comment


                              #15
                              I can't say how much important is to have a proper option like this with a laptop and 1080p, however, I don't expect Epic to fix this, I mean, even the Windows scale option it's pretty broken (since the beginning), so... in the meantime, when I'm working with the laptop I will be like this:

                              Comment

                              Working...
                              X