Announcement

Collapse
No announcement yet.

Bake Material Position Offset Doesn't Work

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • replied
    Originally posted by Slavq View Post
    Hey, how is that supposed to work? I just tested it like that: https://imgur.com/a/xHlTWyL

    ... After checking "Bake Material Position Offset Into Collision" it says that it rebuilds grass maps, but when I play, the character falls through the terrain, so the terrain that you see on my screenshot doesn't have any collision at all. It also blinks, maybe because of bound culling, since it has a big offset...?

    https://gfycat.com/cooperativelivegelada-mycfavisit

    ... Is it because the landscape is still visually offset and the 'true' collision is created at non-offset location...? I don't know. Any ideas? I'm on 4.22.
    I'd be grateful for any working example. Maybe I do something wrong.
    Thank you for posting something like this
    Last edited by RobertAOY; 08-12-2019, 12:38 AM.

    Leave a comment:


  • replied
    Hey, how is that supposed to work? I just tested it like that: https://imgur.com/a/xHlTWyL

    ... After checking "Bake Material Position Offset Into Collision" it says that it rebuilds grass maps, but when I play, the character falls through the terrain, so the terrain that you see on my screenshot doesn't have any collision at all. It also blinks, maybe because of bound culling, since it has a big offset...?

    https://gfycat.com/cooperativelivegelada

    ... Is it because the landscape is still visually offset and the 'true' collision is created at non-offset location...? I don't know. Any ideas? I'm on 4.22.
    I'd be grateful for any working example. Maybe I do something wrong.

    Leave a comment:


  • replied
    It, works, but not too accurate.

    Without:




    With:


    Leave a comment:


  • started a topic [EDITOR] Bake Material Position Offset Doesn't Work

    Bake Material Position Offset Doesn't Work

    Hello,

    Bake Material Position Offset doesn't seem to be working with tiled landscapes. When I check it on each landscape tile the collision doesn't change. i.e I make a hole using WPO and I still get to walk on the empty surface as if it was not deformed using WPO.

    Version: 4.12-4.13
Working...
X