Announcement

Collapse
No announcement yet.

IAP-Enabled games get rejected from the iOS Store in 4.12

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    IAP-Enabled games get rejected from the iOS Store in 4.12

    We submitted our game to iOS Store this week expecting it to pass with flying colours, but it keeps being rejected because of In-App Purchases not working over IPv6 networks. We followed all the instructions as provided here.

    There is already an existing post both on Answerhub and the Forums on this issue, so far with no official response.

    Seems like this issue isn't isolated to just us, and we don't really have a way of fixing it. Any chance for some official feedback on this issue?

    Our feedback from the App Store, just for proof:

    Click image for larger version

Name:	14075080_10154348435989854_1402997388_o.png.jpg
Views:	1
Size:	41.9 KB
ID:	1191988

    #2
    Hmm thats a worry, it is now (since July 1st a requirement that your app can run on iPV6 only networks). Have you tried to test your app and see what logging you get? - not sure if I have seen this mentioned in the 4.13 notes. Had kind of assumed UE4 was already IPv6 compliant.

    Comment


      #3
      BUMP

      This is still a problem for us, no official word so far and we're pretty sure we've done nothing wrong :/

      Comment


        #4
        Hi TheJamsh,

        We actually uploaded a version of Unreal Match 3 on 4.12, which has IAP enabled. Samantha responded to the other thread saying that she checked w/Platform Team and IPv6 support is in as well ( https://forums.unrealengine.com/show...r-IPv6-network ), so it may be best to log an AnswerHub post with your particular issue. Thanks!

        Comment


          #5
          We're still having problems with this, still no response on the Answerhub thread in question so posting here.

          Our full version of the game is also being rejected now for the same reason, despite having already been on the Store before and having no in-app purchases. Apparently this could be something to do with IOSEngine.ini, but surely there's no possible way for us to disable IPV6 anyway?

          Apparently - this config file was added to our builds for this submission only. We're not disabling IPv6 anywhere are we? I don't understand why this isn't working...

          Code:
          [/Script/BuildSettings.BuildSettings]
          bCompileAPEX=False
          bCompileBox2D=False
          bCompileICU=True
          bCompileSimplygon=False
          bCompileLeanAndMeanUE=True
          bIncludeADO=True
          bCompileRecast=True
          bCompileSpeedTree=False
          bCompilePhysXVehicle=False
          bCompileFreeType=True
          bCompileForSize=True
          bCompileCEF3=False
          
          [Audio]
          AudioDeviceModuleName=IOSAudio
          ; Defines a platform-specific volume headroom (in dB) for audio to provide better platform consistency with respect to volume levels.
          PlatformHeadroomDB=0
          
          [OnlineSubsystem]
          DefaultPlatformService=IOS
          
          [Advertising]
          DefaultProviderName=IOSAdvertising
          
          [SlateRenderer]
          NumPreallocatedVertices=200
          Our previous submission for our full version of the game didn't have this problem and didn't include this config file, which surely means we're already supporting IPv6? So why would adding this file cause it to be rejected?

          We have to have this file for the Lite version (with ads / in app purchases) - so deleting it isn't really an option, there must be something somewhere that's turning it off :/

          Comment


            #6
            It looks like you are missing this setting:

            Code:
            [OnlineSubsystemIOS.Store]
            bSupportsInAppPurchasing=True

            Comment


              #7
              Hi Chris,

              We've tried that, we also had it in DefaultEngine.ini. Here's our updated settings:

              Code:
              [/Script/BuildSettings.BuildSettings]
              bCompileAPEX=False
              bCompileBox2D=False
              bCompileICU=True
              bCompileSimplygon=False
              bCompileLeanAndMeanUE=True
              bIncludeADO=True
              bCompileRecast=True
              bCompileSpeedTree=False
              bCompilePhysXVehicle=False
              bCompileFreeType=True
              bCompileForSize=True
              bCompileCEF3=False
              
              [Audio]
              AudioDeviceModuleName=IOSAudio
              ; Defines a platform-specific volume headroom (in dB) for audio to provide better platform consistency with respect to volume levels.
              PlatformHeadroomDB=0
              
              [OnlineSubsystem]
              DefaultPlatformService=IOS
              
              [Advertising]
              DefaultProviderName=IOSAdvertising
              
              [OnlineSubsystemIOS.Store]
              bSupportsInAppPurchasing=True
              IsAllowedToMakePurchases=True
              
              [SlateRenderer]
              NumPreallocatedVertices=200

              Comment


                #8
                My only other suggestion is to make sure you have this in your project's build.cs:

                Code:
                if (Target.Platform == UnrealTargetPlatform.IOS)
                {
                    PrivateDependencyModuleNames.AddRange(new string[] { "Core", "CoreUObject", "Engine", "OnlineSubsystem" });
                    DynamicallyLoadedModuleNames.Add("OnlineSubsystemIOS");
                }
                If this isn't it, I'd recommend creating your own AnswerHub post for this issue.

                Comment


                  #9
                  Yeh we've got that, been using App Store functionality for ages which all works fine (Game Center etc).

                  Made an answerhub post here: https://answers.unrealengine.com/que...ios-store.html

                  Comment


                    #10
                    So according to Answerhub, this is indeed an engine issue it seems.

                    Not entirely sure why some apps are getting through and others aren't in that case, since I'm assuming you didn't make these changes [MENTION=438596]game[/MENTION]DNAStudio

                    Comment

                    Working...
                    X