Announcement

Collapse
No announcement yet.

OpenGL ES 3.1 / 3.2 for Gear VR

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    [FEATURE REQUEST] OpenGL ES 3.1 / 3.2 for Gear VR

    While Vulkan is the future, there is no support for VR on mobile in current Vulkan API.

    Looking at https://en.wikipedia.org/wiki/OpenGL_ES#OpenGL_ES_2.0 I can see that ES 3.0+ offers a lot more goodies than ES 2.0

    According to Oculus, UE4's ES 3.1 renderer is not "compatible" with Gear VR as Epic chose to not bother with ES 3.1 and move toward Vulkan. It's all good for regular mobile of course. Meanwhile mobile VR folks are stuck with ES 2.0

    Could Epic please reconsider and add support for Gear VR to ES 3.1 renderer ? (and enable ES 3.1 to be selectable in Project Settings so that we don't have to build engine from source to get ES 3.1 working)

    Thanks

    P.S. Vulkan is the future, I know that.. But if that future doesn't come this year (which it won't) or in 2017, might as well give mobile VR devs better renderer than ES 2.0 until Vulkan for mobile VR is implemented and well tested.

    #2
    Hello, it's been two years from this topic. I'm curious about GearVR and Open GL ES 3.1 support. Is it possible now? Vulkan still not possible. Does anyone know?

    Comment


      #3
      Originally posted by smbv1 View Post
      Hello, it's been two years from this topic. I'm curious about GearVR and Open GL ES 3.1 support. Is it possible now? Vulkan still not possible. Does anyone know?
      Not possible, but Oculus said they will announce something about Vulkan soon (but no ETA on that)

      Comment


        #4
        Hello, I have opened scene from UE GearVR documentation. It's empty scene, and I have changed some settings there, I have disabled Open GL ES2 and enabled ES 3.1, I have also switched to materials preview to Android GL ES 3.1 and run it in the GearVR with Samsung S8, and it worked fine!
        I'm confused, how to check which Open GL is currently running? Maybe some settings have not been updated and I still on GL 2?
        Attached Files

        Comment


          #5
          Maybe because S8 is quite powerful? According to both Epic and Oculus, UE4 ES 3.1 renderer is not optimized for Gear VR and it runs in deferred and not forward. I develop on S6 and with ES 3.1 it always runs at 30 fps.

          Comment


            #6
            What does it mean for me, is that I can develop for GearVR and use Open GL ES 3.1 without any problem since Samsung S8 and GearVR and Unreal Engine 4.18.3 fully supports it? I did not notice any frame drops on this. I have compiled scene with GL2 and GL3 and compared FPS, and I see no difference. Is that right? How to check Forward rendering ON/OFF?

            What if I enable GL2 and GL3.1 in the project settings at the same time, what it's going to change?

            Comment


              #7
              Originally posted by smbv1 View Post
              What does it mean for me, is that I can develop for GearVR and use Open GL ES 3.1 without any problem since Samsung S8 and GearVR and Unreal Engine 4.18.3 fully supports it?
              Except it doesn't support it. We just had this discussion on Oculus official development forums and the verdict was to use GLES2 until Vulkan support is provided. If you want to use ES3.1 as-is, by all means do it.

              Originally posted by smbv1 View Post
              .... Forward rendering ON/OFF?
              You don't - ES3.1 in UE4 doesn't support forward path. Only deferred.

              Comment


                #8
                Okay, now it's clear. Thank you very much motorsep

                Comment

                Working...
                X