Announcement

Collapse
No announcement yet.

disable reflection from a light

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    [FEATURE REQUEST] disable reflection from a light

    Hello,

    It would be very useful if there was a checkbox in spotlight / pointlight actors, that would enable or disable the light's reflection of glossy surfaces. I have experience with vray renderer and this was a very useful feature.

    Thank you.

    #2
    every light has a "min. Roughness" Parameter that exactly does that.
    Click image for larger version

Name:	Unbenannt.jpg
Views:	1
Size:	77.4 KB
ID:	1111869
    Click image for larger version

Name:	Unbenannt.jpg
Views:	1
Size:	86.2 KB
ID:	1111870
    Last edited by Raildex_; 07-11-2016, 02:59 PM.

    Comment


      #3
      Originally posted by Raildex_ View Post
      every light has a "min. Roughness" Parameter that exactly does that.
      Thank you for your reply Raildex_.
      Your solution works only in certain situations, when the environment actors around the light have non-reflective materials on them. When there are assets which are more reflective, the roughness of the light, just diffuses the reflection across the surface of the objects, thus making them washed out.

      Here is what I mean:
      I have a mirror placed in the scene and you can see clearly how the reflection washes out the reflection of the mirror (also it has effect on other actors that are reflective, but not to that extent)

      Click image for larger version

Name:	LightsOFF.jpg
Views:	1
Size:	318.2 KB
ID:	1111966
      Click image for larger version

Name:	lightsONroughness1.jpg
Views:	1
Size:	335.2 KB
ID:	1111967


      So setting the roughness to 1 is viable temporary hack, but it certainly does not substitute an option that would allow us to disable the reflection of a light source.

      Comment


        #4
        Have you tried turning your mirror to unlit? This way it does not receive any lighting.
        Not sure if this helps though.

        Comment


          #5
          i found setting the light radius to 50 and min roughness to 0.018 exactly causes the specular to completely disappear.
          if you lower to min roughness to a value nearer to zero it causes what looks like NaN errors.

          Comment


            #6
            Originally posted by Raildex_ View Post
            Have you tried turning your mirror to unlit? This way it does not receive any lighting.
            Not sure if this helps though.
            If I set it to unlit, then I won't be able to make the material reflective

            Comment


              #7
              Originally posted by mserena View Post
              i found setting the light radius to 50 and min roughness to 0.018 exactly causes the specular to completely disappear.
              if you lower to min roughness to a value nearer to zero it causes what looks like NaN errors.
              I tried this, but it doesn't work for me, the light is still visible in the reflection of other objects.

              Comment


                #8
                is there any solution to this?

                Comment

                Working...
                X