Announcement

Collapse
No announcement yet.

Request function name change for getComponentTranform and others related

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

    [FEATURE REQUEST] Request function name change for getComponentTranform and others related

    I don't understand why an ActorComponent has:

    SetWorldTransform
    SetRelativeTransform

    and then:

    GetComponentTransform
    GetRelativeTransform

    Why not just:
    GetWorldTransform
    GetRelativeTransform

    to keep it consistent?
    Same goes for GetComponent.... Location, Rotation, Scale etc.
    Just name it WORLD like the Set functions.... makes much more sense to me.
Working...
X