Announcement

Collapse
No announcement yet.

Bug, or no bug? [Mesh Reimporting]

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Bug, or no bug? [Mesh Reimporting]

    Hi,

    I have a small problem with mesh reimporting.
    But before I open a keg on AnswerHub, I just want to make sure its really a bug and Im not missing something....

    I created a mesh in 3DMax, including two UV mappings for texture and lightmap.
    After importing and building the lighting, I got a warning that my lightmap UVs are overlapping. (Ok, I was a bit sloppy there...)
    Now I thought "Meh, before going back to Max, lets see how the UE4 generated lightmap UVs look like." Sometimes they are not so bad.
    So I went into the Static Mesh editor, ticked the option for lightmap generation in the import settings and clicked on reimport.

    What I expected was that UE4 generates lightmap UVs and eitehr replaces the current information in channel 1, or ammends a third channel..
    Neither happened. My model still has my original UVs in the second channel. Otherwise the reimport was without errors or warnings...

    So, is there something wrong with reimporting, or did I miss something?

    Cheers,
    Klaus

    PS: Engine version is 4.11 p1
    Last edited by KVogler; 01-11-2016, 09:03 PM.

    #2
    Did you check to see if there was a new UV channel? When you go into the static mesh editor and adjust the lightmap generation settings it also has a destination UV channel that you have to choose. I don't think it reassigns the lightmap UV channel if you generate lightmap UV's after importing, so it could have generated a third channel but still had it set to use the second channel.

    Comment


      #3
      Thanks for your answer

      Did you check to see if there was a new UV channel?
      I think I did...

      it also has a destination UV channel that you have to choose
      Ill have to check again.... Tomorrow

      Comment

      Working...
      X