Announcement

Collapse
No announcement yet.

Steam Multiplayer Tutorial Series?

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Originally posted by Echo9Hotel View Post
    Wes, or anyone who can help,

    Thanks for all of the great videos. You guys are killing it. I'm following the multiplayer blueprint series now and having some issues. Apparently so are several others. I hope you can help.

    In video #11 you test the lobby. I have followed the series start to finish (up to this point) I believe accurately (accept using my own characters and avatars), and when I try to join a multiplayer game the host starts the session, the client finds the session and when I click accept to join I just get a black screen. The host does not see the client join. Occasional the client will see black screen indefinitely, and other times it will revert back to the main menu after about 10 seconds.

    Do you have any idea what might be the problem? I realize you must get tons of messages like this and I know its time consuming. I apologize for adding to the pile. If you have a moment to offer some help it would be greatly appreciated.

    I have packaged/ziped my project and hosted it online if you want to take a look and see if you can ID the problem I am having. Maybe I made a small error. I tried to follow to the t.

    http://transcendere.net/gamedev/EchoNineHotel.zip is the url for the project.

    Thanks for any help you can offer.


    I would post some screens of my nodes and such but I wouldnt have any idea where to start.

    Also ... I should mention I confirm I do get to the join session successfully when I click accept (after searching for a match). I added a print string node after the join session and I do see that print string in game.

    I also recorded the experience on YouTube. here is a link to that video: https://youtu.be/KNfea_SmH4U

    Best wishes.

    Miguel
    Miguel, I'll take a look at your project and try to see what's going on. A couple quick questions, does it work when you try LAN? Also on your two machines are you using the same Steam Account or different ones?

    EDIT: In the meantime, for those that want it, here is a link to the finished project:

    https://forums.unrealengine.com/show...490#post570490


    -W
    Last edited by DizzyWes; 07-25-2016, 02:54 PM.

    Comment


      Originally posted by Wes Bunn View Post
      Miguel, I'll take a look at your project and try to see what's going on. A couple quick questions, does it work when you try LAN? Also on your two machines are you using the same Steam Account or different ones?

      EDIT: In the meantime, for those that want it, here is a link to the finished project:

      https://forums.unrealengine.com/show...490#post570490


      -W
      Thank you Wes,

      Yes it occurs when trying LAN session as well. I am using a separate Steam account on each PC. 2 different steam accounts.

      Thanks.

      Migs
      Last edited by DizzyWes; 07-25-2016, 02:54 PM.

      Comment


        Cool thanks, will try to have a response by end of day tomorrow after I've looked at it (my laptop is at home today >.<).

        -W

        Comment


          I jut tried running your project (linked) on one pc and my partial project on the other. hosting either side lan or internet I get the same results. Using the downloaded project on both PC's seems to work for internet but I cannon get lan working consistently. That may be due to my network however. So I'm thinking its definitely something I must have done incorrectly.

          I'm going to stare and compare the two projects and see what I did differently.

          Thanks again.


          Migs

          Comment


            The black screen problem has happened to me but with other tutorials.
            ProBoon, Old-School FPS, Open Source & Tutorials
            Support Project Boon on Patreon

            On Steam Soon, Click Below

            Comment


              Thanks for the great series! Right now I'm somehow stuck at #11. Do I have to package the project to test this with my second pc ? (no ue4 installed on the second one) Also after I tried packaging, it failed.

              Also, the little steam window does not appear when I start the standalone game in the editor. I did everything as mentioned in the tut, now I try to make the project you posted work.

              *Update* I packaged the full project I downloaded here and once I start in on my second computer it says that I need Visual Studio installed to start it...can anyone give me a hint on how to set this up correctly ?
              Last edited by IceDealer; 07-31-2016, 11:30 AM.

              Comment


                Originally posted by IceDealer View Post
                Thanks for the great series! Right now I'm somehow stuck at #11. Do I have to package the project to test this with my second pc ? (no ue4 installed on the second one) Also after I tried packaging, it failed.

                Also, the little steam window does not appear when I start the standalone game in the editor. I did everything as mentioned in the tut, now I try to make the project you posted work.

                *Update* I packaged the full project I downloaded here and once I start in on my second computer it says that I need Visual Studio installed to start it...can anyone give me a hint on how to set this up correctly ?
                Open your project on your second PC and play it using the stand alone mode, packaging is not necessary just the editor. You might need a second Steam account too.
                ProBoon, Old-School FPS, Open Source & Tutorials
                Support Project Boon on Patreon

                On Steam Soon, Click Below

                Comment


                  Originally posted by masterneme View Post
                  Open your project on your second PC and play it using the stand alone mode, packaging is not necessary just the editor. You might need a second Steam account too.
                  It was actually easier to package and transfer it to my second pc instead of installing the whole engine. Thanks for the tips, it works now! Just had to install some C++ redistributable and voilĂ  . Now I would be curious about server lists and doing all that stuff in C++

                  Comment


                    Originally posted by IceDealer View Post
                    It was actually easier to package and transfer it to my second pc instead of installing the whole engine. Thanks for the tips, it works now! Just had to install some C++ redistributable and voilĂ  . Now I would be curious about server lists and doing all that stuff in C++
                    I didn't think about the installation, I guess is because I have 2 computers already set up, but great that you found what was causing trouble.
                    ProBoon, Old-School FPS, Open Source & Tutorials
                    Support Project Boon on Patreon

                    On Steam Soon, Click Below

                    Comment


                      I have the black screen problem at the end of lesson 16 here https://www.youtube.com/watch?v=_-ya...ndZqZ&index=16

                      Cant join a lan session even though it finds the session. This is what it logs when the server host the game and moves to the lobby


                      LogOnline:Warning: NULL: Can't start an online session (Game) in state InProgress
                      LogLoad: Took 0.218097 seconds to LoadMap(/Game/MOBA/Maps/Lobby)
                      LogNet:Warning: Network Failure: GameNetDriver[FailureReceived]: Host closed the connection.
                      LogNet:Warning: Network Failure: GameNetDriver[FailureReceived]: Host closed the connection.
                      LogNet: NetworkFailure: FailureReceived, Error: 'Host closed the connection.'
                      LogBlueprintUserMessages: [GameInfoInstance_C_1] Client 1: Failure Received
                      LogBlueprintUserMessages: [GameInfoInstance_C_1] Client 1: Failure Received
                      LogNet: UNetConnection::Close: [UNetConnection] RemoteAddr: 127.0.0.1:7777, Name: IpConnection_22, Driver: GameNetDriver IpNetDriver_33, IsServer: NO, PC: MainPlayerController_C_0, Owner: MainPlayerController_C_0, Channels: 11, Time: 2016.08.03-04.55.59
                      LogNet: UChannel::Close: Sending CloseBunch. ChIndex == 0. Name: [UChannel] ChIndex: 0, Closing: 0 [UNetConnection] RemoteAddr: 127.0.0.1:7777, Name: IpConnection_22, Driver: GameNetDriver IpNetDriver_33, IsServer: NO, PC: MainPlayerController_C_0, Owner: MainPlayerController_C_0
                      LogNet:Warning: Network Failure: GameNetDriver[ConnectionLost]: Your connection to the host has been lost.
                      LogNet:Warning: Network Failure: GameNetDriver[ConnectionLost]: Your connection to the host has been lost.
                      LogNet: NetworkFailure: ConnectionLost, Error: 'Your connection to the host has been lost.'

                      Any word on how to resolve this issue?
                      Last edited by SinZero; 08-03-2016, 01:01 AM.

                      Comment


                        Wondering if its possible to show a server list instead of just joining whatever random session it finds

                        Workflow: [Main Menu] Join Internet Game > [Server List Menu] Find ALL Internet Servers & Display > Click a server to select > Click "Join" to initiate the loading into the server.
                        I don't really need people making a ton of random sessions, just for it to find the sessions that are available, or, those that are setup as "unofficial servers" hosted by anyone. I also dont need the lobby or anything like that. I assume that i can simply edit it out in the menu bits, and, jsut direct link from main menu to the server list, but, there is no list. It simply finds the first open server and asks if the players want to join.
                        Founder and CEO of Angry Penguin Studio, LLC
                        Dallas, TX USA
                        https://www.facebook.com/AngryPenguinStudios

                        Comment


                          Originally posted by Angrytoilet View Post
                          Wondering if its possible to show a server list instead of just joining whatever random session it finds

                          Workflow: [Main Menu] Join Internet Game > [Server List Menu] Find ALL Internet Servers & Display > Click a server to select > Click "Join" to initiate the loading into the server.
                          I don't really need people making a ton of random sessions, just for it to find the sessions that are available, or, those that are setup as "unofficial servers" hosted by anyone. I also dont need the lobby or anything like that. I assume that i can simply edit it out in the menu bits, and, jsut direct link from main menu to the server list, but, there is no list. It simply finds the first open server and asks if the players want to join.
                          You for sure can do this, it's actually not too much different than what he does in the tutorial.

                          From another reply I made elsewhere:

                          If you watch this tutorial, when he drags off the results from the "Find Sessions" bit, you should be able to use that to populate a server browser UI, and connect to the selected server that way.
                          As long as you cache the server results you should be able to connect to them by selecting them from the list.

                          Comment


                            After starting the game, we cant find the server... What's the matter? If regional restrictions? 420 server, or smth else? Testing was conducted on a finished project that you have posted...

                            Comment


                              Originally posted by mrooney View Post
                              You for sure can do this, it's actually not too much different than what he does in the tutorial.

                              From another reply I made elsewhere:



                              As long as you cache the server results you should be able to connect to them by selecting them from the list.
                              This sounds great! Anyone able to aid me in accomplishing this? I am a little lost in this process to be honest.
                              Founder and CEO of Angry Penguin Studio, LLC
                              Dallas, TX USA
                              https://www.facebook.com/AngryPenguinStudios

                              Comment


                                Originally posted by jaran View Post
                                I have the black screen problem at the end of lesson 16 here https://www.youtube.com/watch?v=_-ya...ndZqZ&index=16

                                Cant join a lan session even though it finds the session. This is what it logs when the server host the game and moves to the lobby





                                Any word on how to resolve this issue?
                                I'm having the same problem
                                James Brad Barnette
                                Senior Creative Artist
                                3Dmotif LLC

                                Comment

                                Working...
                                X