Announcement

Collapse
No announcement yet.

moving / renaming still completey broken in 4.8

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    [EDITOR] moving / renaming still completey broken in 4.8

    Ok, I've searched the AnswerHub thoroughly. Yes, there's plenty of reports concerning this issue, all marked as resolved although the solutions are things like "I've rolled back my project to a version from 2 month ago", or "I've deleted the redirectors manually and fixed all references by hand"..

    Please fix this, Epic!

    1. Most of the time I move a blueprint actor class or component which is referenced in other blueprints and scenes my editor just crashes during the process

    2. After the crash the file has indeed been moved and there's a redirector asset in it's old location, so far so good.

    3. I run FixUpRedirectors, it says some references could not be fixed because they're part of an unloaded asset, which in most cases is a level.

    4. I load that level and try FixUpRedirectors, it says FAILED TO LOAD ASSETS, and lists the components of the asset i'm trying to fix.


    This is absolutely common when moving assets. It only ever works on some very rare occasions, when moving simple graphic content that isn't references much.
    .
    Last edited by flip hazard; 06-29-2015, 01:50 PM.

    #2
    I'm constantly having this issue as well. Overall stability of the engine has much improved, especially with 4.8, but moving or renaming assets remains a risky and messy business.

    Is it something that's being worked on?
    Are there any workarounds or such to avoid these issues?

    Comment


      #3
      I'm also having this problems, sometimes i delete folders(and after restart i see them again) or rename something and close editor but after start i have errors(renaming back can help but its not good ) with this renaming assets.

      Comment


        #4
        Try fixing up your redirectors: https://docs.unrealengine.com/latest...ors/index.html

        If you do not this can cause file folders to still appear or the naming issues you've pointed out.
        Tim Hobson | Learning Resources | Epic Games
        UE4 Documentation

        Comment


          #5
          Thanks for your support, Mr. Hobson, but:

          Originally posted by flip hazard View Post
          3. I run FixUpRedirectors, it says some references could not be fixed because they're part of an unloaded asset, which in most cases is a level.

          4. I load that level and try FixUpRedirectors, it says FAILED TO LOAD ASSETS, and lists the components of the asset i'm trying to fix.


          Other than the AnswerHub issues mentioned above I can't find any mention of these bugs. Have they ever been acknowledged by the Epic devs ?
          I wonder if it only happens to a few users?
          We're using SVN for version control. Could it be related to that somehow?

          .

          Comment


            #6
            Originally posted by flip hazard View Post
            I wonder if it only happens to a few users?
            We're using SVN for version control. Could it be related to that somehow?
            Happens to me, too, and I'm not using version control through the editor or SVN at all.

            Comment


              #7
              Yep, had many issues with that, too. My whole project is full of 'ghost files' (redirectors) and not-really-deleted files. Replacing of references doesn't work reliable either.

              Comment


                #8
                I've encountered these problems in projects with no version control as well, so I don't think that's it.
                It does feel like I'm getting fewer crashes when I don't use version control though.


                Originally posted by Tim Hobson View Post
                Try fixing up your redirectors: https://docs.unrealengine.com/latest...ors/index.html

                If you do not this can cause file folders to still appear or the naming issues you've pointed out.
                In addition to what flip hazard said, I oftentimes find myself with broken redirectors. They don't show up as assets or redirectors in the engine and fixing redirectors doesn't do anything. All I can do is delete the files via the explorer manually. In other words, the whole redirection system seems to be a bit unstable. It would be interesting to know how the teams at Epic are handling file management and whether there are any plans to fix it.

                Comment


                  #9
                  Originally posted by Efrye View Post
                  I've encountered these problems in projects with no version control as well, so I don't think that's it.
                  It does feel like I'm getting fewer crashes when I don't use version control though.




                  In addition to what flip hazard said, I oftentimes find myself with broken redirectors. They don't show up as assets or redirectors in the engine and fixing redirectors doesn't do anything. All I can do is delete the files via the explorer manually. In other words, the whole redirection system seems to be a bit unstable. It would be interesting to know how the teams at Epic are handling file management and whether there are any plans to fix it.
                  This isn't a problem I have run into myself, typically I use fix up redirectors on the Contents folder in the Content Browser (I choose this folder specifically because it propagates to all child folders in the filepath) after moving or renaming any assets and have no errors from that point on. Can you walk me through some specific steps you are taking that reproduce this on your end? I'll be happy to try to get this to occur on my side and see if we can find the root of the problem!
                  Adam Davis | Marketplace Support | Epic Games
                  How to report a bug? | Installation & Setup issues? | Answerhub Bug Reports | Twitter

                  Comment


                    #10
                    Originally posted by Adam Davis View Post
                    This isn't a problem I have run into myself, typically I use fix up redirectors on the Contents folder in the Content Browser (I choose this folder specifically because it propagates to all child folders in the filepath) after moving or renaming any assets and have no errors from that point on. Can you walk me through some specific steps you are taking that reproduce this on your end? I'll be happy to try to get this to occur on my side and see if we can find the root of the problem!
                    It's hard to pin down because it seems to happen randomly with deleted assets. Mostly with skeletal mesh files in my case, but that might be because that's what I'm currently working with the most.

                    Here a way to reproduce it that always works for me:

                    1. Open the ShooterGame project version 4.8.
                    2. Force delete the HeroTPP folder. (HeroTPP_AnimBlueprint and HeroTPP_Death can't be deleted.)
                    3. Try to fix up redirectors via right click on the Content folder or HeroTPP folder. It won't work.
                    4. Restart the project and try to fix up redirectors the same way. It still won't work.

                    In this case I have to use "force delete" since the assets are referenced by other files, but in my own project this problem exists even with character assets that haven't been used anywhere.

                    And please keep in mind that this isn't exactly the same problem as described in the opening post, it just highlights some of the current issues with the redirection system.

                    Comment


                      #11
                      I used have the issue until I was pointed to the "Fix Redirectors" link ... since then I have not encountered this issue. Sometimes when I use it or try to delete assets, it tells me the assets are still in memory ... so I merely open a new map and close all my open Blue Prints.

                      If the above doesn't help, I close the editor and re-open the editor ... no Blueprints are then referenced in memory and I can safely run the "Fix Redirectors".

                      In my opinion the need to use the "Fix Redirectors" option is far less frequent in 4.8 then it was in 4.7 ... 8-}
                      Quinton Delpeche
                      Founder - Gobbo Games | Designer - The Colony 2174 (Board Game) | Developer - Riders of Asgard

                      Comment


                        #12
                        Originally posted by Efrye View Post
                        It's hard to pin down because it seems to happen randomly with deleted assets. Mostly with skeletal mesh files in my case, but that might be because that's what I'm currently working with the most.

                        Here a way to reproduce it that always works for me:

                        1. Open the ShooterGame project version 4.8.
                        2. Force delete the HeroTPP folder. (HeroTPP_AnimBlueprint and HeroTPP_Death can't be deleted.)
                        3. Try to fix up redirectors via right click on the Content folder or HeroTPP folder. It won't work.
                        4. Restart the project and try to fix up redirectors the same way. It still won't work.

                        In this case I have to use "force delete" since the assets are referenced by other files, but in my own project this problem exists even with character assets that haven't been used anywhere.

                        And please keep in mind that this isn't exactly the same problem as described in the opening post, it just highlights some of the current issues with the redirection system.
                        Can you try this with one of the blueprint based projects? The problem you'll run into with Shootergame is that many of the classes that are deleted are directly tied into many of the C++ classes, so any pointers in code that are now pointing to a NULL value now must be manually removed. Additionally, keep in mind that redirectors are not going to be the primary issue when deleting folders. At that point, redirectors will not help as they are designed to point code to the file's new location. Any references to that information is considered NULL if an asset is deleted and will need to be re-referenced.
                        Adam Davis | Marketplace Support | Epic Games
                        How to report a bug? | Installation & Setup issues? | Answerhub Bug Reports | Twitter

                        Comment


                          #13
                          I'm having this problem too on 4.8.3. Steps to reproduce:

                          Create a couchknights project. Create a directory named "CouchKnightsMigrate".

                          Move all the other folders into "CouchKnightsMigrate". Save all. Reopen the project, and you get all these errors:

                          Click image for larger version

Name:	failed_move.png
Views:	1
Size:	230.9 KB
ID:	1083200

                          Right clicking Content -> fix up redirectors fails as well:

                          Click image for larger version

Name:	failed_fixup_redirectors.png
Views:	1
Size:	123.2 KB
ID:	1083201

                          Trying a few folders at a time fails in much the same way.
                          Last edited by muchcharles; 08-03-2015, 08:09 PM.

                          Comment


                            #14
                            Yes, the editor seems to crash or freeze quite often when moving assets. Especially when they are under source control.

                            Thanks god we have source control!
                            Realistic Atmosphere 2.0 | YouTube | Forum | Marketplace

                            Comment


                              #15
                              Originally posted by muchcharles View Post
                              I'm having this problem too on 4.8.3. Steps to reproduce:

                              Create a couchknights project. Create a directory named "CouchKnightsMigrate".

                              Move all the other folders into "CouchKnightsMigrate". Save all. Reopen the project, and you get all these errors:



                              Right clicking Content -> fix up redirectors fails as well:



                              Trying a few folders at a time fails in much the same way.
                              Try fixing the redirectors before closing the project the first time. Does this address the error or are you still getting warnings?
                              Adam Davis | Marketplace Support | Epic Games
                              How to report a bug? | Installation & Setup issues? | Answerhub Bug Reports | Twitter

                              Comment

                              Working...
                              X