Announcement

Collapse
No announcement yet.

Trouble renaming assets

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Trouble renaming assets

    This has already happened to me numerous times, and it is very annoying! Whenever I make a material or blueprint, then rename it, it works fine. However, if I try to return the old name, it tells me that another asset already exists there. Even though there is nothing there. This has also happened to folders, and really any kind of asset.

    Is this supposed to happen? Is there a workaround? Any feedback on this would be greatly appreciated!

    #2
    You should always save your asset after each modification. You get that warning because it still exists in the Editor memory.
    UE4 blog: www.michalorzelek.com/blog/ - Tutorials, free content and more!

    Comment


      #3
      But this problem continues even after I restart the editor. It still tells me that the asset exists even though it doesn't.

      Comment


        #4
        Have you tried cleaning up redirectors? That might work.

        Caldera Entertainment | Twitter | ArtStation

        Comment


          #5
          How do you do that?

          Comment


            #6
            This will tell you all you need to know.

            https://docs.unrealengine.com/latest...ors/index.html

            Caldera Entertainment | Twitter | ArtStation

            Comment


              #7
              Renaming/moving things in UE4 is not a good idea.
              You need to know what you are/UE4 is doing.
              If you rename something UE4 creates a link with the old name, linking to the new name.

              You can fix these up by right click on a folder in the content browser and select "fixup file ..." as mentioned above.

              This doesn't work always, so you'll end up with lots of folders with links in it.

              I ended up, deleting all these links and empty folders via Windows-Explorer. Result is of course, that lots of assets/levels/materials broke and needed to be fixed.


              One idea would also be, to migrate your content to a new project. It copies the needed files without the links!
              But this means also some work and adjustments.

              => TL; DR

              Make & clean your folder structure BEFORE you use the assets to create a level.
              Last edited by nn23; 04-16-2015, 04:10 AM.

              Comment


                #8
                Thank you for your quick and informative replies, I feel like a complete noob now. I'll be sure to do it right from now on.

                Comment


                  #9
                  I find that fixing redirectors can be 50/50. Generally if you restart the editor after doing it, and clean up the remaining windows explorer files/folders it works.

                  Caldera Entertainment | Twitter | ArtStation

                  Comment


                    #10
                    I have tried doing that in the past, and that did not work. I saw the ghost file in Windows Explorer, deleted it, started the editor back up, the file apparently still existed.
                    Last edited by TommyZakh; 04-16-2015, 06:51 PM.

                    Comment


                      #11
                      Did you delete it after fixing the redirectors though? When you fix redirectors usually a window pops up that will ask you to confirm the deletion. Once you complete that, close the editor/launcher and delete those same files in the windows explorer if they remain. That's how I have to do it.

                      Caldera Entertainment | Twitter | ArtStation

                      Comment


                        #12
                        Oh ok, thanks.

                        Comment


                          #13
                          I move folders every now and then. I discover if I give it a couple of weeks it doesn't cause any issues when I delete them. There was one time I deleted them immediately. All my materials lost their texture selections. Took me 2 days to fix. Fortunately I had an older version I used to save time. If I didn't have the backup it would have taken longer than 2 days.
                          Strife - 1996 - Remake

                          Comment


                            #14
                            That's another thing, before messing around with moving/renaming/redirectors I would recommend backing up the original project. Sometimes things can go wrong, and it'll be good to have.

                            Caldera Entertainment | Twitter | ArtStation

                            Comment

                            Working...
                            X