Announcement

Collapse
No announcement yet.

Desktop Window Manager Problems

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    [EDITOR] Desktop Window Manager Problems

    I am having all kinds of problems lately, but I think they mostly have to do with Desktop Window Manager. These issues started in June, but I was building a new computer so I put off asking about it since I figured the problem might become moot. However, the problem persisted on my new hardware. Since then, I have also tested this in 4.22, .23. and .24 as well so I'm pretty sure it's Windows and not Unreal 4.25 that's the problem here.

    So what happens is, I open my project (which defaults to the main menu level which has no geometry) and everything's fine. When I open a level and then test it, all the menus stop working. They're still clickable, but the dropdowns are invisible and the invisible buttons do not respond to clicks. Additionally, all the tooltips for these invisible buttons are just black boxes. I also cannot open assets after this starts. Sometimes it will just say the entire editor is not responding in the task manager after a I try to open an asset, but most often a transparent window thumbnail for the asset appears in the task bar, but the window itself never opens and cannot be viewed. And all of this will happen too if I just leave the editor up long enough. Testing makes it happen faster.

    This problem renders the whole engine unusable.

    I searched through the AnswerHub (and asked an unanswered question about this there). Most of the questions I found involve a similar problem from circa 4.12 where the stopgap solution was holding down the space key as you clicked on a menu button or changing to a high contrast theme, but those solutions haven't helped here. The most useful post I found was this one, in which one of the answers suggested that this problem was caused by Desktop Windows Manager. Basically, the thing that runs Aero.

    If I disable DWM, everything works as expected. I would rather actually fix the problem though because I also find that playing Marketplace asset demos with DWM enabled makes them freeze up. (Funnily enough, I can play games made in Unreal just fine.)

    What's weird is, I thought maybe this was just another subtle hint that us Windows 7 holdouts need to get on the 10 train, but I tried all of this out on another Win7 machine with much lower specs than my new computer and it works same as it always did. So I feel like there must be some setting or something that I can just change and have my world be right again.

    Please let me know if you need any further information to help me.
Working...
X