Announcement

Collapse
No announcement yet.

Question about the future Unreal Engine 5

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Question about the future Unreal Engine 5

    If you're creating a game using UE 4.25 and your characters are all UE 4.25 compatible,
    will you be able to use them in Unreal Engine 5.0? I don't want to pickup anything from the Market place
    If it's soon will be unusable in UE 5 Thanks

    #2
    Answered my own question. Looks like there won't be backwards compatibility with the items created for 4.25 and lower. Too bad there's no conversion util. Would be nice to carry forward, but ain't complaining though looking at the new advance V5 engine.

    Comment


      #3
      5 is Unreal 4 + better rendering technology.
      It's not a new engine created from scratch.

      Compatibility won't be perfect, but won't be impossible as well.
      | Savior | USQLite | FSM | Object Pool | Sound Occlusion | Property Transfer | Magic Nodes | MORE |

      Comment


        #4
        https://www.unrealengine.com/en-US/b...nreal-engine-5

        Unreal Engine 4 & 5 timeline

        Unreal Engine 4.25 already supports next-generation console platforms from Sony and Microsoft, and Epic is working closely with console manufacturers and dozens of game developers and publishers using Unreal Engine 4 to build next-gen games.

        Unreal Engine 5 will be available in preview in early 2021, and in full release late in 2021, supporting next-generation consoles, current-generation consoles, PC, Mac, iOS, and Android.

        We’re designing for forward compatibility, so you can get started with next-gen development now in UE4 and move your projects to UE5 when ready.

        We will release Fortnite, built with UE4, on next-gen consoles at launch and, in keeping with our commitment to prove out industry-leading features through internal production, migrate the game to UE5 in mid-2021.

        Comment


          #5
          Originally posted by UREAL2028 View Post
          Answered my own question. Looks like there won't be backwards compatibility with the items created for 4.25 and lower. Too bad there's no conversion util. Would be nice to carry forward, but ain't complaining though looking at the new advance V5 engine.
          Not sure where you're getting that info. They never said 4.25 or lower. The official information is here:
          https://www.unrealengine.com/en-US/faq?active=ue5

          Will it be possible to migrate a UE4 project to UE5?
          Yes. Developers will be able to migrate their UE4 projects to UE5, which is backwards-compatible. Developers targeting next-gen consoles are encouraged to start building with UE4 today and port their projects to UE5 if needed.
          There's nothing there stating that older UE4 content isn't forward compatible. UE4 has always supported forward compatibility of assets (e.g. Assets created in 4.20 can be brought into 4.25.)




          Brushify is a complete landscape solution and shader infrastructure for Unreal Engine 4.
          Get Brushify on Unreal Marketplace: www.brushify.io

          Comment

          Working...
          X