Announcement

Collapse
No announcement yet.

DXGIGetDebugInterFace1 could not be located in dynamic library dxgi.dll

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    DXGIGetDebugInterFace1 could not be located in dynamic library dxgi.dll

    so i grabbed this 8.1 sdk for win8.1 someone suggested installed 4.25 and got the below what am i missing it appears the engine may still be loading but what am i as i said missing, am io missing this dll or does that mean the one i have is messed up?

    #2
    so i see this is a windows 8.1 issue that sdk i was told by another here messes **** up thanks...

    Comment


      #3
      So this mean that the problem is with older versions of Windows? Does that mean that to run the newer Unreal Engine one have to be using Windows 10? I'm using Windows 7 and it's saying that it's missing that as well.

      Comment


        #4
        I have the same issue on Win7.
        Is there a way to disable it?

        Comment


          #5
          Same with my Windows 7. Can we disable it Epic team? Since updating the engine to 4.25 it is bogging down extremely. Not sure what is going on but seems to be skipping frame rate as I work. Thank you

          Comment


            #6
            Same here .....
            Cepheus Protocol
            recruitment@halcyonwinds.com

            Comment


              #7
              This doesn't just seem to be an inconvenient error message. When you try to run your packaged game (or when you press "Launch" in the editor), it will give the same error but with CreateDXGIFactory2, after which the game crashes. I did some digging, and apparently (if I understood correctly) it's because it needs DXGI 1.3, which is only available for windows 8+. This means that games packaged with 4.25+ will not work on windows 7 anymore.

              I don't know if this was intentional or whether it was an oversight/bug, but it currently means that the UE4 has basically dropped support for packaging to windows 7, and not in the development sense, but in the "minimum specs required to run your game" sense.


              Click image for larger version  Name:	error.png Views:	0 Size:	19.8 KB ID:	1772355
              Last edited by LowEntry; 06-06-2020, 05:54 PM.
              Created blueprints for:
              Network connections | JSON | XML | HTTP requests | Compression | Encryption | File system

              Also accepting freelance work (web development, UE4, Java, etc) (just send us a problem or an idea and we'll think it out for you for free, no strings attached)
              https://lowentry.com/

              Comment


                #8
                Start your app with -novendordevice option can resolve this problem.

                Comment


                  #9
                  Start your app with -novendordevice option can resolve this problem.
                  May you tell us how to do that? Or give us a hint?

                  Comment


                    #10
                    Originally posted by Amelia_P View Post

                    May you tell us how to do that? Or give us a hint?
                    There are two solutions for resoving this problem.

                    Solution 1:

                    1. package your game and you got an YourGame.exe
                    2. create a shortcut for YourGame.exe
                    3. open shortcut property window. add -novendordevice in the target textfield.


                    Solution 2:
                    1. package your game, you got a folder named WindowsNoEditor
                    2. Go to WindowsNoEditor\Engine\Binaries\ThirdParty\NVIDIA\NVaftermath\Win64
                    3. Delete the dll named: GFSDK_Aftermath_Lib.x64.dll

                    Comment


                      #11
                      Originally posted by LowEntry View Post
                      This doesn't just seem to be an inconvenient error message. When you try to run your packaged game (or when you press "Launch" in the editor), it will give the same error but with CreateDXGIFactory2, after which the game crashes. I did some digging, and apparently (if I understood correctly) it's because it needs DXGI 1.3, which is only available for windows 8+. This means that games packaged with 4.25+ will not work on windows 7 anymore.

                      I don't know if this was intentional or whether it was an oversight/bug, but it currently means that the UE4 has basically dropped support for packaging to windows 7, and not in the development sense, but in the "minimum specs required to run your game" sense.


                      Click image for larger version Name:	error.png Views:	0 Size:	19.8 KB ID:	1772355
                      You should modify the source code like below:

                      1. Go to the folder: {UE4SROUCE}\Engine\Source\Runtime\D3D12RHI\Private

                      2. Open D3D12Adapter.h with text editor (e.g. VS Code)

                      3. Modify CreateDXGIFactory function's implementation like below:

                      FORCEINLINE void CreateDXGIFactory(bool bWithDebug)
                      {
                      #if PLATFORM_WINDOWS || PLATFORM_HOLOLENS
                      VERIFYD3D12RESULT(::CreateDXGIFactory(IID_PPV_ARGS(DxgiFactory.GetInitReference())));
                      VERIFYD3D12RESULT(DxgiFactory->QueryInterface(IID_PPV_ARGS(DxgiFactory2.GetInitReference())));
                      #endif
                      }

                      4. Recompile UE4-Editor

                      That's all.

                      Comment


                        #12
                        Originally posted by kongque View Post

                        You should modify the source code like below:

                        1. Go to the folder: {UE4SROUCE}\Engine\Source\Runtime\D3D12RHI\Private

                        2. Open D3D12Adapter.h with text editor (e.g. VS Code)

                        3. Modify CreateDXGIFactory function's implementation like below:

                        FORCEINLINE void CreateDXGIFactory(bool bWithDebug)
                        {
                        #if PLATFORM_WINDOWS || PLATFORM_HOLOLENS
                        VERIFYD3D12RESULT(::CreateDXGIFactory(IID_PPV_ARGS(DxgiFactory.GetInitReference())));
                        VERIFYD3D12RESULT(DxgiFactory->QueryInterface(IID_PPV_ARGS(DxgiFactory2.GetInitReference())));
                        #endif
                        }

                        4. Recompile UE4-Editor

                        That's all.

                        Ah thank you so much, that really helps a lot!

                        That does require using the source version of the engine if I understand right?

                        Do you know anything about whether Epic will fix it in future versions of the engine or whether this was intentional (as in they won't change or fix it)?
                        Created blueprints for:
                        Network connections | JSON | XML | HTTP requests | Compression | Encryption | File system

                        Also accepting freelance work (web development, UE4, Java, etc) (just send us a problem or an idea and we'll think it out for you for free, no strings attached)
                        https://lowentry.com/

                        Comment


                          #13
                          Originally posted by kongque View Post

                          There are two solutions for resoving this problem.

                          Solution 1:

                          1. package your game and you got an YourGame.exe
                          2. create a shortcut for YourGame.exe
                          3. open shortcut property window. add -novendordevice in the target textfield.


                          Solution 2:
                          1. package your game, you got a folder named WindowsNoEditor
                          2. Go to WindowsNoEditor\Engine\Binaries\ThirdParty\NVIDIA\NVaftermath\Win64
                          3. Delete the dll named: GFSDK_Aftermath_Lib.x64.dll
                          Thank you!

                          Comment


                            #14
                            Originally posted by LowEntry View Post


                            Ah thank you so much, that really helps a lot!

                            That does require using the source version of the engine if I understand right?

                            Do you know anything about whether Epic will fix it in future versions of the engine or whether this was intentional (as in they won't change or fix it)?

                            Yes, you should use source code built version.

                            I resolved this problem by read and debugged the source code. I don't known whether Epic will fix it.

                            Comment


                              #15
                              Originally posted by Mazen IIXIS View Post
                              I'm using Windows 7 and it's saying that it's missing that as well.
                              For what's worth, Microsoft ended support for Windows 7 on January 22. No more patches, security fixes. Wild West for malicious software.
                              I'd recommend upgrading Windows on every developer machine to Windows 10. Especially that you can get a better performance thanks to DX 12 which should be soon enabled by default.

                              Comment

                              Working...
                              X