Announcement

Collapse
No announcement yet.

Skeletal Mesh Asset Won't Delete After Cloth Simulation in Ue4 24.3

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Skeletal Mesh Asset Won't Delete After Cloth Simulation in Ue4 24.3

    Hello! I'm running into a problem with deleting my skeletal mesh! :0... It only has a problem deleting after I apply clothing data, it deletes just fine before. I keep getting this error message:



    SkeletalMesh /Game/Flag.Flag is in use.

    ---
    Running the editor with '-NoLoadStartupPackages' may help if the object is loaded at startup.
    ---


    External referencers of SkeletalMesh /Game/Flag.Flag:
    ClothPainterSettings /Engine/Transient.Default__ClothPainterSettings (root) (1)
    0) ObjectProperty /Script/ClothPainter.ClothPainterSettings:ClothingAssets.ClothingAssets



    Once I go into the skeletal mesh and remove the clothing data I can delete the asset, and it appears to be deleted, but if I switch folders and then switch back, the asset reappears like it was never deleted. I'm not sure if this is a bug or if I'm doing something wrong? I've been able to recreate the issue with a bunch of different assets, the problem only appears after the clothing data is applied.


    Click image for larger version

Name:	Capture.JPG
Views:	255
Size:	267.8 KB
ID:	1727087

    #2
    It was also happening in 24.2! Thought I should mention that. I haven't been able to try it in 24.1

    Comment


      #3
      You can delete clothing data. This should solve the problem.

      Click image for larger version

Name:	Annotation 2020-08-01 160501.png
Views:	83
Size:	17.0 KB
ID:	1795571

      Comment

      Working...
      X