Announcement

Collapse
No announcement yet.

System Font UE4 4.23 Big Problem !

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • replied
    Jamie, thanks for the reply, I've read that tutorial several times and couldn never been able to import Chinese fonts. That's like a info about general process, can't we have examples of such fonts for better understanding?

    Leave a comment:


  • replied
    We have documentation on fonts and the font editor, and the last part of it shows an example composite font that has been configured to also support Japanese.

    Leave a comment:


  • replied
    I don't understand why there is no proper tutorial or documentation to implement Asian fonts for 4.23 and 4.24?

    Leave a comment:


  • replied
    I have the same problem. I couldn't find Slate.EnableLegacyLocalizedFallbackFont to change it.
    I used to work with 4.19 and I recently upgraded to 4.23. Everything worked fine except for the localization. Is it faster to solve it when upgrading to 4.24?

    Leave a comment:


  • replied
    Our standard Roboto font asset is only configured to properly support English and maybe some European languages. As noted in the docs:

    By default, UMG text widgets use a font that ships with Unreal Engine. This gives you something to work with out of the box so you can get started quickly. However, this built-in font has some limitations; for example, it only supports a small set of languages. For most projects, especially those that require UIs with non-English text, you'll want to import your own custom fonts into Assets and set up your text widgets to use your fonts.
    Slate.EnableLegacyLocalizedFallbackFont is a CVar, so make sure you INI syntax is correct for it.

    Leave a comment:


  • replied
    Hi Jamie, I am using Roboto and not a custom font , and not sure if the overview applies? When I moved up to 4.24 it fixed but broke a load of other VR related items so had to painfully back track to 4.23 - I tried Slate.EnableLegacyLocalizedFallbackFont=1 in my defaultengine.ini but that didnt help..still stuck with a release date looming..

    Leave a comment:


  • replied
    This doesn't look like a bug. Our legacy localized fallback fonts were changed to emit a warning (telling you fix your fonts) in 4.22, disabled by default in 4.23, and removed in 4.24.

    Below is the relevant excerpt from the release notes:

    Deprecated: Legacy localized fonts are now disabled by default.
    • These have been "soft" deprecated since 2014, were formally deprecated (emitting a warning if used) in 4.22, and will be removed in 4.24.
    • They can be temporarily enabled again by setting Slate.EnableLegacyLocalizedFallbackFont to 1.
      • You should instead ensure that your font assets are set-up correctly by using this overview.

    Leave a comment:


  • replied
    was this fixed?

    Leave a comment:


  • replied
    I submited a bug report

    Leave a comment:


  • replied
    Hello. Please submit a bug report here > https://epicsupport.force.com/unrealengine/s/

    Thank you

    Leave a comment:


  • started a topic System Font UE4 4.23 Big Problem !

    System Font UE4 4.23 Big Problem !

    Hello,

    I have problem after update on 4.23 with font when i write in japenese character i have problem (i tested with Roboto but i doesn't change ...)
    I never have this problem with 4.22.3 ...
    Thank you!
Working...
X