Announcement

Collapse
No announcement yet.

Visibility does not work logically in UE

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

    [EDITOR] Visibility does not work logically in UE

    Dear Epic,

    If I have a static mesh actor, it is naturally visible and it naturally casts a shadow. If I go to its Details/ Rendering/ Visible and turn the checkbox OFF, that static mesh actor is hidden in BOTH the editor and the game, logically good so far. So why when you build the lighting, does that static mesh actor STILL cast a shadow? It is not visible; it should be completely off - no shadow casting. The tool tip for Visible even states this: "if false, the primitive is not drawn, does not cast a shadow." But Visible does not work as it should, as the tool tip states! You must also go to Details/ Lighting/ Cast Shadow and turn that checkbox OFF also.

    Basically, to turn something off fully is a TWO-STEP process. Sorry to complain, but that's ridiculous. If you want something hidden yet still casting a shadow, THAT condition is the unique condition and should take the two-step process. Hiding something completely (shadows and visibility) should be a one-step process. This should be as easy as making the Details/Lighting/Cast Shadow flag ignored if
    Details/ Rendering/
    Visible is set to false. The Details/Lighting/Cast Shadows flag already has the property to be ignored for Unlit materials; why not also for the Visible flat? Please fix the interface.

    Thank you,
    Matt
Working...
X