Announcement

Collapse
No announcement yet.

Unable to block the Epic Games Launcher ?

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    [LAUNCHER] Unable to block the Epic Games Launcher ?

    I've generally blocked any apps that i don't need using the internet. But apparently trying to block the EGL.. I've literally disabled any .exe file you would expect, and it's like it does nothing.

    I've never had this happen to me before. Any other apps that I've blocked .. 100% success .. except the god **** launcher.

    I did this:

    1. searchAllow an app through Windows Firewall → uncheck the epicgameslauncher.exe (all of them & anything related that don't really need using the internet)

    2. searchWindows Defender Firewall with Advanced Security → Created new rules (Outbound & Inbound) and blocked: C:\Users\%USER%\AppData\Roaming\Launcher\Engine\Binaries\Win64\EpicGamesLauncher.exe & UnrealEngineLauncher.exe (Win32 folder as well) (previously moved the launcher to a different location, to disable the auto-launch in case you're wondering. (Works, until you update the launcher. Then you have to move it someplace else again))

    But anyway.. the launcher somehow still manages to connect to the internet as if it isn't blocked at all.

    ---

    I Signed Out of the launcher now, and I always just instantly kill it when it auto-launches.

    It's clear that they've put some effort to not allowing users to block it, apparently.

    Anything else to try ?

    #2
    Disclaimer #1 that the launcher is not my focus area and these forums are intended for the engine itself.
    Disclaimer #2 that the launcher is intended as an online service, and if you choose to use the Unreal Editor without it then I'd probably recommend you work with the engine source code via Github instead.

    That said, a member of our launcher team suggests that you may need to set the rule to block UnrealCEFSubProcess. This is the Chromium Embedded Framework.
    Stephen Ellis | Enterprise Program Coordinator

    Comment


      #3
      Originally posted by Stephen Ellis View Post
      That said, a member of our launcher team suggests that you may need to set the rule to block UnrealCEFSubProcess. This is the Chromium Embedded Framework.
      That was the only process i didn't have blocked.

      However, even after blocking UnrealCEFSubProcess.exe (everywhere i could find it), surprisingly the launcher still connects all the same!

      Comment

      Working...
      X