Announcement

Collapse
No announcement yet.

[RENDERING] Weird rendering artifacts appearing for ~1-2 frames

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • replied
    I'm addressing this successfully by setting up a warmup on the sequence render (I did a 20 frame warmup with 2 seconds' delay before warmup and 2 seconds' delay before shot warmup). Also closed secondary viewports during the render. Can't say with certainty which of these made the difference, but I am getting clean renders by doing this.

    Leave a comment:


  • replied
    Downgrading drivers to over 2 year old ones didn't fix the issue at all, and apparently I start to see even more people having this problem. (to reproduce this u could just open very gpu demanding scene and try to render a sequence from it using sequencer on a high screenscale, i also noticed that these glitches happen when vram is almost at full usage [100-300 mb before the max. capacity])

    Leave a comment:


  • replied
    Still happening...
    Attached Files

    Leave a comment:


  • replied
    This doesn't happen only when changing the screenscale, it's just an easy way to reproduce the glitch/artifact. I use UE4 to render my scenes with sequencer and I get these glitches while rendering aswell (as i wrote in the title they happen kinda often for 1-2 frames in a row in a whole rendered sequence).
    Last edited by KrasheRXD; 11-27-2018, 03:22 AM.

    Leave a comment:


  • replied
    If it's something that only happens right after changing the screen scale, then I wouldn't worry about it, it's not a setting that should be changed during gameplay, so if it has a momentary glitch then maybe require a game restart to put that into effect.

    Leave a comment:


  • replied
    That didn't really helped, they still appear after setting the screenscale and restarting the editor. So if this is a driver issue is there any place where i can report the problem?

    Leave a comment:


  • replied
    It looks like a GPU driver issue, maybe it's something that would work properly if the screen scale is set and then you restart the editor.

    Leave a comment:


  • [RENDERING] Weird rendering artifacts appearing for ~1-2 frames

    After using UE4 for a year I noticed weird and annoying shading/rendering artifacts which are pretty easy to reproduce. Basically just open any heavy and demanding ue4 level/scene and move the screenscale slider in the viewport (or go for 200 screenscale and play the level), you will probably get similar results. I am using 4.20.2 version of Unreal, but i think it doesn't really matter because this thing happens on every version i tried.

    My specs:

    Windows 10 Home 17763.134
    Intel Core i5-4690k (OC to 4.3GHz)
    Asus GeForce GTX 1070, Nvidia Driver 417.01
    16 GB of RAM

    I suspect that this is some driver issue because I saw some people facing similar trouble and downgrading the drivers has seem to fix the issue for them (not sure if this was the same problem I have).

    Here are the screenshots of "artifacted" frames - https://imgur.com/a/MshXOdN
Working...
X