Announcement

Collapse
No announcement yet.

Steam online subsystem not finding server with find sessions with 4.20

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • replied
    Originally posted by mhnoni View Post

    I wonder if epic is going to fix a simple ping on 2020. its been ages and this is not working. maybe they will fix it when they release a game on steam but since they are not going to then no hope to fix this small issue unless you go to the source and change it by yourself.
    It's not actually Epic's fault technically, It's actually a limitation of Steam Lobby Servers (which is what Listen Servers are as far as Steam is concerned). Steam doesn't provide a way for you to retrieve the ping to a lobby, so Epic would have to ping the lobbies themselves. If you use dedicated servers, pings will show up just fine.

    There's a 'fix' here
    http://www.aclockworkberry.com/ping-...ssion-results/

    Leave a comment:


  • replied
    Originally posted by TheJamsh View Post
    Yeah I just found that. I added the Authentication stuff the my WindowsEngine.ini file, but still unable to find any sessions. My session is definitely being created and registered according to the output log window, but I'm unable to find it on another machine with another Steam User. Session is created on Port 7777 and I get a valid lobby ID. I'm creating my sessions with presence enabled.

    I'm going to attempt to package up Shooter Game using my AppID's and see if I can find any sessions there. Perhaps that way I can see what else needs to be changed between versions.

    EDIT: So I've just tried this with ShooterGame and I was able to find and join a listen server session. Ping is still shown as 9,999 so that still doesn't work properly, but at least I was able to join. Going to check my code vs theirs.

    EDIT #2: Still no idea what's going wrong here
    I wonder if epic is going to fix a simple ping on 2020. its been ages and this is not working. maybe they will fix it when they release a game on steam but since they are not going to then no hope to fix this small issue unless you go to the source and change it by yourself.

    Leave a comment:


  • replied
    Thanks Matthew!

    Leave a comment:


  • replied
    Hello,

    As mentioned on the 4.20 release thread, we currently have a bug submission for this issue and I'm looking into it personally. I've reproduced the issue using the 4.20 release stream from Github and I'm currently narrowing down other versions.

    Edit: We are doing additional testing, but the bug report can be found here: https://issues.unrealengine.com/issue/UE-62144
    Last edited by Matthew J; 07-25-2018, 01:36 PM.

    Leave a comment:


  • replied
    Thanks for the update

    Leave a comment:


  • replied
    Originally posted by TheJamsh View Post
    Further update on this. I've tested several projects under several different scenarios now, this doesn't just affect me.

    Multiplayer Shootout: Launcher & Source builds work as intended.
    ShooterGame: Only Launcher build is able to find sessions. Source build fails.

    I've tried the fix mentioned by jimsnomis - still doesn't solve it for ShooterGame it seems.

    Further Update:
    It looks like using search filters is what breaks it. So you need to implement the fix provided by jimsnomis for the BuildID, then you also need to ensure that when you search for sessions, you're not using any search filters.

    *Finally* able to see sessions through steam. Ping is still 9,999... but that's a challenge for another day.
    See: https://forums.unrealengine.com/unre...04#post1505904

    MuchCharles tracked down where it is going wrong specifically

    Leave a comment:


  • replied
    Further update on this. I've tested several projects under several different scenarios now, this doesn't just affect me.

    Multiplayer Shootout: Launcher & Source builds work as intended.
    ShooterGame: Only Launcher build is able to find sessions. Source build fails.

    I've tried the fix mentioned by jimsnomis - still doesn't solve it for ShooterGame it seems.

    Further Update:
    It looks like using search filters is what breaks it. So you need to implement the fix provided by jimsnomis for the BuildID, then you also need to ensure that when you search for sessions, you're not using any search filters.

    *Finally* able to see sessions through steam. Ping is still 9,999... but that's a challenge for another day.
    Last edited by TheJamsh; 07-24-2018, 03:51 PM.

    Leave a comment:


  • replied
    Nah using my own app ID, getting nothing at all in the session list (keeps coming back empty). I'll just have to step through and see what's going on, as far as I can tell I'm not doing anything out of the ordinary. Perhaps it's not reading config settings from WindowsEngine.ini and falling back to DefaultEngine instead (that would be irritating). Down the rabbit hole we go...

    Leave a comment:


  • replied
    Originally posted by TheJamsh View Post
    Thanks for the help either way, looks like that's a good place to start. Did Bug team get back to you?
    np you're welcome, Yep bug team got back but before I located this specific issue, mailed them it now. Before this they couldn't repro but if it's build config related then it'd need a clean get and build to repro anyhow.

    BTW if you're using the placeholder steam ID 480 (Spacewars), you get a load of other people's sessions in the find results which are then filtered out by buildid so maybe that's what you saw - someone else's session.

    Leave a comment:


  • replied
    No worries, guess I'll have to try stepping through as well. Thanks for the help either way, looks like that's a good place to start. Did Bug team get back to you?

    Leave a comment:


  • replied
    Originally posted by TheJamsh View Post
    And is it working for you now? I've set up those settings in WindowsEngine.ini and it's still not finding any sessions. I've also checked the FNamedOnlineSession and it seems to be coming back with a valid BuildId, though not one I've specified anywhere.
    Yep it's all good here, though I add the settings to defaultengine.ini not windowsengine.ini. Tested with two projects now.

    Leave a comment:


  • replied
    And is it working for you now? I've set up those settings in WindowsEngine.ini and it's still not finding any sessions. I've also checked the FNamedOnlineSession and it seems to be coming back with a valid BuildId, though not one I've specified anywhere.

    Leave a comment:


  • replied
    Originally posted by TheJamsh View Post
    Well that explains a lot given that I'm using a source build packaged as an installed build. I'll give it a try and see if it works. Thanks for reporting back. How did you find this one?
    Stepped through the Source to find it in the end after a few process of elimination passes.

    Leave a comment:


  • replied
    Well that explains a lot given that I'm using a source build packaged as an installed build. I'll give it a try and see if it works. Thanks for reporting back. How did you find this one?

    Leave a comment:


  • replied
    I've found the problem which is to do with building unreal from source. It's fine with the prebuilt version. For the moment the work around is to override the buildid in the defaultengine.ini for the project:

    [OnlineSubsystem]
    DefaultPlatformService=Steam
    bUseBuildIdOverride=true
    BuildIdOverride=[somerandomnumber]

    In the source there's a changelist number defined which it uses as the buildID. This is set to 0 in 4.20 which causes the search to ignore the session as it needs to match by buildid for compatibiilty reasons.

    Leave a comment:

Working...
X