Announcement

Collapse
No announcement yet.

Steam online subsystem not finding server with find sessions with 4.20

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    #16
    Hello,

    As mentioned on the 4.20 release thread, we currently have a bug submission for this issue and I'm looking into it personally. I've reproduced the issue using the 4.20 release stream from Github and I'm currently narrowing down other versions.

    Edit: We are doing additional testing, but the bug report can be found here: https://issues.unrealengine.com/issue/UE-62144
    Last edited by Matthew J; 07-25-2018, 01:36 PM.

    Comment


      #17
      Thanks Matthew!

      Comment


        #18
        Originally posted by TheJamsh View Post
        Yeah I just found that. I added the Authentication stuff the my WindowsEngine.ini file, but still unable to find any sessions. My session is definitely being created and registered according to the output log window, but I'm unable to find it on another machine with another Steam User. Session is created on Port 7777 and I get a valid lobby ID. I'm creating my sessions with presence enabled.

        I'm going to attempt to package up Shooter Game using my AppID's and see if I can find any sessions there. Perhaps that way I can see what else needs to be changed between versions.

        EDIT: So I've just tried this with ShooterGame and I was able to find and join a listen server session. Ping is still shown as 9,999 so that still doesn't work properly, but at least I was able to join. Going to check my code vs theirs.

        EDIT #2: Still no idea what's going wrong here
        I wonder if epic is going to fix a simple ping on 2020. its been ages and this is not working. maybe they will fix it when they release a game on steam but since they are not going to then no hope to fix this small issue unless you go to the source and change it by yourself.

        Comment


          #19
          Originally posted by mhnoni View Post

          I wonder if epic is going to fix a simple ping on 2020. its been ages and this is not working. maybe they will fix it when they release a game on steam but since they are not going to then no hope to fix this small issue unless you go to the source and change it by yourself.
          It's not actually Epic's fault technically, It's actually a limitation of Steam Lobby Servers (which is what Listen Servers are as far as Steam is concerned). Steam doesn't provide a way for you to retrieve the ping to a lobby, so Epic would have to ping the lobbies themselves. If you use dedicated servers, pings will show up just fine.

          There's a 'fix' here
          http://www.aclockworkberry.com/ping-...ssion-results/

          Comment

          Working...
          X