Announcement

Collapse
No announcement yet.

UE4 4.19 Materials Broken

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    UE4 4.19 Materials Broken

    I'm having an issue with UE4 4.19. It's not loading or compiling materials correctly. I've seemingly tried everything at this point:

    Opened a new project and made a new material of just a single color (I get errors in the stat window right after creating the material, before I even plug anything into it).

    Imported a model textured in Maya as an FBX.

    Opened a Project from an older version of UE4.

    Downloaded a Substance Source material using the substance plugin.

    Uninstalled and reinstalled UE4 4.19.

    Verified installation of 4.19.

    Changed Metal version from 1 to 2 (UE4 will not open a project when set to 2).

    Everything fails. The material just loads with default checkerboard, and when I open the material to edit it I get a long bit of debug info in the Stats window, saying there's 20 errors generated. I also tried the preview build of 4.20, and it has the same issue. Does anyone have any ideas or experienced this issue? I need a blueprint that's only compatible with 4.19, and won't work in 4.18 (otherwise I'd just use that). I'm left with figuring out what's wrong with 4.19. 4.19 worked fine previously, either 4.19.0 or .1, but something since then has broken. I attached a text file with the errors I'm getting, I have no idea what I'm looking at in there.
    Attached Files

    #2
    I had a corrupt installation, and uninstalling through the epic launcher wasn't enough. If you experience a similar issue, make sure you delete the install folder yourself manually!

    Comment

    Working...
    X