Announcement

Collapse
No announcement yet.

Epic Launcher High CPU Usage

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

    Epic Launcher High CPU Usage

    Just got a Razer Blade 15" laptop... and the editor runs great and my game runs great.

    But the epic launcher uses like 75%+ CPU and causes the fans to kick in.

    So weird - only the launcher does this - ue editor runs great and games run great.

    If i kill launcher - cpu drops and fans turn off.

    On my desktop - Epic Launcher doesnt use crazy high CPU .... acts normal.

    Any ideas?

    So weird.....
    https://www.casualdistractiongames.com

    #2
    OptimisticMonkey

    There's loads of threads about this going back for years.
    Some devs (me included) opt to just disable the launcher.
    I link to some of those past Launcher threads in this post...

    Comment


      #3
      Easiest trick:

      Run the launcher so that everything is up to date
      Make a shortcut to the unreal editor (so you can launch any project)
      Close out of the launcher
      Navigate to it's folder location and just add a 1 to the start of the launcher's name.

      DO NOT relaunch the launcher while it's renamed or it will remember that exe name and continue to open in the future.
      Any time you need to update something, take the 1 out of it's name and open it.

      This is will keep it from ever reopening on you when you launch the editor.
      Last edited by IronicParadox; 06-10-2018, 01:22 PM.

      Comment


        #4
        This is nasty workaround

        I use to create direct shortcut to the project and I'm all good.
        "C:\Program Files\Epic Games\UE_4.19\Engine\Binaries\Win64\UE4Editor.exe" C:\Repo\MyGame\MyGame.uproject

        Also I was using a trick with adding empty PerforceBuild.txt to Engine\Build folder, but I'm not sure if it's still needed
        https://answers.unrealengine.com/que...-launcher.html

        Comment


          #5
          Originally posted by Cheshire Dev View Post
          This is nasty workaround

          I use to create direct shortcut to the project and I'm all good.
          "C:\Program Files\Epic Games\UE_4.19\Engine\Binaries\Win64\UE4Editor.exe" C:\Repo\MyGame\MyGame.uproject

          Also I was using a trick with adding empty PerforceBuild.txt to Engine\Build folder, but I'm not sure if it's still needed
          https://answers.unrealengine.com/que...-launcher.html
          The editor will still launch the launcher after a few minutes. The perforce trick works as well though.

          Comment


            #6
            Thanks for the feedback.... crazy something as simple as a launcher uses up that much cpu
            https://www.casualdistractiongames.com

            Comment


              #7
              A simpler solution is to go into the launcher settings and enable the system tray option. Once it is minimized to the tray, which can be done by closing the launcher, it will use 0% CPU/GPU.

              Hope that helps!
              Free Community Ocean & Sky Project || Join us on Discord! || Trello Roadmap

              Comment


                #8
                I found that rebooting my machine fixed it for me.

                Comment

                Working...
                X