Announcement

Collapse
No announcement yet.

Why Python 2.7?

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Why Python 2.7?

    Tried to do a little digging before making this post, but didn't find anything relevant.

    With the introduction of Python to UE4, why not use the most current standard version? (at the time of this post, 3.6.5)

    I know we can compile from source with our own version, but I would fear branching the audience when UE4 does finally switch. Python 2.7 will be ending support in 2020, and according to the vfx platform (http://www.vfxplatform.com/) with be standardizing Python 3 next year, with the other applications we all use probably following. I get the feeling the version picked was heavily influenced by what Autodesk has been using, who are probably not the best role models of staying current.

    Just wanted to know if Python 3 was on the radar, if it is being tested by anyone else than myself, and what's driving the reason behind implementing Python in the first place I guess?

    #2
    You've already listed the reason in your question

    The VFX standard right now is 2.7, aiming to move to 3 by the EOL of 2.7. That said, we've been forward facing on this and Python 3 works just fine with our plugin (and I make sure it stays that way), so when the time comes to switch it shouldn't be an issue on our side.

    Comment


      #3
      Yay! I hate currently moving between 2.x and 3.x for various projects and whatnot. So glad to hear that standards are evolving. Thanks for the forward thinking.

      Comment

      Working...
      X