Announcement

Collapse
No announcement yet.

Ever since upgrading my monitor to a 1440p one, the UE4 editor performs terribly

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

    [EDITOR] Ever since upgrading my monitor to a 1440p one, the UE4 editor performs terribly

    I got a new monitor a few months ago. A S2716DG. It's a 1440p, 144Hz monitor. While I used to get silky smooth framerates in the editor (pretty much always over 120, locked to that), for some impossible reason UE4 now performs terribly. Sure, it could be the resolution. Downsizing the screen does nothing. Everything is sluggish, using blueprints is painful.

    Is there a way I can debug this? What the heck could be causing these problems?

    Thanks!

    #2
    In a desperate attempt to fix this after months of pain, I had a moment of clarity. I upgraded my 4 month old drivers (could have helped) and disabled non-exclusive-fullscreen G-Sync (probably the issue).

    Silky smooth 120FPS blueprint programming. Please lock this thread!

    Comment


      #3
      The editor doesn't work with gsync, yeah. You don't have to disable it system wide, I turned it off for UE4Editor.exe in program specific settings.

      Comment


        #4
        Found this reply and super happy I did because it was making sad to choose between GSync for windowed games vs UE4 laggy issues.

        A little more useful information, in your NVidia settings, choose manage 3D Settings, add programs, pick Unreal Engine. Then in the settings for UE click on Monitor Settings and switch it from Default(GSync) to Fixed Refresh Rate.

        Comment


          #5
          I don't have G-Sync in my Nvidia settings?

          Comment

          Working...
          X