Announcement

Collapse
No announcement yet.

Massively speed up light building and shader compiling!! adjust UE4 affinity to LOW

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    #16
    IT REALLY WORKS! SUPER! Lots of thanks!

    Comment


      #17
      it doesn't work at all. I 've set Priority to Low for Unreal Engine, and the Shader Compiler to High and even created a material instance. It takes 20 secs to compile shaders each time. I am trying to change a refraction value and this is making it impossible to work with. Why is everything with UE so **** complicated? There are so many people talking about this issue on so many different threads and there is no solution... I have worked with Unity, Sketchfab, Marmoset, 3DCoat and none of them had this issue. I even had to research how to import a model from 3dsmax to Unreal for god's sake because apparently you have to be working in meters inside 3dsmax but export in cm!!! Everything about this engine is so counter intuitive!

      Comment


        #18
        At least, this worked for me.
        I have been stuck for an hour always when materials are being loaded but setting different priorities on this tasks, worked and got forward.
        Thnx

        Comment


          #19
          Originally posted by DarkHorror View Post
          are shaders, and light building taking you a long time? Since those are done as other tasks setting UE4 priority to low will give the light building and shader compiling priority over the UE4. It makes it go much much faster. at least on my i5 3570k. I would guess maybe on an i7 you won't get such a speedup. But on slower machines especially ones slower than mine, it can help a lot.
          This might be a language barrier, but I've been trying to find the affinity settings, but couldn't find it. Could anyone perhaps explain to me how this is actually achieved? Thanks!

          Comment


            #20
            @fartwork69 see post #11 for how-to

            @BYOB3D and ThanosBob it's possible your machine specs are too high for this to help, and you have a different bottleneck

            @DebellicA it's definitely hacky and so it helps to know what's going on, i'll break it down for anyone interested:
            • apps normally run at normal (0)
            • UE4 spawns compiler threads at below normal (-1)
            • we fix this by setting other apps to low (-2)
            if we take this route, we actually need to set ALL apps to low. EpicGamesLauncher will start hogging CPU immediately, and i turned off firefox.

            alternately, the idea of setting the shader compiler to high (+2) should fix everything with no other changes. but I could not figure this one out, the shader threads keep coming and going for me.
            Last edited by dadtaru; 12-23-2020, 02:08 PM.

            Comment


              #21
              To set the shader compiler priority to a default value for each compiler instance, we can access the BaseEngine.ini file located in Engine\Config directory. Open the file and search (ctrl + F) for "workerprocesspriority" and set the corresponding priority value to whatever suits your needs: -2 = Low, -1 = Below Normal, 0 = Normal, 1 = Above Normal, 2 = High.

              Comment

              Working...
              X