Announcement

Collapse
No announcement yet.

4.19 & 4.20 Editor & Packaged Games Have Hangs/Hiccups Constantly

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    #46
    I have tested nVidia drivers and:
    385.69 (September 21, 2017) is the last driver that doesn't show these problems (hiccups with Material Billboard).
    387.92 (October 9, 2017) is the first one where I get hiccups.

    Comment


      #47
      Originally posted by Naifu View Post
      I have tested nVidia drivers and:
      385.69 (September 21, 2017) is the last driver that doesn't show these problems (hiccups with Material Billboard).
      387.92 (October 9, 2017) is the first one where I get hiccups.
      The problem is that with 4.17 and 4.18 the issue does not appear no matter the driver version. There might be a change in the driver along with a change in the engine that together causes the issue, we will in the end relly on the dev team to pin point the issue and fix it. As developers ourselves we might consider the developers/gamers/users will always try to have the latest drivers installed, since many provide a benefit on gameplay for several games/features.
      Nilson Lima
      Technical Director @ Rigel Studios Ltda - twitter: @RigelStudios
      Join us at Discord: https://discord.gg/uFFSEXY

      UE4 Marketplace: Cloudscape Seasons
      supporting: Community FREE Ocean plugin

      Comment


        #48
        I recently ran into this problem as well and opened a thread about it, where I was referred to this one.

        The issue is seemingly caused by any particle system with mesh emitters in my case. I could reproduce it on two different machines with Nvidia GPUs so far (970 and 1080) by creating an empty new project, creating a default emitter with mesh data, and putting a bunch of those emitters in an empty new level. You can download the project here: https://drive.google.com/open?id=1ND...52t7aZVtW71UUK

        Video demonstration:

        Comment


          #49
          Originally posted by Efrye View Post
          Video demonstration:
          Oh wow, that's pretty terrible... My guess is there is some kind of additive error, within the particle loop, going on that isn't being cleared or clamped properly. The longer it runs, the larger the number gets, the larger the frame hitch.

          Comment


            #50
            Yeah, it makes 4.19 completely unusable for me unless I disable all of my mesh emitters. The frequency of those hitches, and thus the speed at which they escalate, depends on the number of mesh emitters in the level though. So if there's only a handful of them, it takes much longer for the issue to become noticeable. I assume that's why the problem isn't getting more attention.

            Comment


              #51
              Originally posted by Efrye View Post
              Yeah, it makes 4.19 completely unusable for me unless I disable all of my mesh emitters. The frequency of those hitches, and thus the speed at which they escalate, depends on the number of mesh emitters in the level though. So if there's only a handful of them, it takes much longer for the issue to become noticeable. I assume that's why the problem isn't getting more attention.
              Seems to jive with my initial complaint/experience. Particle systems with a mesh (albeit one particle that rotates) and a couple hundred of them since they are pickups all over a large Map. Same symptoms.

              Comment


                #52
                The issue 57740 fixed in 4.19.2 really was not even touch this present issue. All the same using the example project Motus Digital provided. We gotta wait then.
                Nilson Lima
                Technical Director @ Rigel Studios Ltda - twitter: @RigelStudios
                Join us at Discord: https://discord.gg/uFFSEXY

                UE4 Marketplace: Cloudscape Seasons
                supporting: Community FREE Ocean plugin

                Comment


                  #53
                  Hey all,

                  I just wanted to chime in and say I have noticed this issue as well. It is quite intrusive and definitely makes working in the editor difficult. As a level designer I need to manipulate and place many objects in a scene efficiently, which is hard to do when the editor hitches whenever I rotate the camera, or an object, or anything!

                  Motus Digital I sincerely believe the issue is related to the Shared Data Cache prompt that appears now when running 4.19. I found a user on the AnswerHub who reported this issue for 4.19, and there is no real answer as to whether or not all users NOT using a shared DDC are affected by these hitches.

                  Would you/anyone/everyone confirm if they are using a shared DDC for their projects?

                  https://answers.unrealengine.com/que...ing-to-41.html

                  I think this could be the culprit, however; I am not 100%

                  Cheers,

                  Comment


                    #54
                    Originally posted by AHLabrodex View Post
                    Would you/anyone/everyone confirm if they are using a shared DDC for their projects?
                    As I mentioned in my post above, I could reproduce the bug in an empty new project, so I don't think it's related to Shared Data Cache.

                    Comment


                      #55
                      Having the same problem with 4.19.2. World runs smoothly in 4.18, but hitches every 10 seconds or so in 4.19.2. The freeze is very brief in a standalone game, worse in editor window. Seems to be related to number of billboard textures in the viewport??

                      Comment


                        #56
                        We are noticing this as well, is this happening in built standalone game as well?
                        Is there a response from Epic, is there a fix we can integrate? This is a huge problem for us due to the use of mesh particles we use.

                        Comment


                          #57
                          Originally posted by BandanaKid View Post
                          We are noticing this as well, is this happening in built standalone game as well?
                          Is there a response from Epic, is there a fix we can integrate? This is a huge problem for us due to the use of mesh particles we use.
                          I don't think there's any response from Epic yet, but there's a bug report you can put your vote on to get their attention:

                          https://issues.unrealengine.com/issue/UE-58676

                          The only "fix" I've seen so far is to install an older Nvidia driver version:
                          Originally posted by Naifu View Post
                          I have tested nVidia drivers and:
                          385.69 (September 21, 2017) is the last driver that doesn't show these problems (hiccups with Material Billboard).
                          387.92 (October 9, 2017) is the first one where I get hiccups.

                          Comment


                            #58
                            According to the latest update to the issue mentioned above, this won't be fixed until 4.21.

                            So I guess I'll be stuck with 4.18 for 6-12 months. Game development sometimes...

                            Comment


                              #59
                              Originally posted by Efrye View Post
                              According to the latest update to the issue mentioned above, this won't be fixed until 4.21.

                              So I guess I'll be stuck with 4.18 for 6-12 months. Game development sometimes...
                              And of course those of us who are creating products for the Marketplace need to make them work "correctly" with 4.19 or whatever current rev., so we are forced to find a workaround without the luxury(?) of hanging out in 4.18. ... or 4.16 or whatever rev. one's stuff worked perfectly in with no need for improvement. Technology marches on!

                              Comment


                                #60
                                With 4.20 coming at July you would expect a 4.21 not earlier than December and not later than February 2019.
                                Nilson Lima
                                Technical Director @ Rigel Studios Ltda - twitter: @RigelStudios
                                Join us at Discord: https://discord.gg/uFFSEXY

                                UE4 Marketplace: Cloudscape Seasons
                                supporting: Community FREE Ocean plugin

                                Comment

                                Working...
                                X