Announcement

Collapse
No announcement yet.

4.19 & 4.20 Editor & Packaged Games Have Hangs/Hiccups Constantly

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • replied
    Originally posted by VictorBurgos View Post
    My Blueprint Compile times have also gone up, along with the Editor hangups. It seems worse in 4.19.1 somehow. But all of this is worse than 4.18. I know the BP Compile time issues are from the Compilation Manager.

    Even hitting Play for PIE is gross
    I'm glad others are able to somewhat verify my issues, but of course it saddens me that these issues exist for them. Victor and others are having a tougher time than me, getting rid of the two particles made my situation acceptable. Although I still get a crappier performance and occasional screen hangs that were not there in 4.18 and PIE.

    Leave a comment:


  • replied
    My Blueprint Compile times have also gone up, along with the Editor hangups. It seems worse in 4.19.1 somehow. But all of this is worse than 4.18. I know the BP Compile time issues are from the Compilation Manager.

    Even hitting Play for PIE is gross

    Leave a comment:


  • replied
    For the record, me:
    24GB system, 980GTX 4GB GPU, i7-4790K @4.00Ghz+ 4 cores/ 8 threads

    You have a nice machine Nilson!

    I have not tried re-updating to 391.35 yet, not sure it will make a difference with 4.19.1

    Leave a comment:


  • replied
    Originally posted by motorsep View Post
    How much RAM do you have ? I had the same issue until I upgraded to 16Gb of RAM.
    32GB on system and 8GB on GPU, processor at 3.9GHz - 8 cores/16 threads.

    Leave a comment:


  • replied
    How much RAM do you have ? I had the same issue until I upgraded to 16Gb of RAM.

    Leave a comment:


  • replied
    Originally posted by Motus Digital View Post
    FYI - I tried it in 4.19.1 and the same problem exists. Does not seem to be addressed yet.
    Yes, the majority intent on the .1 release is to address crashes.

    Leave a comment:


  • replied
    FYI - I tried it in 4.19.1 and the same problem exists. Does not seem to be addressed yet.

    Leave a comment:


  • replied
    Thanks for the verification Nilson! I will post any info/progress I receive.

    Cris

    Leave a comment:


  • replied
    After seeing your video, I entered the project again and waited, waited, and the hiccups started to appear. The gap from the FPS at the hiccups increased and I found another thing interesting: while the editor is open (not running or simulating) if you click outside the editor in a way for it to lose the window focus (ie: you can click on Windows' Toolbar in the bottom) and then click in the editor again, you will see that the FPS presents a large difference from what it was before. To see the regular FPS back, the only way is to run or simulate. Im rolling back the driver just as an experiment.

    PS: I have rolled back 5 versions back and the issue still there, so one can really reproduce it. As soon you get the issue number, let us know, so we can vote on it for fix priority
    Last edited by NilsonLima; 04-10-2018, 09:27 AM.

    Leave a comment:


  • replied
    Thanks all, I appreciate everyone's attention and efforts on this.

    I have reported the bug FWIW, we'll see what happens and how long it takes to find out what the real deal is. Reproduce-able bug, driver issue, something else, or my machine is a delicate rare flower that just doesn't like 4.19.

    FYI the video I made and sent to Epic, if you want to see what I am seeing FWIW.
    https://vimeo.com/263995984

    Leave a comment:


  • replied
    Originally posted by NilsonLima View Post
    I tested the project but got no issues, also I didn't touch Windows updates or the driver version... it must be something else... I would suggest to you rollback a driver version if it is not the latest one installed, there was a release for NVidia drivers with optimizations for Fortnite (not the last, but the previous one if Im not mistaken).

    I do feel the scene has a timed consumption of resources and the FPS drops like 20 FPS each 2-3 sec aprox.
    Thank you for testing.

    Seems like it is a graphics issue of some sort, I'll try rolling back 4 versions since it has happened last three. Plus the fact that you are getting a "timed consumption of resources and the FPS drops like 20 FPS each 2-3 sec" tells me there still might be something universal there, just not as drastic on your hardware as mine.

    So far I have replaced the offending Particles with static mesh and rotating them with a looping Timeline, turning off all shadows/indirect lighting/etc. has my simulation apparent overhead as low as it was with Particles(fps is as high as before). That may be my fix till I can get more corroborating evidence with the particles evil or lack of it.

    Bottom line, Particles no prob 4.18, Particles big prob 4.19 - which means there is something going on Epic changed regardless of it affecting my machine(and likely others with similar) only as far as anyone has reported yet.

    Leave a comment:


  • replied
    I tried as well and definitely saw the stuttering. I believe I'm getting something similar but no where near as frequent and bothersome as that. gtx970 on driver 391.35 fwiw.

    Leave a comment:


  • replied
    I tested the project but got no issues, also I didn't touch Windows updates or the driver version... it must be something else... I would suggest to you rollback a driver version if it is not the latest one installed, there was a release for NVidia drivers with optimizations for Fortnite (not the last, but the previous one if Im not mistaken).

    I do feel the scene has a timed consumption of resources and the FPS drops like 20 FPS each 2-3 sec aprox.
    Last edited by NilsonLima; 04-09-2018, 07:28 PM.

    Leave a comment:


  • replied
    DIRECT CAUSE OF PROBLEM DISCOVERED - EPIC "PICKUP" PARTICLES

    After hours of detective work and deleting BP and everything but the kitchen sink out of the Project - the problem was the kitchen sink, the free Epic ShooterGamePack Particles:

    "P_AssaultRifle_AMmo" and "P_Health"


    Click image for larger version

Name:	Epic_PickupParticles_01.PNG
Views:	1091
Size:	9.4 KB
ID:	1458070

    Remove these from my custom Pickup BPs, issue disappears instantly. Without removing the particles, the frequency of the "stutter" drops in relation to how many instances in the Map. With only one containing Pickup in the scene it hangs hard about every 10 seconds. This was the problem all along, pretty dramatic and crippling affect on a Project. Good grief, what a waste of two days.

    I was able to replicate it by adding 70+70(to get the quicker stutter frequency) instances of them to a blank 4.19 Project with nothing in it but the particles and associated meshes and material. A noticeable hang around every second. (Your hardware may produce a different timing) Please download the 4.19 Project "ParticleTest" and see for your self(or not?), leave it open about five minutes and the rotating particles will start pausing. Unless once again my PC is super special and hates 4.19 individually....

    Download:
    https://drive.google.com/drive/folde...ua?usp=sharing
    ParticleTest.zip

    I tried replacing the Ammo/Cross meshes with the default "no mesh" cube in the particles, but same result. It seems the particle system itself is causing the problem, not its referenced mesh.
    I suppose I can simply put a static mesh in the pickups, but not as snazzy as a rotating particle. Sucks. Better ideas anyone?

    EPIC: Why do these stock particles hangup and bring 4.19.0 to its knees? I will be submitting this as a bug.

    Leave a comment:


  • replied
    Thanks for everyone's input, a common thread here but hard to tell if they are all the actual same issue.

    I don't have temperature specs, but as I mentioned I am running at 29% and lower CPU with lots of RAM overhead, no unusual and extremely low Disk activity. When Building lights the CPU pegs 100% and my fans kick into high gear noisily, so I no there is no thermal issue. My specific 980GTX video card and all current drivers the culprit? Who knows.

    So to be a broken record, no unusual hardware activity, it just putts along normally. Hiding and showing the viewport turns off/on the stutter in the rest of the editor like a switch (like a video/graphics/driver problem). Unchecking "Realtime" turns off/on the stutter in the editor like a switch. I have never un-checked the "Realtime" in any version of UE4 for years - except in 4.19 as a last resort, and of course simulating it returns as Realtime is back on. And a Packaged exe runs perfectly, no problems, only the editor hangs.

    I appreciate everyone's eyes on this so far.

    So what is the viewport in 4.19 reacting to that hasn't been an issue since 4.16? Once again I implore Epic to suggest a rendering/viewport setting(or?) to hopefully negate this new incurred behavior in 4.19, hence the reason I am posting in this "Epic Feedback" forum.

    Leave a comment:

Working...
X