Announcement

Collapse
No announcement yet.

4.19 & 4.20 Editor & Packaged Games Have Hangs/Hiccups Constantly

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Originally posted by Efrye View Post

    I think 57557 and 58676 may have been fixed in 4.20 P3, or at least I can no longer reproduce them on my system either. I can still reproduce it in 4.19. (Windows 10, GTX 970 (Nvidia driver 398.11), 32 GB RAM, i7-4790K @ 4.00GHz).
    Internally we would sometimes find a programmer or artist who experienced similar issues. Usually about 1 per month and then it would go away. Eventually we found that it was actually the TBB allocator that was getting hung up sometimes. We talked to Intel and 4003112 (which hit 4.20) resolves these kinds of issues. Of course it's entirely possible that you were hitting a completely DIFFERENT source of hitching.

    Comment


      Originally posted by Deathrey View Post

      Note, that drawing to a render target from a blueprint is easily reproducible, but it is not the only activity that demonstrates the issue. Particle systems are also affected.
      Might be something about creating / updating buffers on the fly.

      If you decide not to hotfix this in 4.20, a brief description of the issue, once located, would be helpful, so that others can patch it up for themselves.

      Godspeed to ones, trying to locate the cause.

      Creating buffers is definitely one trigger. Updating buffers, I'm not so sure yet.

      Comment


        in our case... specially with 4.19... DrawMaterialToRenderTarget totally sinks the editor FPS.. from 120 to 70fps on a GTX1070.
        Is that solved on 4.20? because water simulation on our game was kinda ruined.

        I actually have an example project with 4.18 and 4.19 being exactly the same, but having those issues

        Comment


          Waurelius If you need another project to test you can download the one in my signature. It has quite a bit of hitching on my system (8700k & gtx 1080) but doesn't always happen right away, you might need to make changes to the world such as adjusting some values on BP_Ocean and moving things around, or switching between PIE and editor a few times. Not sure what triggers the hitching, but it will start after using the project for a bit. Don't have a 4.20 version on GitHub yet but can add a new branch if needed.
          Free Community Ocean & Sky Project || Join us on Discord! || Trello Roadmap

          Comment


            I having the same problem in a VR project I've made. The hitching starts after about 2 minutes (very short hiccup) and gets worse over time (severe hitches). Restarting the executable repeats this behaviour: no hitching for the first 2 minutes, then worse. The hitching occurs in the editor and in the packaged version. Simply starting the executable and the console command 'stat unit' shows the performance going down the drain after a few minutes. I went back to nVidia driver version 385.69: no more hitching. But you can't expect people to install such an old driver...

            Comment


              It it just me or has the latest nvidia driver update (398.36) released 26.6.2018 made it better?

              Comment


                Haven't checked it out tbh... i'll give it a try and report back... hopefully this can solve the issues

                Comment


                  Originally posted by StickySnoutStd View Post
                  It it just me or has the latest nvidia driver update (398.36) released 26.6.2018 made it better?
                  Just tested with my game, and 398.36 did not help. The stuttering/hitching is the same as it has been since 4.19's first release.

                  Comment


                    Moving forward as there will be no update on 4.19 - how about 4.20? Are the hiccups still there?

                    Comment


                      Originally posted by Syed View Post
                      Moving forward as there will be no update on 4.19 - how about 4.20? Are the hiccups still there?
                      Look at the thread title
                      Easy to use UMG Mini Map on the UE4 Marketplace.
                      Forum thread: https://forums.unrealengine.com/show...-Plug-and-Play

                      Comment


                        Originally posted by StickySnoutStd View Post
                        It it just me or has the latest nvidia driver update (398.36) released 26.6.2018 made it better?
                        Tried it: still the same hitching after 2 minutes. Driver version 385.69 does not hitch, but takes 8 - 8.2 ms to render a frame in my project. Newer driver versions only take 5 - 6 ms. They started using a different method to render I suppose, but it has this terrible bug.

                        Comment


                          Yeah, sorry it's me... the stuttering started again i guess i was just lucky for an hour or so there...

                          Comment


                            Originally posted by John Alcatraz View Post

                            Look at the thread title
                            Lol.. I have been following this thread for quite some time - I think the OP must have edited the title along the way..

                            Actually what I mean is it is more helpful to report based on the latest 4.20 preview (not 4.19). 4.19 will not be updated anyway...

                            Comment


                              Originally posted by Syed View Post

                              Lol.. I have been following this thread for quite some time - I think the OP must have edited the title along the way..

                              Actually what I mean is it is more helpful to report based on the latest 4.20 preview (not 4.19). 4.19 will not be updated anyway...
                              This bug is already set to be fixed on the final 4.20 release. At least the one related to drawing to Render Targets
                              Freelancer Game Dev Generalist and Unreal Consultant | Portfolio
                              Unreal products: Dynamic Picture Frames, Neo Kinect

                              Comment


                                Originally posted by Syed View Post
                                Moving forward as there will be no update on 4.19 - how about 4.20? Are the hiccups still there?
                                I'd recommend to just download the latest preview and give it a shot. 4.20 P3 fixed the hiccup issues I was having, but it would appear that there are several different causes for the same symptoms.

                                Comment

                                Working...
                                X