Announcement

Collapse
No announcement yet.

UE4 pop-up menu's (import, saving, etc) always on different location/locks me out.

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    [FEATURE REQUEST] UE4 pop-up menu's (import, saving, etc) always on different location/locks me out.

    So I am not sure if this needs to be a feature request or a bug-report.
    This never really happened until recently, I either never really noticed it, or its because I now got a 4 monitor setup.
    Havent tried with all ue4 versions, but def. know it happens in 4.16 and up.

    I have 4 monitors from left to right: 1080p huion, 4k monitor 1, 4k monitor 2 (main monitor), 2k monitor.
    I use UE4 on my main 4k monitor.

    for some reason the pop-up menu's like Import/Export/Saving/etc all are located between halfway my Huion and left 4k monitor.

    The problems:

    The first time these menu's pop up they are opened in the center of my main 4k monitor, on which I have ue4 open and active.
    Any pop-up menu after that opens halfway the most left and 2nd most left monitor.
    but sometimes they dont appear at all and are located god knows where.
    I cant interact with them, I cant move them with the windows key and arrows and even if I could move them since I dont know where they are I dont know which direction I would need to move them.
    This basically locks me out of UE4 unless I can close the menu.

    A workaround that doesn't always work is setting another monitor as "Main monitor" so the menu pops up on a random other monitor.
    Another workaround is (sadly) closing ue4 trough the task manager and deleting the ini files in the config folder. (which results in other stuff being reset as well)
    Not to mention it starts all over again with the menu's appearing correctly the first time and then go back to being centered on the edge of the left most monitors.

    The pop-up menu's show up in the Alt-Tab list but I cant move them, cant access them, and since sadly just pressing Enter does not work on these menu's I am basically screwed.
    So my question is, please for the love of people who use a lot of monitors, and for the love of sanity add an option that these menu's are always forced to appear in the center of the monitor that has ue4 active.

    I'll attach a zipfile with the config files and dxdiag, in the hope someone can pinpoint the problem and solve this.
    http://www.filedropper.com/monitorissue < there you go.

    #2
    I've actually been looking into this to make it more consistent. I'll post up with an update when I've got an actual fix.

    Comment


      #3
      any update on this?

      Comment


        #4
        Apologies, this is somewhat delayed but should be done next week.

        Comment


          #5
          Originally posted by project.gheist View Post
          Apologies, this is somewhat delayed but should be done next week.
          While I kinda was asking more globally, glad to hear this. hopefully that will solve a lot of my frustrations

          Comment


            #6
            Unfortunately I've been unable to reproduce this issue locally. I can see from come where it might go wrong (which is when the pop up menu determines which window to center on), but I'm unsure as to why and what would cause that. I did make a PR which would resolve an issue I was having regarding notifications showing up on different monitors every time (see https://github.com/EpicGames/UnrealEngine/pull/4524).

            Comment


              #7
              Hey Luos

              I know RCL followed up with you about the "Tab+Esc" option to quit, but we just had a few follow-up questions to help us in debugging this.

              Do you use any sort of monitor manager software, like DisplayFusion? What version of Windows are you on?

              Also, are you able to hover over the Unreal Engine logo on the taskbar when the FBX import dialog is up and see the dialog? If so, you should be able to right-click it and either Close or Move it. If you select Move and then press an arrow key, the dialog should jump to your mouse cursor.

              Definitely looking into this, just all the details help thanks!

              Comment


                #8
                Suffering from the issue too. Pop-ups are there for good or offscreen elsewhere.
                Using custom DPI scaling.
                The issue is only reproducible with custom DPI scaling enabled.
                It Started in 4.18, along with terribly over-sized UE4 UI issue.

                Comment


                  #9
                  Originally posted by Deathrey View Post
                  Suffering from the issue too. Pop-ups are there for good or offscreen elsewhere.
                  Using custom DPI scaling.
                  The issue is only reproducible with custom DPI scaling enabled.
                  It Started in 4.18, along with terribly over-sized UE4 UI issue.
                  Luos, are you also changing the DPI? Are you using High DPI mode in the editor?

                  Just to double-check, Deathrey, how are you changing the DPI in the editor?

                  Thanks so much for any details you can give!

                  Comment


                    #10
                    Originally posted by Shadow.Storm View Post

                    Luos, are you also changing the DPI? Are you using High DPI mode in the editor?

                    Just to double-check, Deathrey, how are you changing the DPI in the editor?

                    Thanks so much for any details you can give!
                    I've experienced issue on two separate machines with the following setup:

                    1) Main monitor @ HD, second monitor @ 720p Win7 dpi scaling is set to 125%. With High DPI UE4 editor setting enabled, the issue is present. With Editor HighDPI disabled, everything is sound.

                    2) Main monitor @4k, second monitor @4k Win7 dpi scaling is set to 200%. The editor UI looks off, disregarding of Enable High DPI Support checkbox.

                    In both cases, setting DPI scaling to default 100% in OS, resolves the issue.
                    The only common thing between two machines is really dpi scaling settings in OS.

                    Comment


                      #11
                      Do you use any sort of monitor manager software, like DisplayFusion?
                      No, just regular win10 pro

                      What version of Windows are you on?
                      This has been going since last year may, ever since I replaced one of my monitors for two 4k ones. (also obtained a new gpu since October last year 780ti > 1080ti)
                      Besides a long period summer last year, I always kept win10 up to date, but have reinstalled it twice since.

                      To be fair, I cant remember this being an issue before I got my third monitor so I cant remember if it actually occurred back then.

                      so, are you able to hover over the Unreal Engine logo on the taskbar when the FBX import dialog is up and see the dialog?
                      This logo is not available on the taskbar, as a matter of fact more than often content browser, material editors, and other browsers seem to prefer monitor 2 (4k) its taskbar than my main monitor (4k).


                      If so, you should be able to right-click it and either Close or Move it. If you select Move and then press an arrow key, the dialog should jump to your mouse cursor.
                      This doesnt work as there is no taskbar icon.
                      to clarify, even selecting the menu with alt + tab and then alt+spacebar and pressing the button for "move" does not work.


                      Luos, are you also changing the DPI? Are you using High DPI mode in the editor?


                      Monitor 4: huion 220v2 1080p - No dpi changes
                      Monitor 2: Samsung UHD 4k - No dpi changes, size of text, apps, other items 150%
                      Monitor 1: Samsung UHD 4k - No dpi changes, size of text, apps, other items 150% (main)
                      Monitor 3: LG 2715x1527 resolution - No dpi changes, size of text, apps, other items 125% < oddball resolution, but even after setting it to 1080p doesnt solve the issue.

                      I am not changing dpi inside software (at least, not unreal engine 4)

                      This setting is identical for any and all ue4 versions I use. (currently only 4.16 up to 4.19 installed)


                      I havent used ue4 since my talk with RCL so havent had the time to try out tab+esc.
                      If you have any further questions or would like to do a call/hangout/seagull/pigeon im all up for that.

                      Comment


                        #12
                        Okay, thanks for the update! Definitely will help as we look into this.

                        Comment

                        Working...
                        X