Announcement

Collapse
No announcement yet.

Editor so slow/unresponsive when Blueprint Windows are open!

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • replied
    Click image for larger version

Name:	slowanreel.gif
Views:	544
Size:	21.7 KB
ID:	1417219






    PS. I don't use a shared DDC

    Leave a comment:


  • replied
    Wow, that's pretty weird... In the past, I've tried clearing out the DCC cache in my AppData\Local\UnrealEngine\4.18 folder and that never did anything anything, but switching it to -ddc=noshared caused my fps to almost triple in the editor viewport? (I made sure the cache location changed, and within the ue418 install folder, there's a DCC folder now and within the project folder, there's also a DCC folder)

    Now I should note that I haven't had my editor open for a few days and in that time, my Windows updated to the fall creator edition, so it's hard to say if it was a windows issue or if that noshared option did the trick. Guess I'll never know now lol...

    Leave a comment:


  • replied
    Some editor performance problems are actually from the windows appearance / performance settings.

    My friend's i9, 1080 ti and 32gb rig with windows 10 feels like sloth in ue4 editor with all visual settings enabled in windows. I fixed this by right clicking on "This PC" and then properties, this will take you to the system settings. you can also go to [Control Panel \ All Control Panel Items \ System]
    I then went to advanced system settings on the left and then i hit the performance settings button. you can either toggle adjust for best performance or custom, don't let it decide what to use, and don't adjust for best appearance.

    Also, I drastically improved editor performance by creating a shortcut for the project im working on and using this option.
    Originally posted by SHORTCUT Target
    C:\SourceControl\GameProject\GameProject.uproject -ddc=noshared
    This option is great if you're working by yourself, have a team over the internet, or local team is not using Derived Data Cache.
    If you have a local team and are using a central DDC location don't use this option.
    Learn more about DDC here
    If you have windows 10's fall creator pack, disable game mode and game dvr. Turn advanced power settings to high performance if on desktop pc. and if you have nvidia card, disable geforce experience.

    Also turn off the real time thumbnails in the content browser. View Options in the content browser.

    I have had varying performance improvements for each item, but overall it's become much better and tolerable.
    For some crazy reason, my work i5 780 16gb pc runs the editor far superior than my friends i9 1080ti 32gb setup. Obviously things like lighting bake run faster, but editor performance itself runs better on mine than his. So there has to be something else that is causing the performance hit.
    Last edited by SaxonRah; 01-18-2018, 06:16 PM.

    Leave a comment:


  • replied
    I don't update my Windows 10 version, i'm actually actively blocking access to Windows Update so it doesn't just download random patches to my system. But the editor feels clunky now even on clean/new projects, it's a real shame, this engine was great when i started using it.

    Leave a comment:


  • replied
    I've had the issue since late last year so it wouldn't be the new fall creative edition. I'm actually on windows build 15063 which is previous to the Falls Creator Update, to the Creator Update and even previous to the Anniversary Update
    disabling the UE setting to reduce usage in the background didn't help either (was one of the first suggested things I tried)
    I have a GTX 970

    Leave a comment:


  • replied
    Strange - I wonder if it is limited to gtx 1080 and above.

    I am experiencing the same thing - gtx 1080 ti. My friend has same problem too - and has a gtx 1080.
    My laptop doesnt have the issue, it has a 970m.

    Can anyone confirm they are using a gtx 1080 and not seeing the slowdown with any slate/bp editor windows open?

    Leave a comment:


  • replied
    Did your Windows update to the new fall creative edition? Microsoft pushed it out to the masses this week and it's possible that it could have screwed with your game dvr settings or something along those lines. I know there has been all sorts of complaining about the update screwing with game/application performances. Google around for "windows 10 fall creator update fps fix" and you'll literally see hundreds of posts talking about this.

    If it isn't that, then perhaps you could try disabling the UE setting to reduce usage while in background(can't remember the setting name off the top of my head). It's possible that it's throttling the other other viewports when you are clicked into another window like a blueprint.

    Leave a comment:


  • replied
    Sorry guys, but this issue was non-existing in 4.10 and before - i was using Windows 10 back then already. I don't have GeForce Experience installed either.

    Leave a comment:


  • replied
    1. yes, I uninstalled it
    2. I don't use that
    3. what should I do about Win10?

    I've ruled all the others too. went through the list of programs that conflict with UE4 (not running any), and tried DX12 (crashes when compiling shaders)
    Last edited by Chosker; 01-16-2018, 05:50 AM.

    Leave a comment:


  • replied
    Originally posted by Chosker View Post
    that helped a bit but didn't get close to solving the problem for me
    Chosker

    At this point, you've ruled all 3 of these out as the cause?

    1. Nvidia GeForce Experience...
    2. Gsync
    3. Win10

    Leave a comment:


  • replied
    that helped a bit but didn't get close to solving the problem for me

    Leave a comment:


  • replied
    Lots of posts mention disabling:

    Nvidia GeForce Experience...

    Leave a comment:


  • Editor so slow/unresponsive when Blueprint Windows are open!

    Hey guys,
    i've been working with UE4 for quite a while now and i noticed that the Editor got extremely slow over the last releases. Whenever a window for blueprints is open even medium sized scenes which run with 120 FPS in fullscreen become very slow (less than 30 FPS) as soon as another editor window is open e.g. blueprints window - i work on 3 displays as the same time. This wasn't the case in previous version but it feels like the problem became worse with each release since 4.16 ... If i minimize the windows the FPS instantly goes back up to 120 FPS...

    I have a pretty decent development system with a GTX1080, 64GB RAM, i7 6850k and never had issues like this before. I'm the only one with this problem or are there others who experienced this as well ?
Working...
X