Announcement

Collapse
No announcement yet.

screen resolution scale problem

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    screen resolution scale problem

    Hi everybody,
    i am having a problem using screen resolution scale in my game.
    i am planning to have a function to set the resolution scale to 100 - 200 % and maybe more (for sharper images and to be future safe ;-) )
    if i set resolution scale to 200 % everything is fine, but if i set it again to 100 % the grafics in the viewport arent the same as before i set the game to 200 and back to 100 ...
    its much more blurry in general and looking very odd and i cant get grafic quality back unless i restart the whole engine ...
    anybody nows if this is supposed to happen or is this a known bug ?

    kind regards
    stucki
    www.ofpawnsandkings.de

    #2
    Which is the scalability settings? Does it stay the same all the time? Did you try to enforce the scalability after changing back the scr.res to 100%?

    And just for the sake of curiosity, what do you mean as future safe regarding this?
    Nilson Lima
    Technical Director @ Rigel Studios Ltda - twitter: @RigelStudios
    Join us at Discord: https://discord.gg/FUwTvzr

    UE4 Marketplace: Cloudscape Seasons
    supporting: Community FREE Ocean plugin

    Comment


      #3
      thx for the answer,
      yes scalability settings stay the same... i checked that already ..
      future safe: see how fast grafik cards have evolved in the last years.... i guess this will go on for a while. and if somebody does play the game in maybe 2-3 years. they can play the game with maybe resolution scale of 200 or 300 % that runs now on 100 %. the overall grafics improve a lot (especially on a Full-HD-Display) but even on a 4k display you can notice the difference...

      www.ofpawnsandkings.de

      Comment


        #4
        Ok got it. What I usually do, since I use a GTX1080 is to nerf it: I decrease the main clock -200MHz and memory clock -2000MHz and power limit -50%... so it behave like something faster than GTX 1060 and slower than GTX 1070. I also have R9 380 in one i5 machine if I want something even slower than a good GTX 1060. It works for me.

        Now going back to your issue, is this happening in any scene or just your scene? Id like to try this if it is happening in any scene, so it is just to put r.screenpercentage 200 right?
        Nilson Lima
        Technical Director @ Rigel Studios Ltda - twitter: @RigelStudios
        Join us at Discord: https://discord.gg/FUwTvzr

        UE4 Marketplace: Cloudscape Seasons
        supporting: Community FREE Ocean plugin

        Comment


          #5
          Originally posted by NilsonLima View Post
          Ok got it. What I usually do, since I use a GTX1080 is to nerf it: I decrease the main clock -200MHz and memory clock -2000MHz and power limit -50%... so it behave like something faster than GTX 1060 and slower than GTX 1070. I also have R9 380 in one i5 machine if I want something even slower than a good GTX 1060. It works for me.

          Now going back to your issue, is this happening in any scene or just your scene? Id like to try this if it is happening in any scene, so it is just to put r.screenpercentage 200 right?
          i am working with a gtx 1080 ti and test the game on 4k resolution, if it stays at 40 frames its okay for me. (as its a point & click game i dont need more than 30 fps) guess in 1 year or so when the game is ready for release every "normal" grafic card can play it in 30 fps on 4k ...

          i use a keypress flipflop event in my level blueprint which actuallay toggles r.screenpercentage 200/100,
          but its just the same if i enter it via console.
          after i toggled to 200 percent and stop the game, the game window is getting a little blurry. in game and in editor.
          i can not test a published build right now, cause one of my plugins is giving me an error and aborts publishing ....

          its ue 4.18.2 on an up to date windows 10 machine.
          grafics card nvidia gtx 1080 ti

          kind regards
          stucki


          www.ofpawnsandkings.de

          Comment


            #6
            anybody else experiencing this ?
            www.ofpawnsandkings.de

            Comment


              #7
              I was not able to reproduce it... which is weird... any plugin installed into your system?
              Nilson Lima
              Technical Director @ Rigel Studios Ltda - twitter: @RigelStudios
              Join us at Discord: https://discord.gg/FUwTvzr

              UE4 Marketplace: Cloudscape Seasons
              supporting: Community FREE Ocean plugin

              Comment


                #8
                Originally posted by NilsonLima View Post
                I was not able to reproduce it... which is weird... any plugin installed into your system?
                **** ... i could have thought about this myself .... i have a options menu plugin activated, maybe this is messing with screen resolution .... i will chek this asap ..
                thx for the idea !!
                www.ofpawnsandkings.de

                Comment


                  #9
                  its not the plugin .... tested that ...

                  can you please set the following engine scalability settings:

                  resolution scale 100 %
                  view distance: Near
                  Anti Aliasing: High
                  Post Processing: Epic
                  Shadows: Cinematic
                  Textures: High
                  Effects: High
                  Foilage: High

                  and with this setting switch between 200 % and 100% screen resolution in game
                  thx again !

                  kind regards
                  stucki



                  www.ofpawnsandkings.de

                  Comment


                    #10
                    Confirmed that the issue is not happening here, after stopping I checked the scalability settings and they stay the same, the switch I just did a Key B pressed to flipflop the screen resolution between 200 and 100 as you said, also I was using console command. I got a GTX1080 with latest drivers here.
                    Last edited by NilsonLima; 01-16-2018, 10:57 AM.
                    Nilson Lima
                    Technical Director @ Rigel Studios Ltda - twitter: @RigelStudios
                    Join us at Discord: https://discord.gg/FUwTvzr

                    UE4 Marketplace: Cloudscape Seasons
                    supporting: Community FREE Ocean plugin

                    Comment


                      #11
                      I think I will repeat the test in 4K, it was just this missing I think.
                      Nilson Lima
                      Technical Director @ Rigel Studios Ltda - twitter: @RigelStudios
                      Join us at Discord: https://discord.gg/FUwTvzr

                      UE4 Marketplace: Cloudscape Seasons
                      supporting: Community FREE Ocean plugin

                      Comment


                        #12
                        Yep, no issue, played in viewport, in pie and as standalone, went to 200%, then 100%, back to editor and all is fine.
                        Nilson Lima
                        Technical Director @ Rigel Studios Ltda - twitter: @RigelStudios
                        Join us at Discord: https://discord.gg/FUwTvzr

                        UE4 Marketplace: Cloudscape Seasons
                        supporting: Community FREE Ocean plugin

                        Comment


                          #13
                          thx again for the testing .... crazy thing this is ....
                          could it be because its a project started someday in UE 4.10 or so and carried over and over to 4.18.2 ? ...
                          have to test it in a blank new project .... with ue.18.2
                          kind regards

                          stucki
                          www.ofpawnsandkings.de

                          Comment


                            #14
                            I was thinking... the only thing left that might differ are options set into config.ini... we got few possibilities... make both equal or delete them and check with defaults which is the behavior we get. What do you think?

                            Edit: other thing that might help is delete the intermediate folder and after deleting the config.ini, restart the editor.
                            Last edited by NilsonLima; 01-16-2018, 12:08 PM.
                            Nilson Lima
                            Technical Director @ Rigel Studios Ltda - twitter: @RigelStudios
                            Join us at Discord: https://discord.gg/FUwTvzr

                            UE4 Marketplace: Cloudscape Seasons
                            supporting: Community FREE Ocean plugin

                            Comment


                              #15
                              Originally posted by stucki View Post
                              its not the plugin .... tested that ...

                              can you please set the following engine scalability settings:

                              resolution scale 100 %
                              view distance: Near
                              Anti Aliasing: High
                              Post Processing: Epic
                              Shadows: Cinematic
                              Textures: High
                              Effects: High
                              Foilage: High

                              and with this setting switch between 200 % and 100% screen resolution in game
                              thx again !

                              kind regards
                              stucki


                              It is the plug in. I just started having issues with it also, and came here also looking. If you click fullscreen, and save apply.
                              Things go screwy. i even re opened the omk widget bp from the mega. I emailed him before, and hes been quick to issue fixes, patches. etc.
                              Even in the main project.

                              Comment

                              Working...
                              X