Announcement

Collapse
No announcement yet.

Why is Undo so terrible?

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    #31
    Originally posted by Tisanim View Post
    Preview 3 also isn't any different. Can't undo material instance changes. It can't be just me?? Worried.

    ‚Äč
    You're not alone, I've noticed today on 4.24 p4 undoing material instance parameters gives only message, but numbers and effect in viewport remain unchanged

    Comment


      #32
      Originally posted by tonpix View Post

      You're not alone, I've noticed today on 4.24 p4 undoing material instance parameters gives only message, but numbers and effect in viewport remain unchanged
      Sweeeet effin jesus. Thanks for posting. The bug report person tried to help but gave up since, he couldn't replicate it.

      Do you have any ideas to try? As a last measure, if the final release has the same issue, I'm planning to *clean* install the engine. Simple reinstall didn't work though.

      Comment


        #33
        Undo is problematic in mostly softwares, because you must register 100% of the data changed to it works corretctly, which usually is done via objects, which will consume tons of memory, and then to optmize it, shortcuts are made which turns the undo system laggy, buggy and risk your whole software archteture.

        Would be safer at each modification the Undo write an duplicate version at disk, with properly identification to the history state. But depending of the operation it would turn your harddrive in a RAM

        Comment


          #34
          Originally posted by ClavosTech
          There's no revert to disk.... That's the biggest issue imo.
          There is:
          Right click the asset > Asset Actions > Reload

          Also i Suggest Always you changed a parent blueprint which affects many children blueprint, to Right Click the folder, and RESAVE ALL
          I already had corrupted many assets by not doing that, because the parent class got changed and the children assets didnt saved, just the parent

          Comment


            #35
            Missed that... It wasn't always there iirc. Thanks Krakhat!

            Comment


              #36
              Shiny 4.24

              But.. I... can't....un....do. What..the...he...ck. Send..chocolates...to my ...grave.

              Gaaah. I don't even know if *clean install* is the solution.

              Comment


                #37
                UPDATE: Received another email from bug report help, now, he indeed can reproduce this and has logged it. https://issues.unrealengine.com/issue/UE-85711 (Why the "related to" link has been removed from the post?)

                Also I don't get why tonpix and I are the only ones affected???




                Comment


                  #38
                  I figured out something interesting with undo so I hope this helps.

                  When you do something and you try to undo and you get that symbol in the bottom right that basically says nothing to undo, just create another node or anything really. Then press undo twice and it will undo the first mistake. This works for me 99% of the time. Idk about 4.24 though but just in general on older engine versions, i have to use this trick.

                  Comment


                    #39
                    Thank you TheNebelung. Here the issue is that the message at bottom right, says the undo has reverted the values but the values don't change in the "instance" parameter. The undo of parameter value inside the material itself works fine. Just the instance parameter undo seems to be not working, which as you can imagine is such a crucial thing.

                    Comment


                      #40
                      My bug report was added to tracker https://issues.unrealengine.com/issue/UE-85711, dunno why your ue4 person couldn't reproduce, maybe she/he thought it was inside material editor? In any case, it got reproduced and tracked, so we can wait for fix.

                      Comment


                        #41
                        Only 6 people seem to have it so far. This simply cannot be a bug in the code. Otherwise everyone would have had this and no one can work with this.

                        What could it be? Our system hardware? Windows corruption? Some divers?

                        As I've mentioned I've tried reinstalling 4.24 also. Could removing all versions and removing all epic related folders etc. and then reinstalling help??

                        Comment


                          #42
                          I also have this.
                          Now: Unreal Engine 4.24.1 (Upgraded project from 4.23)
                          Windows 10, 16gb ram, i7, gtx1060.

                          Comment


                            #43
                            " When you do something and you try to undo and you get that symbol in the bottom right that basically says nothing to undo, just create another node or anything really ", TY I'll keep that in mind, but what the heck is going on with UNDO ? Should it matter when you save, can't there be a global undo cache or however said system 'works', to avoid losing entire edits to lacking undo?

                            Is UE4 the only app void of an effective undo system ?
                            Man,I hope so, as working diligently ,focused,its very difficult or should we have to, to work without worry of the undo system leaving our artwork in the cold with no undo.
                            Solo but Seismic - feel free to apply
                            https://neighborlee1.wixsite.com/theheartseed

                            Comment


                              #44
                              Originally posted by Squall_dk View Post
                              Completely agree. our team all has this horrific bug. It's especially annoying when you delete something you can't bring back!
                              THIS!, or can't bring back prior 'sculpt' after a fair amount of work. For such a modern engine, this is insane. Maybe sculpting 'after save'can't be undone, but if true I guess the undo system was put in place in the context of those using it, would USE SVN or such ? Till addressed and maybe that was the intent, I'll just finally get around to plastic and hopefully avoid issues going forward, and backing up with some regularity.
                              Last edited by neighborlee; 01-07-2020, 06:55 PM.
                              Solo but Seismic - feel free to apply
                              https://neighborlee1.wixsite.com/theheartseed

                              Comment


                                #45
                                Hey folks - the bug that Tisanim reported should be fixed in the next hotfix. Stay tuned!

                                Comment

                                Working...
                                X