Announcement

Collapse
No announcement yet.

Very poor performance in the editor using multiple monitors

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Very poor performance in the editor using multiple monitors

    It drops below 10fps and becomes unusable, the interface lags so badly I struggle to click on things.

    I've been working with 3 or 4 monitors ever since I started using unreal back at version 4.8. I have the main editor window and viewport in the centre screen, the content browser, details panel, viewport 2 and levels window all on my left monitor and blueprints or sequencer on the right monitor. Sometimes I even use my 50" TV as an extra screen and this is the perfect setup for me. I'm constantly working on all screens without a problem up until recently when windows 10 updated. I'm not sure if this was the cause or not, but it started happening around the same time.

    If I type 'stat gpu' in the editor it says slate is taking up anything between 0-200ms but as soon as I close all the extra windows and just have the main window it drops to 0.6ms, so I'm guessing it has something to do with the interface rendering. It's really inconsistent though and seems fine occasionally, then suddenly everything is at 5fps again. Then it'll start doing it even if I only have 1 window open until I restart the editor

    So far I've tried reinstalling the engine, updating all my drivers, even reinstalling windows and all my software. I searched the forums and answerhub and have seen a few others reporting something similar, and there's even a report here: https://issues.unrealengine.com/issue/UE-41678 and here: https://issues.unrealengine.com/issue/UE-37659. I've tried running in DX12 like was suggested in one answerhub post, and pretty much everything else that I read.

    Currently using 4.17.2 but I tried creating a blank project in 4.18 and it even happens there. I've lost 3 days work to this (game dev is my job and I'm gonna miss deadlines now) so need a solution ASAP.

    I understand there is going to be some performance impact having more than one window open but it shouldn't be this huge and never used to be a problem. Currently performance is all over the place no matter how many windows I have open

    As this is a known issue with the engine and has been for some time it needs to be fixed NOW.

    Setup: GTX 1080, i7 and 16gb ram, windows 10 running all latest drivers and updates.


    edit: I've tried disconnecting all monitors apart from 1. If I open 2 separate windows on the same monitor it's still just as bad.
    Last edited by Cosmik-Debris; 12-12-2017, 05:37 PM.

    #2
    I have the same issue, both at work and at home
    for me the editor can drop down to 2fps. also once I reach this slow state (10 fps or less) pretty much anything I click freezes the editor for 1-5 seconds

    as you stated in your last comment I don't think it's about the amount of monitors, but simply the amount of windows that are open
    also the more complex the main viewport scene is, the more loss I seem to get out of other open windows
    Follow me on Twitter!
    Developer of Elium - Prison Escape
    Local Image-Based Lighting for UE4

    Comment


      #3
      Have you guys tried disabling the option to reduce performance when in background? I forget the exact setting name, but it's something along those lines. Another thing I've noticed, even on a single monitor, I end up having to dock all windows because my performance tanks astronomically if they aren't docked. It could be some kind of similar issue to that. Try putting everything on one monitor and open a few tabs that aren't docked to the main editor window. See if it causes the same FPS drop for you.

      Comment


        #4
        Yeah I tried the reduce performance in background thing, it makes no difference.

        If everything is docked to the main window then performance is a lot better, but this kinda defeats the point in having multiple monitors! I've been using 3 or 4 monitors for ages with 3 or 4 tabs that aren't docked and while performance took a hit it wasn't very noticeable. Now all of a sudden unreal hates me and won't let me have more than one window without it lagging like crazy, not sure what happened

        Comment


          #5
          'm constantly working on all screens without a problem up until recently when windows 10 updated.
          The 'smoking gun' maybe...???

          Comment


            #6
            Originally posted by franktech View Post
            The 'smoking gun' maybe...???
            Quite possibly, it's as if I'm running ccminer in the background lol.

            Comment


              #7
              Originally posted by bishop86 View Post
              Yeah I tried the reduce performance in background thing, it makes no difference.

              If everything is docked to the main window then performance is a lot better, but this kinda defeats the point in having multiple monitors! I've been using 3 or 4 monitors for ages with 3 or 4 tabs that aren't docked and while performance took a hit it wasn't very noticeable. Now all of a sudden unreal hates me and won't let me have more than one window without it lagging like crazy, not sure what happened
              Yeah, that's what I thought. I've been so used to only working on one monitor that it doesn't bother me, but it would be nice to expand stuff across a couple. I'm not sure if it's an Unreal issue or if it's a windows v. gfx driver issue, but it's annoying as hell.

              Comment


                #8
                I remember reading somewhere that having the viewport set to realtime made the whole editor to redraw. Maybe disabling the realtime preview helps a bit.
                0xAFBF
                https://github.com/0xafbf

                Comment


                  #9
                  Originally posted by BoteRock View Post
                  I remember reading somewhere that having the viewport set to realtime made the whole editor to redraw. Maybe disabling the realtime preview helps a bit.
                  Hey, thanks for the idea but I already tried this and it doesn't really help

                  Comment


                    #10
                    I think you need to disable Lower CPU usage while in background, in the Editor Settings.

                    Comment


                      #11
                      Originally posted by Moddingear View Post
                      I think you need to disable Lower CPU usage while in background, in the Editor Settings.
                      look at the replies above, that was already suggested and discarded. it doesn't improve at all
                      Follow me on Twitter!
                      Developer of Elium - Prison Escape
                      Local Image-Based Lighting for UE4

                      Comment


                        #12
                        I only had this issue when one of the monitors was controlled by a much weaker gpu or directly trough mobo.
                        running 2 4k, 1 2k, and a graphics tablet on 1080p without any hitches on a 1080ti now, so your setup on a 1080 should run fairly well.
                        Id blame win10 partly for that.

                        Comment


                          #13
                          Originally posted by Luos View Post
                          I only had this issue when one of the monitors was controlled by a much weaker gpu or directly trough mobo.
                          running 2 4k, 1 2k, and a graphics tablet on 1080p without any hitches on a 1080ti now, so your setup on a 1080 should run fairly well.
                          Id blame win10 partly for that.
                          Like I said, it's happening even on single display setups as well. With just the editor and a material window open, if the material window isn't docked to the main frame, BOTH viewports will tank to like 1/10th the frame rate they should be. Even on an empty scene and blank material, with gfx set to low, it will do this. As soon as I dock the material window, the frame rate jumps right back up.

                          EDIT: Oh and it will do this with blueprints and any other new window. It's not just materials...

                          Comment


                            #14
                            Originally posted by IronicParadox View Post

                            Like I said, it's happening even on single display setups as well. With just the editor and a material window open, if the material window isn't docked to the main frame, BOTH viewports will tank to like 1/10th the frame rate they should be. Even on an empty scene and blank material, with gfx set to low, it will do this. As soon as I dock the material window, the frame rate jumps right back up.

                            EDIT: Oh and it will do this with blueprints and any other new window. It's not just materials...
                            Exactly the same here, even with one monitor. I'm pretty sure a blank project with a gtx 1080 should be getting more than 10fps when I open 2 windows! It's weird how my pc can handle anything I throw at it, Doom ultra settings at 1440p is 140 fps for example but the UI in ue4 takes 200ms to render. I'm completely baffled! Hopefully someone will come along with a simple solution and make me look stupid!

                            EDIT: another weird thing: Even if I close the extra windows sometimes the engine gets stuck at 10fps until I restart it...

                            EDIT 2: restarting the editor no longer fixes it... getting 7fps and serious lag whenever I open any asset/bp.... someone pleeeease help I don't think I can face working on just one monitor

                            EDIT 3: Just done some tests on my Alienware laptop (GTX 1080) and even in a super complex scene I can open up a huge BP in a new window and only lose 2fps... this is the performance we should be getting, everything is super smooth. Not sure why it's ok on the laptop and not the PC?
                            Last edited by Cosmik-Debris; 12-14-2017, 07:19 PM.

                            Comment


                              #15
                              Originally posted by bishop86 View Post
                              EDIT 3: Just done some tests on my Alienware laptop (GTX 1080) and even in a super complex scene I can open up a huge BP in a new window and only lose 2fps... this is the performance we should be getting, everything is super smooth. Not sure why it's ok on the laptop and not the PC?
                              I'm on a laptop and have the issues. I've tested a million different things like windows power profiles, core unparking, regedit'ing the "RequireSignedAppInit" for nvidia optimus(have to do it for some 3d apps/games to make sure it forces the nvida card and not the intel), xbox dvr **** disabled, nvidia power settings, etc. Nothing fixes it.

                              If it's any help for debugging this problem, this laptop was upgraded from windows 7 to 10 and wasn't a fresh install. That's about the only thing

                              Comment

                              Working...
                              X