Announcement

Collapse
No announcement yet.

My Feedback - Performance - Why I'll be staying with Unity for the time being.

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

    My Feedback - Performance - Why I'll be staying with Unity for the time being.

    So I subscribed to Unreal and downloaded it, and loved it.

    Literally loved everything about it, and I prefer it to Unity in every way. Unfortunately, the only thing that is stopping me is the heavy hardware requirements. Everything runs perfectly on my specced out PC, but UE4 seems to have a vengeance against integrated graphics cards. It wont run at all on my 2013 MBP (Intel HD 3000), or my Windows Laptop (Intel HD 4000). Both of these are capable of running some pretty graphically demanding games (you'd be surprised how good these Intel HD GPU's are). On my Windows laptop, I can launch UE4, but even the Tappy Chicken demo is unplayable, and a blank project is just as bad. On my MBP, UE4 wont even load up! (Just for clarity's sake, the CPU and memory usage are not the problem, they both meet the requirements).

    Unfortunately, I just can't justify locking myself in a room for hours and so my laptops are my go to systems for the most part. They both run Unity perfectly, and this, and only this, is why I'm sticking to Unity for the time being.

    I know I'm probably not the target market for Epic for the most part, but are there any plans to improve performance on lower end systems?

    Thanks
    Last edited by MCam; 03-26-2014, 07:21 AM.

    #2
    I was having a similar problem even with a really nice video card. It was actually fine at lower resolutions but at 2560x1600 my frame rate was awful. I ended up buying a Geforce 770 and my performance greatly improved.
    Crystal Flux a Snowboarding Shooter:https://twitter.com/GadzGamz
    Pinball Template:http://www.pinterest.com/gadzgamz/pinball-template/
    Hot Springs Air Hockey: Hot Springs
    Latest release: Bonsai Golf Coral

    Comment


      #3
      Originally posted by RyanGadz View Post
      I was having a similar problem even with a really nice video card. It was actually fine at lower resolutions but at 2560x1600 my frame rate was awful. I ended up buying a Geforce 770 and my performance greatly improved.
      That's not really an option for laptops though

      Comment


        #4
        If you wanted to upgrade to the new laptops with Geforce 8xx series I think you could get a decent framerate. That new Razer Blade looks amazing!
        Crystal Flux a Snowboarding Shooter:https://twitter.com/GadzGamz
        Pinball Template:http://www.pinterest.com/gadzgamz/pinball-template/
        Hot Springs Air Hockey: Hot Springs
        Latest release: Bonsai Golf Coral

        Comment


          #5
          Originally posted by RyanGadz View Post
          If you wanted to upgrade to the new laptops with Geforce 8xx series I think you could get a decent framerate. That new Razer Blade looks amazing!
          I wanted to try Unreal though because it's cheaper than Unity Pro. Unity Pro would be cheaper than Unreal + New Laptop

          I just wanted to know if the hardware requirement is something that may change in the future. I don't want to buy new hardware, because quite frankly I can't afford it at this moment in time.

          Comment


            #6
            a couple things to try:

            decrease size of the preview window
            bake the lighting

            other than that I have not found any settings that dramatically increase framerate.
            Crystal Flux a Snowboarding Shooter:https://twitter.com/GadzGamz
            Pinball Template:http://www.pinterest.com/gadzgamz/pinball-template/
            Hot Springs Air Hockey: Hot Springs
            Latest release: Bonsai Golf Coral

            Comment


              #7
              One thing I did notice, is when you open up a menu (e.g show) from the preview window, my FPS sky rockets because the preview window gets paused. Makes me wonder if we can't just have a "pause" option for the preview pane, at least then I could work on blueprints etc, and save the pretty stuff for when I'm back on my desktop.

              Comment


                #8
                Oh try "engine scalability settings" in Quick Settings that helps a lot too
                Crystal Flux a Snowboarding Shooter:https://twitter.com/GadzGamz
                Pinball Template:http://www.pinterest.com/gadzgamz/pinball-template/
                Hot Springs Air Hockey: Hot Springs
                Latest release: Bonsai Golf Coral

                Comment


                  #9
                  Originally posted by MCam View Post
                  Makes me wonder if we can't just have a "pause" option for the preview pane.
                  There is a 'Realtime' option in the menu in the top-left corner of the viewport that lets you turn off constant rendering.
                  Lead Programmer - UE4 Animation/Physics/Audio Team - Epic Games
                  Twitter: @EpicJamesG

                  Comment


                    #10
                    I use a Razor 14" as my personal laptop. I find it to be the perfect balance for Gaming, Content Creation, and battery life.

                    Comment


                      #11
                      Originally posted by JamesG View Post
                      There is a 'Realtime' option in the menu in the top-left corner of the viewport that lets you turn off constant rendering.
                      Unchecking 'Realtime' did help a bit. It let me navigate around a bit more freely at least. Thank you for that.

                      Originally posted by Paul Oliver View Post
                      I use a Razor 14" as my personal laptop. I find it to be the perfect balance for Gaming, Content Creation, and battery life.
                      I'd love to get a Razor, but I'm getting married next year so not allowed to spend much money


                      Is it likely that UE4 will be a bit more friendly to lower end machines in the future, or is this just the way it is?

                      Comment


                        #12
                        Originally posted by JamesG View Post
                        There is a 'Realtime' option in the menu in the top-left corner of the viewport that lets you turn off constant rendering.
                        I posted about this and found this actually increases CPU usage in OSX, so I don't think this a universal solution (although it should be in theory).

                        Originally posted by Paul Oliver View Post
                        I use a Razor 14" as my personal laptop. I find it to be the perfect balance for Gaming, Content Creation, and battery life.
                        Can you tell me what your idle CPU usage is? On my 2013 Macbook Air (in OSX) UE4 Editor will drain my battery in just over 1 hour (and I can get up to ~8 hours of dev time in Unity).

                        Comment


                          #13
                          Originally posted by bleeds187 View Post
                          Can you tell me what your idle CPU usage is? On my 2013 Macbook Air (in OSX) UE4 Editor will drain my battery in just over 1 hour (and I can get up to ~8 hours of dev time in Unity).
                          I can't even get the editor to load on my Macbook Pro

                          Comment


                            #14
                            Thats strange, it runs fine on my Air (Haswell GPU makes up the difference I guess), it just consumes the battery way too fast and causes the CPU/GPU to produce a ton of heat.

                            Comment


                              #15
                              Hi Folks,

                              I believe this: https://www.unrealengine.com/blog/ho...video-settings may help some of you get better performance on your laptop

                              Comment

                              Working...
                              X