Announcement

Collapse
No announcement yet.

A problem about struct in UE 4.12.5

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    [BLUEPRINT] A problem about struct in UE 4.12.5

    Above all, I have to tell you, I am Chinese ,and I am a middle-school student , so my English is poor,I do beg you pardon.

    Yesterday I meet a big problem.My project was completed , and I packaged it successfull.
    When I test my packaged game , I founded a bug , so I backed to my project to fix it.

    It was a little bug. In order to fix it , I had to change the default value of a variable in a struct.
    After my changing, I tried to package my project again, but no matter how many times I try , it failed.The error code was always 25 (unkown error).
    I tried to find where has problem, but I failed. After two hours' work , I felt so annoyed.

    I decided to change the default value of the variable in a struct back to the bug version. But the problem still happened.
    Then , I read the white message in the message diary, and found there were lots of complied errors.All of the errors were about the struct I changed.
    I started to search the root cause. At last I found that when I change the default value and save it , it is not only save the struct,but save lots of other blueprints.

    Click image for larger version

Name:	QQ图片20170528210501.png
Views:	1
Size:	14.4 KB
ID:	1221031

    I realised that those blueprints are all relate to the struct I changed.
    So I opened one of them, and I found the problem: the blueprint was no compiler!!!

    I undesood: when I change the default value of a variable in a struct, I have to recompile all the blueprints relate to the struct.
    That is the problem I am telling you. I suggest , when the user change the default value of a variable in a struct , the editor will make a list of the blueprints have the struct,and allow the user to recompile them in one key.

    What's more, please let the complie error message in the message become red, it is a big error!

    That'all. Thank you for reading.
    Last edited by t64744901; 05-29-2017, 12:02 AM.
Working...
X